Bug 488736 - "Adaptive" opacity mode does not work anymore
Summary: "Adaptive" opacity mode does not work anymore
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Plasma
Component: Panel (show other bugs)
Version: 6.1.0
Platform: Arch Linux Linux
: HI normal
Target Milestone: 1.0
Assignee: Plasma Bugs List
URL:
Keywords: regression
: 487227 488797 488811 488834 488867 (view as bug list)
Depends on:
Blocks:
 
Reported: 2024-06-19 13:41 UTC by Hanabishi
Modified: 2024-06-27 08:06 UTC (History)
9 users (show)

See Also:
Latest Commit:
Version Fixed In: 6.1.1
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hanabishi 2024-06-19 13:41:30 UTC
SUMMARY

In 6.1.0, "Adaptive" opacity mode does not work. The panel always remains transparent as in "Translucent" mode.

STEPS TO REPRODUCE
1. Set "Panel Configuration > Opacity > Adaptive".
2. Maximize any window.

OBSERVED RESULT

The panel always remains transparent.

EXPECTED RESULT

The panel should became opaque.

SOFTWARE/OS VERSIONS

KDE Plasma Version: 6.1.0
KDE Frameworks Version: 6.3.0
Qt Version: 6.7.1

ADDITIONAL INFORMATION

Wayland session.
Comment 1 Nate Graham 2024-06-19 19:56:45 UTC
Is the panel at the top screen edge?

Does the issue reproduce in a new clean user account on the same machine?
Comment 2 Hanabishi 2024-06-19 20:14:24 UTC
(In reply to Nate Graham from comment #1)
> Is the panel at the top screen edge?
> 
> Does the issue reproduce in a new clean user account on the same machine?

Yes. I tested it on a fresh user account to exclude configuration issues.
Comment 3 Nate Graham 2024-06-20 14:27:13 UTC
Thanks. What GPU are you using?
Comment 4 Hanabishi 2024-06-20 15:01:54 UTC
(In reply to Nate Graham from comment #3)
> Thanks. What GPU are you using?

OpenGL core profile renderer: AMD Radeon RX 580 Series (radeonsi, polaris10, LLVM 17.0.6, DRM 3.57, 6.10.0-rc4)
OpenGL core profile version: 4.6 (Core Profile) Mesa 24.1.2-arch1.1

Btw, switching to software rendering does not change the behavior. So I don't think this is a rendering issue.
Comment 5 Fushan Wen 2024-06-20 15:59:22 UTC
*** Bug 488797 has been marked as a duplicate of this bug. ***
Comment 7 Nate Graham 2024-06-20 16:23:14 UTC
*** Bug 487227 has been marked as a duplicate of this bug. ***
Comment 8 Bug Janitor Service 2024-06-20 17:23:09 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/plasma-desktop/-/merge_requests/2324
Comment 9 Nate Graham 2024-06-20 18:28:59 UTC
*** Bug 488811 has been marked as a duplicate of this bug. ***
Comment 10 cwo 2024-06-20 21:48:42 UTC
*** Bug 488834 has been marked as a duplicate of this bug. ***
Comment 11 filip.kendes1 2024-06-21 06:34:09 UTC
*** Bug 488867 has been marked as a duplicate of this bug. ***
Comment 12 tromzy 2024-06-21 08:49:18 UTC
I can confirm this bug.

OS : Arch Linux 
KDE Plasma : 6.1.0
KDE Frameworks : 6.3.0
Qt : 6.7.1

Wayland
Comment 13 Miren Radia 2024-06-21 08:57:03 UTC
I also have the same problem for my top non-floating panel. This isn't a problem for my bottom, always visible, floating panel.

Here are my software version:
Operating System: Fedora Linux 40
KDE Plasma Version: 6.1.0
KDE Frameworks Version: 6.3.0
Qt Version: 6.7.1
Kernel Version: 6.9.4-200.fc40.x86_64 (64-bit)
Graphics Platform: Wayland
Processors: 16 × 12th Gen Intel® Core™ i7-1260P
Memory: 31.1 GiB of RAM
Graphics Processor: Mesa Intel® Graphics
Manufacturer: Framework
Product Name: Laptop (12th Gen Intel Core)
System Version: A6
Comment 14 Fushan Wen 2024-06-22 01:00:54 UTC
Git commit 08637d603162f2ac595ff904c4a97aef386e7897 by Fushan Wen.
Committed on 22/06/2024 at 01:00.
Pushed by fusionfuture into branch 'master'.

Panel: fix adaptive opacity not reacting to maximized windows

The mode "TaskManager.RegionFilterMode.Intersect" checks if two regions
overlap, so the additional +1 is required.
FIXED-IN: 6.1.1

M  +1    -1    desktoppackage/contents/views/Panel.qml

https://invent.kde.org/plasma/plasma-desktop/-/commit/08637d603162f2ac595ff904c4a97aef386e7897
Comment 15 Fushan Wen 2024-06-22 01:02:15 UTC
Git commit dc62acf008ef0a48f00d57f6d163663a73edff7d by Fushan Wen.
Committed on 22/06/2024 at 01:01.
Pushed by fusionfuture into branch 'Plasma/6.1'.

Panel: fix adaptive opacity not reacting to maximized windows

The mode "TaskManager.RegionFilterMode.Intersect" checks if two regions
overlap, so the additional +1 is required.
FIXED-IN: 6.1.1


(cherry picked from commit 08637d603162f2ac595ff904c4a97aef386e7897)

Co-authored-by: Fushan Wen <qydwhotmail@gmail.com>

M  +1    -1    desktoppackage/contents/views/Panel.qml

https://invent.kde.org/plasma/plasma-desktop/-/commit/dc62acf008ef0a48f00d57f6d163663a73edff7d
Comment 16 Fushan Wen 2024-06-22 01:11:52 UTC
Git commit d65f5b04775df2eb0a3c8a4133584d4449025f08 by Fushan Wen.
Committed on 22/06/2024 at 01:01.
Pushed by fusionfuture into branch 'master'.

appiumtests: test adaptive panel opacity

1. Open a maximized window
2. Take screenshot
3. Close the window
4. Take another screenshot
5. Compare the panel background colors

M  +6    -0    appiumtests/desktop/CMakeLists.txt
A  +172  -0    appiumtests/desktop/bug488736_adaptive_opacity.py

https://invent.kde.org/plasma/plasma-desktop/-/commit/d65f5b04775df2eb0a3c8a4133584d4449025f08
Comment 17 Dilam 2024-06-27 08:06:41 UTC
I can confirm the fix.

Operating System: KDE neon 6.0
KDE Plasma Version: 6.1.1
KDE Frameworks Version: 6.3.0
Qt Version: 6.7.0
Kernel Version: 6.5.0-41-generic (64-bit)
Graphics Platform: Wayland