Bug 485223 - Traditional Task Manager overflows space right of itself in multi row mode
Summary: Traditional Task Manager overflows space right of itself in multi row mode
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Plasma
Component: Task Manager and Icons-Only Task Manager (show other bugs)
Version: 6.0.3
Platform: Other Linux
: NOR normal
Target Milestone: 1.0
Assignee: Plasma Bugs List
URL:
Keywords: regression
: 468195 483641 485459 (view as bug list)
Depends on:
Blocks:
 
Reported: 2024-04-08 10:17 UTC by Dirk Stoecker
Modified: 2024-05-12 05:10 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In: 6.1


Attachments
Image showing the issue and System info as well as first config page (790.57 KB, image/png)
2024-04-08 10:17 UTC, Dirk Stoecker
Details
panel with two widgets (178.90 KB, image/png)
2024-04-15 19:05 UTC, bugs_kde_org
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dirk Stoecker 2024-04-08 10:17:48 UTC
Created attachment 168284 [details]
Image showing the issue and System info as well as first config page

The Plasma Task Manager flows behind elements in the right behind it as soon as it switches to multi-column mode. Works ok with a single column.

STEPS TO REPRODUCE
1. Install Task Manager Widget with other widgets behind
2. Set: Use multi-row view: When Panel is low on space and thick enough (or Always when Panel is thick enough
3. Open enough windows

OBSERVED RESULT

1) Overflows

2) The Starters take too much space (full windows size instead of short for each of them.

EXPECTED RESULT

Keeps to its own space

SOFTWARE/OS VERSIONS

Linux/KDE Plasma:  openSUSE Tumbleweed / 
(available in About System)
KDE Plasma Version: 6.0.3
KDE Frameworks Version:  6.0.0
Qt Version: 6.6.3

ADDITIONAL INFORMATION

Wayland Mode Kernel 6.8.1
Comment 1 Nate Graham 2024-04-08 21:12:53 UTC
Seems similar to Bug 482926 and Bug 483272.
Comment 2 Nate Graham 2024-04-09 22:05:51 UTC
*** Bug 483518 has been marked as a duplicate of this bug. ***
Comment 3 Nate Graham 2024-04-10 20:13:05 UTC
*** Bug 483641 has been marked as a duplicate of this bug. ***
Comment 4 Nate Graham 2024-04-12 14:24:09 UTC
I can trivially reproduce this anytime a Traditional Task Manager is in multi-row mode on a horizontal panel.
Comment 5 Nate Graham 2024-04-13 14:13:00 UTC
*** Bug 485459 has been marked as a duplicate of this bug. ***
Comment 6 bugs_kde_org 2024-04-15 19:05:46 UTC
Created attachment 168569 [details]
panel with two widgets

When it will be fixed. I can't add more than one widget into panel. Look at screenshot.
Comment 7 Marco Martin 2024-04-16 12:28:52 UTC
There are 2 issues here: 

* the launchers taking the space of a full task item: at the moment it's an architectural thing that will need a bit of a refactor to be able to be changed.
* the taskbar overflowing its allowed space: this takes the priority for now as is a bug also within the current architecture
Comment 8 bugs_kde_org 2024-04-16 12:53:16 UTC
Ok, so I see it's bigger problem.
Is it chance to estimate when it will be fixed? Days, weeks, months?
Comment 9 Bug Janitor Service 2024-04-16 15:32:40 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/plasma-desktop/-/merge_requests/2209
Comment 10 bugs_kde_org 2024-04-16 15:40:49 UTC
It's great news :), but if I understand well, it's temporary solution? I hope it will be works.
"In the long term the custom layouting code should be removed and be ported to
a standard GridLayout"
Comment 11 Marco Martin 2024-04-23 07:49:03 UTC
Git commit 0c576c940b1db0433a7e9b3dd0248948ed5f9368 by Marco Martin.
Committed on 23/04/2024 at 07:32.
Pushed by mart into branch 'master'.

On multiline launchers are often as wide as tasks

Since on multiline launchers are often as big as tasks,
don't remove launchers count from the task count when we're on multiline
It's only a partial solution and tasks won't always be optimally wide,
but is a simple one that can be cherrypicked to 6.0

In the long term the custom layouting code should be removed and be ported to
a standard GridLayout

M  +9    -0    applets/taskmanager/package/contents/ui/code/layout.js

https://invent.kde.org/plasma/plasma-desktop/-/commit/0c576c940b1db0433a7e9b3dd0248948ed5f9368
Comment 12 Bug Janitor Service 2024-04-23 07:49:34 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/plasma-desktop/-/merge_requests/2219
Comment 13 Marco Martin 2024-04-24 07:42:50 UTC
Git commit 9ad41c26e0bbe57b7c19883fc5db772613a5d6ca by Marco Martin.
Committed on 24/04/2024 at 07:37.
Pushed by mart into branch 'Plasma/6.0'.

On multiline launchers are often as wide as tasks

Since on multiline launchers are often as big as tasks,
don't remove launchers count from the task count when we're on multiline
It's only a partial solution and tasks won't always be optimally wide,
but is a simple one that can be cherrypicked to 6.0

In the long term the custom layouting code should be removed and be ported to
a standard GridLayout


(cherry picked from commit 0c576c940b1db0433a7e9b3dd0248948ed5f9368)

0c576c94 On multiline launchers are often as wide as tasks

M  +9    -0    applets/taskmanager/package/contents/ui/code/layout.js

https://invent.kde.org/plasma/plasma-desktop/-/commit/9ad41c26e0bbe57b7c19883fc5db772613a5d6ca
Comment 14 Marco Martin 2024-05-06 07:50:25 UTC
Git commit d1b33d1a9dc872e9a2af042152d6ab5ed2617e4e by Marco Martin.
Committed on 06/05/2024 at 07:50.
Pushed by mart into branch 'master'.

Use a GridLayout for taskbar layout

The current javascript layout code is very buggy and error prone,
The normal layouting mechanism of GridLayout is much more reliable
and does for faster and more readable code
Related: bug 424055

M  +2    -2    applets/taskmanager/package/contents/ui/ContextMenu.qml
M  +4    -4    applets/taskmanager/package/contents/ui/GroupDialog.qml
M  +1    -17   applets/taskmanager/package/contents/ui/MouseHandler.qml
M  +109  -28   applets/taskmanager/package/contents/ui/Task.qml
M  +28   -14   applets/taskmanager/package/contents/ui/TaskList.qml
D  +0    -246  applets/taskmanager/package/contents/ui/code/layout.js
A  +126  -0    applets/taskmanager/package/contents/ui/code/layoutmetrics.js
M  +51   -49   applets/taskmanager/package/contents/ui/main.qml

https://invent.kde.org/plasma/plasma-desktop/-/commit/d1b33d1a9dc872e9a2af042152d6ab5ed2617e4e
Comment 15 Nate Graham 2024-05-12 05:10:45 UTC
*** Bug 468195 has been marked as a duplicate of this bug. ***