Bug 474298 - No cursor on Wayland in vm(linux guest)
Summary: No cursor on Wayland in vm(linux guest)
Alias: None
Product: kwin
Classification: Plasma
Component: wayland-generic (show other bugs)
Version: git master
Platform: Neon Linux
: NOR major
Target Milestone: ---
Assignee: KWin default assignee
Keywords: qt6
Depends on:
Reported: 2023-09-08 13:17 UTC by Liang Qi
Modified: 2023-11-08 21:52 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:

Output of drm_info (47.94 KB, text/plain)
2023-09-08 13:24 UTC, Liang Qi
Output of "libinput list-devices" (2.16 KB, text/plain)
2023-09-08 13:29 UTC, Liang Qi

Note You need to log in before you can comment on or make changes to this bug.
Description Liang Qi 2023-09-08 13:17:34 UTC
There is no cursor for Plasma Wayland inside a vm

1. Hardware: MacBook Pro 16", 2019
2. Host: macOS 13.5.2, VMWare Fusion 13.0.2, Guest: neon unstable(updated yesterday)
3. Log into Plasma(Wayland)

With touchpad from mbp, there is no cursor for it, but I can see the highlight when it hovers on some items. Tried an external USB mouse, same effect.

Should see a mouse cursor on the vm. It works fine on Plasma(X11).

Linux/KDE Plasma: neon unstable
(available in About System)
KDE Plasma Version: 5.27.80
KDE Frameworks Version: 5.240.0
Qt Version: 6.6.0

I assume it will be same result for VirtualBox on macOS, perhaps also for VirtualBox/VMWare on Linux/Windows.
Comment 1 Liang Qi 2023-09-08 13:24:57 UTC
Created attachment 161509 [details]
Output of drm_info
Comment 2 Liang Qi 2023-09-08 13:29:51 UTC
Created attachment 161511 [details]
Output of "libinput list-devices"
Comment 3 Zamundaaa 2023-09-09 15:15:55 UTC
There haven't been any recent changes around the cursor with the legacy API (which is forced for VMs). Can you please test an image with 5.27 and check if it works there?
Comment 4 Liang Qi 2023-09-09 16:18:03 UTC
Yeah, I tried Neon user edition from https://neon.kde.org/download, it's Plasma 5.27.7 based on Qt 5.15.10, Plasma Wayland, a VMWare vm in my same mbp, the cursor is fine there.
Comment 5 Liang Qi 2023-09-10 10:59:47 UTC
Installed neon unstable on a real machine, the cursor on wayland is fine there.
Comment 6 Zamundaaa 2023-09-10 11:53:48 UTC
To narrow the problem down a bit, please put
into /etc/environment and reboot (in the VM). Is the cursor still invisible with that?
Comment 7 Liang Qi 2023-09-10 14:24:11 UTC
After set KWIN_DRM_NO_AMS=0 in /etc/environment, reboot and log in, the mouse is there, but after a short while, no response from Plasma, kind of frozen, for example, can't type in Konsole, and no reponse when clicking any item.
Comment 8 guimarcalsilva 2023-09-10 21:57:58 UTC
I can confirm there's no cursor on a Wayland session on VirtualBox. KWIN_DRM_NO_AMS=0 does work and there's a cursor when using it, however, the cursor is not themed with the Breeze cursor, but it's a generic one. I couldn't reproduce the unresponsiveness Liang reported.
Comment 9 Prajna Sariputra 2023-11-08 15:49:18 UTC
I remember hitting this issue a few months ago with a Neon Unstable iso running in QEMU/KVM, although I didn't get around to reporting it back then.

I just tried it again with the 20231107-1001 iso, and the cursor seems to work fine in both X11 and Wayland in the VM, so maybe worth a retest?
Comment 10 guimarcalsilva 2023-11-08 20:31:35 UTC
I can confirm this is fixed. I tested on Gnome Boxes and Virtual Box and the Wayland session now has a cursor (Using the Neon Unstable image from Nov. 7th).
Comment 11 Liang Qi 2023-11-08 21:52:28 UTC
Tried https://files.kde.org/neon/images/unstable/20231107-1001/neon-unstable-20231107-1001.iso , the cursor works now.

But upgraded old vm still doesn't work, and https://files.kde.org/neon/images/developer/20230921-1641/neon-developer-20230921-1641.iso is too old, comparing with unstable.