Bug 469691 - Dead keys are not recognized [circumflex (^), diaeresis (")]
Summary: Dead keys are not recognized [circumflex (^), diaeresis (")]
Status: RESOLVED FIXED
Alias: None
Product: krita
Classification: Applications
Component: General (show other bugs)
Version: nightly build (please specify the git hash!)
Platform: Other Linux
: NOR normal
Target Milestone: ---
Assignee: Dmitry Kazakov
URL:
Keywords:
: 475272 (view as bug list)
Depends on:
Blocks:
 
Reported: 2023-05-13 08:41 UTC by grum999
Modified: 2023-12-08 16:21 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description grum999 2023-05-13 08:41:41 UTC
SUMMARY
circumflex (^) and diaeresis (") can't be used anywhere in Krita input field:
- layer name
- file dialog
- document information field
- scripter and any python plugin 
- ...

STEPS TO REPRODUCE
1.  Try to type ^ (0x5e) character in a field 

OBSERVED RESULT
1.  A SPACE (0x20) character is produced

EXPECTED RESULT
1.  A circumflex character is produced


SOFTWARE/OS VERSIONS
Linux/KDE Plasma: KDE Neon 5.27
KDE Plasma Version: 5.27.4
KDE Frameworks Version: 5.105.0
Qt Version: 5.15.9

OS Keyboard configuration: French (alt. latin-9 only)
OS System language: american english
Krita setting:

ADDITIONAL INFORMATION
Workarounf: copy/paste ^ character from Kate or terminal to Krita works (really boring but at least, it works :))

Using appimage on Linux 

Problem occurs for Krita 5.1.5 (e0453bf87f) and Krita 5.2.0 (edb8d52405)

Other softwares works properly on system

I don't think it could be related to OS itself: according to Krita appimage I still have on my computer, I have appimage working and other not

Here's some notable differences about QT and LOCALE from Krita>Help>Show system information for bug report between working and not working appimage

Last working appimage I have
*** (2022-11-26) krita-5.2.0-prealpha-9cb8ac659f-x86_64.appimage => OK, characters can be used ***
> Qt
>  Version (compiled): 5.12.12
>  Version (loaded): 5.12.12
>
>Locale
>  Languages: en_US
>  C locale: LC_CTYPE=en_US.UTF-8;LC_NUMERIC=fr_FR.UTF-8;LC_TIME=fr_FR.UTF-8;LC_COLLATE=en_US.UTF-8;LC_MONETARY=fr_FR.UTF-8;LC_MESSAGES=en_US.UTF-8;LC_PAPER=fr_FR.UTF-8;LC_NAME=fr_FR.UTF-8;LC_ADDRESS=fr_FR.UTF-8;LC_TELEPHONE=fr_FR.UTF-8;LC_MEASUREMENT=fr_FR.UTF-8;LC_IDENTIFICATION=fr_FR.UTF-8
>  QLocale current: en
>  QLocale system: en
>  QTextCodec for locale: UTF-8

First non-working appimage I have
***  (2023-02-24) krita-5.2.0-prealpha-d01231403e-x86_64.appimage => KO, characters can't be used ***
> Qt
>  Version (compiled): 5.15.7
>  Version (loaded): 5.15.7
>
>Locale
>  Languages: en_US, en, en_Latn_US
>  C locale: LC_CTYPE=en_US.UTF-8;LC_NUMERIC=fr_FR.UTF-8;LC_TIME=fr_FR.UTF-8;LC_COLLATE=en_US.UTF-8;LC_MONETARY=fr_FR.UTF-8;LC_MESSAGES=en_US.UTF-8;LC_PAPER=fr_FR.UTF-8;LC_NAME=fr_FR.UTF-8;LC_ADDRESS=fr_FR.UTF-8;LC_TELEPHONE=fr_FR.UTF-8;LC_MEASUREMENT=fr_FR.UTF-8;LC_IDENTIFICATION=fr_FR.UTF-8
>  QLocale current: en
>  QLocale system: en
>  QTextCodec for locale: UTF-8
Comment 1 Halla Rempt 2023-06-21 11:21:29 UTC
I can confirm the issue, but I suspect it's a problem caused by the upgrade from Qt 5.12 to 5.15. It also sounds similar to https://bugs.kde.org/show_bug.cgi?id=468566
Comment 2 grum999 2023-06-21 16:37:49 UTC
Yes I think it's a Qt thing too, I tried to compile Krita to check if the problem occurs with Qt version installed on my system (then not the one embedded in appimage) but I can't compile Krita anymore, too many broken dependencies for which I can't understand how to fix, so can't do this test for now.

I saw problem doesn't occurs on windows, only on Linux (can't test MacOs)

Grum999
Comment 3 Dmitry Kazakov 2023-11-22 14:58:48 UTC
I can confirm the issue. The problem happens only in the final AppImage. When running from the docker environment, dead keys work fine.
Comment 4 Dmitry Kazakov 2023-11-24 10:03:09 UTC
*** Bug 475272 has been marked as a duplicate of this bug. ***
Comment 5 Dmitry Kazakov 2023-11-24 10:13:30 UTC
Git commit 4fdcfa7d4eb3967ef0d1dd971ef89e5fa4568ec5 by Dmitry Kazakov.
Committed on 24/11/2023 at 11:12.
Pushed by dkazakov into branch 'master'.

Fix dead keys in AppImage package on Linux

https://invent.kde.org/szaman/qtbase/-/commit/e9957f0065ae5f430697fa968fb7d5d91ef68d1f

M  +1    -1    3rdparty/ext_qt/CMakeLists.txt

https://invent.kde.org/graphics/krita/-/commit/4fdcfa7d4eb3967ef0d1dd971ef89e5fa4568ec5
Comment 6 Dmitry Kazakov 2023-11-26 11:55:05 UTC
Git commit 47396f95ddfc18f5f8dbf0e2f2f14e514088f84b by Dmitry Kazakov.
Committed on 26/11/2023 at 12:53.
Pushed by dkazakov into branch 'krita/5.2'.

Fix dead keys in AppImage package on Linux

https://invent.kde.org/szaman/qtbase/-/commit/e9957f0065ae5f430697fa968fb7d5d91ef68d1f

M  +1    -1    3rdparty/ext_qt/CMakeLists.txt

https://invent.kde.org/graphics/krita/-/commit/47396f95ddfc18f5f8dbf0e2f2f14e514088f84b
Comment 7 grum999 2023-12-08 16:15:52 UTC
Hi 

Testing Krita 3.3 prealpha (git 5ffd6be) and bug is still here..
Is it normal?
Commit 4fdcfa7d4eb3967ef0d1dd971ef89e5fa4568ec5 is normally taken in account in nightly?

Grum999
Comment 8 grum999 2023-12-08 16:21:32 UTC
If I understand git graph (https://invent.kde.org/graphics/krita/-/network/master?ref_type=heads) commit has been made on Krita 5.2 branch and not merged yet to master..

But testing last official Krita 5.2.2, and problem is still here

Grum999