Bug 468593 - Thumbbar scrolls to 100th image when >100th image is tagged
Summary: Thumbbar scrolls to 100th image when >100th image is tagged
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Applications
Component: Thumbs-BarView (show other bugs)
Version: 8.0.0
Platform: Other Other
: NOR normal
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2023-04-17 03:53 UTC by Freya Lupen
Modified: 2023-08-08 19:02 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In: 8.1.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Freya Lupen 2023-04-17 03:53:17 UTC
SUMMARY
When an image greater than the 100th one is selected and the thumbbar is reloaded, for instance by tagging the image, the thumbbar scrolls to show the 100th image as the last one.

STEPS TO REPRODUCE
1. Open an album with more than 100 images.
2. Go to Preview view, enable Thumbbar. Select an image greater than the 100th one.
3. Cause the thumbbar to reload, for instance by resizing it or applying a tag to the image.

OBSERVED RESULT
The thumbbar scrolls so that the 100th image is the last one shown.

EXPECTED RESULT
The thumbbar should keep the selected image visible.

SOFTWARE/OS VERSIONS
digiKam 8.0.0

ADDITIONAL INFORMATION
This is just a guess, but perhaps it has something to do with https://invent.kde.org/graphics/digikam/-/commit/78b3bb6f62633c220d49c4797c7876ed8af7616b ?
Comment 1 caulier.gilles 2023-04-19 04:48:10 UTC
Did you use Linux ? Which kind of database ? Did you use AppImage bundle ? Which operating system exactly ?
Comment 2 Freya Lupen 2023-04-19 13:06:31 UTC
This happens on Windows 10 and with the Linux Appimage on Ubuntu 22.04. Database is SQLite.
Comment 3 Maik Qualmann 2023-04-20 06:18:23 UTC
Git commit 28a447a7027ea1e109b60d913dd6128cfb55e6a8 by Maik Qualmann.
Committed on 20/04/2023 at 06:17.
Pushed by mqualmann into branch 'master'.

disable QListView::Batched optimization for the thumbnail bars
FIXED-IN: 8.1.0

M  +2    -1    NEWS
M  +5    -0    core/app/items/thumbbar/itemthumbnailbar.cpp
M  +5    -0    core/showfoto/thumbbar/showfotothumbnailbar.cpp
M  +5    -0    core/utilities/import/views/importthumbnailbar.cpp

https://invent.kde.org/graphics/digikam/commit/28a447a7027ea1e109b60d913dd6128cfb55e6a8
Comment 4 nucleo 2023-05-06 19:53:34 UTC
Just noticed this bug. I confirm that the commit fixes it.
Comment 5 Maik Qualmann 2023-06-01 09:31:09 UTC
*** Bug 470510 has been marked as a duplicate of this bug. ***
Comment 6 Maik Qualmann 2023-07-05 10:30:32 UTC
*** Bug 471968 has been marked as a duplicate of this bug. ***
Comment 7 Maik Qualmann 2023-07-06 20:18:30 UTC
*** Bug 472014 has been marked as a duplicate of this bug. ***
Comment 8 Such A Shame 2023-08-08 19:02:11 UTC
See if this is related https://bugs.kde.org/show_bug.cgi?id=472918 and bug is not properly fixed or it was deeper than this.