Bug 46532 - ball went through wall like a ghost
Summary: ball went through wall like a ghost
Status: RESOLVED FIXED
Alias: None
Product: kolf
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal with 60 votes (vote)
Target Milestone: ---
Assignee: Jason Katz-Brown
URL:
Keywords:
: 57756 (view as bug list)
Depends on:
Blocks:
 
Reported: 2002-08-15 20:18 UTC by Rob Kaper
Modified: 2010-11-01 00:23 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Here is an example of a traped ball :) (113.10 KB, image/png)
2003-02-28 00:46 UTC, Jorge Adriano
Details
screenshot (137.91 KB, image/png)
2005-07-16 18:20 UTC, Maciek "wintermute" Skrzypek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rob Kaper 2002-08-15 20:12:20 UTC
(*** This bug was imported into bugs.kde.org ***)

Package:           kolf
Version:           KDE 3.0.7 CVS/CVSup/Snapshot
Severity:          normal
Installed from:    Compiled sources
Compiler:          Not Specified
OS:                Linux
OS/Compiler notes: Not Specified

I was playing a game of Kolf with the author at LWCE and his ball hit mine and then mine went straight through a wall like a ghost making it impossible for me to reach the cup anymore.

Secondly you majorly screwed me by hitting my ball and sending it into the hazard. If that happens I should be allowed to drop the ball form the exit point without extra strokes as punishment.

(Submitted via bugs.kde.org)
Comment 1 Moritz Moeller-Herrmann 2002-10-04 10:11:14 UTC
I noticed the same thing, a ball getting out off the course in KDE.3.1b2. This 
should never happen. 
Comment 2 Jason Katz-Brown 2002-10-04 16:02:06 UTC
Subject: Re:  ball went through wall like a ghost

> I noticed the same thing, a ball getting out off the course in KDE.3.1b2.
> This should never happen.

vertical wall? horizontal wall? diagonal wall?

Charles Samuels fixed diagonal walls. We're not sure about horiz or vert yet.

And, whether or not it "should never happen" is debatable. On a real minigolf 
course if you hit the ball too hard it bounces.


Thanks,
Jason

Comment 3 Daniel Herring 2002-10-15 07:37:33 UTC
Kolf version: 1.1 (from CVS on October 12, 2002)      
       
I had a similar problem with hole #7 on the "Medium Course" (by Jason).  
I tried putting the ball along the bottom edge of the course, but it was too 
slow.  It got caught by the moving obstacle (up-and-down brown thing) which 
pushed the ball out of bounds.  The ball was stuck on the little bit of green 
between the outer wall and the end of the world; I could hit it, but couldn't 
get it to reenter the green. 
 
Thanks, 
Daniel      
Comment 4 Dan Keshet 2002-11-04 18:40:38 UTC
I had a ball go straight through a vertical wall on hole 7 of the classic course.  Kolf 1.1 
using KDE 3.1beta2  
Comment 5 Jason Katz-Brown 2002-11-05 02:54:29 UTC
Subject: Re:  ball went through wall like a ghost

2002 11$B7n(B 4 $B7nMKF|(B 09:40$B!"$"$J$?$O=q$-$^$7$?(B:
> ------- You are receiving this mail because: -------
> You are the assignee for the bug, or are watching the assignee.
>
> http://bugs.kde.org/show_bug.cgi?id=46532
>
>
>
>
> ------- Additional Comments From dkesh@channel1.com  2002-11-04 18:40
> ------- I had a ball go straight through a vertical wall on hole 7 of the
> classic course.  Kolf 1.1 using KDE 3.1beta2


Was this at a wall corner? If not, it should be fixed in KDE 3.1.

Thanks so much,
Jason

Comment 6 Jorge Adriano 2003-02-28 00:46:34 UTC
Created attachment 1070 [details]
Here is an example of a traped ball :)
Comment 7 Rob Kaper 2003-07-14 02:38:35 UTC
Jason, I'd like to suggest you create an "out of bounds" area. I agree that it's 
actually realistic (if hitting too hard) that the ball drops out, but in real minigolf 
that means you either drop it from where it left the course or you hit again from 
the place you were at before. 
 
Under no condition should a ball remain out of bounds when it's time to hit again. 
 
Comment 8 David Morris 2005-04-30 10:03:38 UTC
I've noticed this problem on hole 8 of the Easy Course. It doesn't happen all the time though. If it helps it was a horizontal wall.
Comment 9 Maciek "wintermute" Skrzypek 2005-07-16 18:20:53 UTC
Created attachment 11817 [details]
screenshot

The same bug as #3
Comment 10 Albert Astals Cid 2005-08-29 22:52:46 UTC
*** Bug 57756 has been marked as a duplicate of this bug. ***
Comment 11 Thorsten Hirsch 2006-04-13 21:26:28 UTC
The problem is still not fixed in KDE 3.5.2.
I've created a screenshot after the ball has been dropped out of the field. You can see, that it's a vertical wall.
http://mitglied.lycos.de/bauerbob/kolf_error.png
Comment 12 Travis Evans 2006-09-12 03:59:25 UTC
Not fixed in KDE 3.5.4.

I encounter this issue a lot when the ball is moving nearly parallel to a vertical or horizontal wall. If the ball is very close to the wall and moving almost parallel with it but slightly toward it, the ball often goes *through* the wall instead of bouncing off it.
Comment 13 Daniel Franke 2006-10-11 13:03:20 UTC
Can confirm comment #12 with KDE-3.5.4. Same happend to me: a shot nearly parallel to diagonal wall -- and off it went ...
Comment 14 missive 2007-12-28 16:32:41 UTC
Not sure this should be part of the same bug or not...

In the most recent (Kolf version 1.9 on recent KDE4 from svn) I can get the ball stuck inside of a wall.

It almost seems like the walls are hollow and need endcaps to keep the ball from going inside.

It is very easy to duplicate this bug on hole #1 of the Classic course. Just putt up to the wall in the middle of the fairway and putt the ball right at the narrow end of the wall.
Comment 15 poly1poly 2008-09-08 22:06:07 UTC
I'm playing Kolf in GNOME 2.14.3, Debian 4.0
Kolf 1.1.1, Linux (i686) release 2.6.18-6-686, Target: i486-linux-gnu
I use a hebrew interface in GNOME and I use a hebrew interface in Kolf
I had the border problem in the classic course with 18 holes made by Niklas Knutsson - the level with a bunch of red bumpers, and the ball got stuck after being hit by a bumper, in the red border to the left.
My turn ended and when I had another turn I hit the ball and it was out of the border with no way of winning.
I was playing both players.
Comment 16 poly1poly 2008-09-10 10:46:08 UTC
Other places where red borders aren't "solid".
I'm playing Kolf in GNOME 2.14.3, Debian 4.0 Kolf 1.1.1, Linux (i686) release 2.6.18-6-686, Target: i486-linux-gnu I use a hebrew interface in GNOME and I use a hebrew interface in Kolf 
I played both players.

In the classic course that was made by Niklas Knutsson, that has 18 holes, in track 8 the second red line, counting from the ball upwards.

In the medium course that was made by Jason Katz-Brown, that has 18 holes, in track 12 the first red line, going from the bottom of the screen to the top (the one that is right after the portal hole - the one that changes your location)

In the USA Pro course that was made by Rob Kaper, that has 11 holes, in track 6 right before the hole - in the last brown part, the left border.
Comment 17 poly1poly 2008-09-10 15:01:23 UTC
I'm playing Kolf in GNOME 2.14.3, Debian 4.0 Kolf 1.1.1, Linux (i686) release 2.6.18-6-686, Target: i486-linux-gnu I use a hebrew interface in GNOME and I use a hebrew interface in Kolf I played both players. 

Here's another one:
USA Pro course, first track (level).
There's a border, brown bridge, border again.
At the start with the yellow ball it was okay but with the blue ball I hit it and it went straight through the first border and out of bounds.
Comment 18 Stefan Majewsky 2010-11-01 00:23:10 UTC
SVN commit 1191723 by majewsky:

Make Box2D the default physics engine for Kolf.

Mission accomplished, folks!

CCMAIL: kde-games-devel@kde.org
BUG: 46532
BUG: 51227
BUG: 131488

 M  +0 -10     ball.cpp  
 M  +1 -5      ball.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1191723