Bug 458486 - Unneeded scrollbar space on scrollable views
Summary: Unneeded scrollbar space on scrollable views
Status: RESOLVED FIXED
Alias: None
Product: frameworks-kirigami
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: 5.97.0
Platform: Other Linux
: HI normal (vote)
Target Milestone: Not decided
Assignee: Marco Martin
URL:
Keywords: regression
: 458386 458542 458650 458749 459241 459547 (view as bug list)
Depends on:
Blocks:
 
Reported: 2022-08-29 19:51 UTC by 2anwe
Modified: 2022-09-23 22:25 UTC (History)
10 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.99


Attachments
systemsettings (257.82 KB, image/png)
2022-08-29 19:51 UTC, 2anwe
Details
screenshot1 (396.53 KB, image/png)
2022-09-20 16:51 UTC, Patrick Silva
Details
screenshot2 (147.58 KB, image/png)
2022-09-20 16:51 UTC, Patrick Silva
Details
screenshot3 (144.96 KB, image/png)
2022-09-20 16:51 UTC, Patrick Silva
Details
screenshot4 (110.28 KB, image/png)
2022-09-20 16:52 UTC, Patrick Silva
Details
screenshot5 (237.06 KB, image/png)
2022-09-20 16:52 UTC, Patrick Silva
Details

Note You need to log in before you can comment on or make changes to this bug.
Description 2anwe 2022-08-29 19:51:59 UTC
Created attachment 151690 [details]
systemsettings

OBSERVED RESULT

Space for scrollbar when its unneeded.

EXPECTED RESULT

No unneeded space.

SOFTWARE/OS VERSIONS

Linux/KDE Plasma: openSUSE Tumbleweed 20220828
KDE Plasma Version: 5.25.4
KDE Frameworks Version: 5.97.0
Qt Version: 5.15.5
Comment 1 Patrick Silva 2022-08-29 22:54:16 UTC
Can confirm on Arch Linux and neon unstable.

Linux/KDE Plasma: Arch Linux
KDE Plasma Version: 5.25.4
KDE Frameworks Version: 5.97.0
Qt Version: 5.15.5
Comment 2 Nate Graham 2022-08-30 21:32:56 UTC
Oh dear, I bet you have the fix for the Qt bug that made scrollbars invisible, and it probably didn't fully fix the issue. *enormous sigh*
Comment 3 Nate Graham 2022-08-31 12:54:51 UTC
*** Bug 458386 has been marked as a duplicate of this bug. ***
Comment 4 Bug Janitor Service 2022-08-31 16:33:39 UTC
A possibly relevant merge request was started @ https://invent.kde.org/frameworks/qqc2-desktop-style/-/merge_requests/184
Comment 5 Patrick Silva 2022-08-31 17:38:40 UTC
*** Bug 458542 has been marked as a duplicate of this bug. ***
Comment 6 Marco Martin 2022-09-01 12:22:00 UTC
upstream bug:
https://bugreports.qt.io/browse/QTBUG-106118

merge request above in case we address it locally
Comment 7 Fushan Wen 2022-09-01 16:03:22 UTC
Git commit 4645d80b0359c6a29bed2da68c9501e1b19e9d48 by Fushan Wen, on behalf of Marco Martin.
Committed on 01/09/2022 at 16:03.
Pushed by fusionfuture into branch 'master'.

Explicit binding for visible

This is a workaround.
after the qqc2 commit d0642867ab629daf36a1194274a74758111140be
the binding on visible gets broken at start by unhideOldItem
with a Binding which is both delayed and RestoreBindingOrValue
the binding survives correctly.

M  +8    -2    org.kde.desktop/ScrollBar.qml

https://invent.kde.org/frameworks/qqc2-desktop-style/commit/4645d80b0359c6a29bed2da68c9501e1b19e9d48
Comment 8 Patrick Silva 2022-09-05 15:53:21 UTC
*** Bug 458749 has been marked as a duplicate of this bug. ***
Comment 9 Nate Graham 2022-09-08 23:19:50 UTC
*** Bug 458650 has been marked as a duplicate of this bug. ***
Comment 10 Patrick Silva 2022-09-12 18:56:03 UTC
Unnecessary horizontal scroll bars persist on my system.

Operating System: Arch Linux
KDE Plasma Version: 5.25.5
KDE Frameworks Version: 5.98.0
Qt Version: 5.15.6
Graphics Platform: Wayland
Comment 11 Patrick Silva 2022-09-17 02:36:30 UTC
*** Bug 459241 has been marked as a duplicate of this bug. ***
Comment 12 Nate Graham 2022-09-18 21:54:12 UTC
Is your Qt KDE patch collection fully up to date?
Comment 13 Patrick Silva 2022-09-18 22:41:09 UTC
(In reply to Nate Graham from comment #12)
> Is your Qt KDE patch collection fully up to date?

I think so. My system is fully update.
Comment 14 Nate Graham 2022-09-20 16:09:15 UTC
Darn. Could you add a screenshow of where it's still happening? Or, a few, if it's still happening in multiple places?
Comment 15 Patrick Silva 2022-09-20 16:51:24 UTC
Created attachment 152266 [details]
screenshot1
Comment 16 Patrick Silva 2022-09-20 16:51:39 UTC
Created attachment 152267 [details]
screenshot2
Comment 17 Patrick Silva 2022-09-20 16:51:51 UTC
Created attachment 152268 [details]
screenshot3
Comment 18 Patrick Silva 2022-09-20 16:52:03 UTC
Created attachment 152269 [details]
screenshot4
Comment 19 Patrick Silva 2022-09-20 16:52:20 UTC
Created attachment 152270 [details]
screenshot5
Comment 20 Nate Graham 2022-09-20 17:35:13 UTC
Thank you so much! We'll investigate. Again! This is a bug that just keeps on giving...
Comment 21 Nate Graham 2022-09-22 23:21:43 UTC
*** Bug 459547 has been marked as a duplicate of this bug. ***
Comment 22 Marco Martin 2022-09-23 09:45:49 UTC
Git commit b05718e982ebe711be55511739cfc789a2a5e5c1 by Marco Martin.
Committed on 23/09/2022 at 09:26.
Pushed by mart into branch 'master'.

also check for controlRoot.size > 0

When horizontal scrollbars appear with a width of the handle as big as
the scrollbar making it useless, it has a size of 0 rather than 1,
like usually vertical scrollbars do

M  +1    -1    org.kde.desktop/ScrollBar.qml

https://invent.kde.org/frameworks/qqc2-desktop-style/commit/b05718e982ebe711be55511739cfc789a2a5e5c1
Comment 23 Marco Martin 2022-09-23 13:08:16 UTC
Git commit a03c9b42c5c2827ff105938a37d573614ca2c4ef by Marco Martin.
Committed on 23/09/2022 at 13:08.
Pushed by mart into branch 'master'.

Also check for controlRoot.size > 0

When horizontal scrollbars appear with a width of the handle as big as
the scrollbar making it useless, it has a size of 0 rather than 1,
like usually vertical scrollbars do

M  +1    -1    org.kde.desktop/ScrollBar.qml

https://invent.kde.org/frameworks/qqc2-desktop-style/commit/a03c9b42c5c2827ff105938a37d573614ca2c4ef