Bug 456737 - Problem with the help icon in the application categories in the menu of the KDE Plasma application
Summary: Problem with the help icon in the application categories in the menu of the K...
Status: RESOLVED FIXED
Alias: None
Product: Breeze
Classification: Unclassified
Component: Icons (show other bugs)
Version: 5.25.3
Platform: Other Linux
: NOR normal
Target Milestone: ---
Assignee: visual-design
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-07-15 02:59 UTC by Corvurius
Modified: 2022-07-17 19:46 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.97


Attachments
monochrome help icon in the menu of the KDE Plasma application. (21.43 KB, image/png)
2022-07-15 02:59 UTC, Corvurius
Details
KDE Menu Editor 1. (65.79 KB, image/png)
2022-07-15 03:00 UTC, Corvurius
Details
KDE Menu Editor 2. (108.30 KB, image/png)
2022-07-15 03:01 UTC, Corvurius
Details
KDE Menu Editor 3. (78.21 KB, image/png)
2022-07-15 03:01 UTC, Corvurius
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Corvurius 2022-07-15 02:59:52 UTC
Created attachment 150636 [details]
monochrome help icon in the menu of the KDE Plasma application.

The strange thing for me was that all of the application categories had color icons, but the help icon was monochrome.
I decided to go to edit the menu and saw that the help icon appeared to be colored at all, not monochrome. I decided to edit the icon and here the default icon chosen was "help-browser". Then I chose the icon "system-help" and only changed the proportions. The icon is still not colored even after rebooting the system. Whether this can be considered a bug or not, but I find it strange.
Comment 1 Corvurius 2022-07-15 03:00:44 UTC
Created attachment 150637 [details]
KDE Menu Editor 1.
Comment 2 Corvurius 2022-07-15 03:01:15 UTC
Created attachment 150638 [details]
KDE Menu Editor 2.
Comment 3 Corvurius 2022-07-15 03:01:34 UTC
Created attachment 150639 [details]
KDE Menu Editor 3.
Comment 4 Nate Graham 2022-07-15 19:47:27 UTC
The issue is that this application is using the help-browser icon, which has a monochrome appearance for its 22px version, and it is displayed at that size in Kickoff.

We should probably remove the monochrome versions of this icon and treat is as an application icon, since those are always colorful. Then anyplace we use that icon in a button, we should migrate to using `help-contents`, which is an action icon and those are monochrome.
Comment 5 Bug Janitor Service 2022-07-15 20:11:45 UTC
A possibly relevant merge request was started @ https://invent.kde.org/frameworks/breeze-icons/-/merge_requests/214
Comment 6 Nate Graham 2022-07-17 19:46:07 UTC
Git commit acc75ff7762d7de0bd6489abc821dba506c2a43b by Nate Graham.
Committed on 15/07/2022 at 20:01.
Pushed by ngraham into branch 'master'.

Remove monochrome versions of help-related app icons

App icons should always be colorful at all sizes. the help-browser and
system-help icons are in the Applications group, and currently violate
this by displaying monochrome versions at their 16px and 22px sizes.
For consistency, they should be removed.

The help-contents action icon currently uses symlinks to those icons for
its 16px and 22px monochrome versions (which are appropriate since it's
an action icon), so to avoid breaking it, those sizes are transformed
into files rather than being symlinks.
FIXED-IN: 5.97

T  +14   -1    icons-dark/actions/16/help-contents.svg
T  +14   -1    icons-dark/actions/22/help-contents.svg
D  +0    -1    icons-dark/apps/16/help-browser.svg
D  +0    -14   icons-dark/apps/16/system-help.svg
D  +0    -1    icons-dark/apps/22/help-browser.svg
D  +0    -14   icons-dark/apps/22/system-help.svg
T  +14   -1    icons/actions/16/help-contents.svg
T  +14   -1    icons/actions/22/help-contents.svg
D  +0    -1    icons/apps/16/help-browser.svg
D  +0    -14   icons/apps/16/system-help.svg
D  +0    -1    icons/apps/22/help-browser.svg
D  +0    -14   icons/apps/22/system-help.svg

https://invent.kde.org/frameworks/breeze-icons/commit/acc75ff7762d7de0bd6489abc821dba506c2a43b