Bug 456137 - Kalendar reminders crashes on startup
Summary: Kalendar reminders crashes on startup
Status: RESOLVED FIXED
Alias: None
Product: kalendar
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Claudio Cambra
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2022-06-29 16:59 UTC by rstoecklmayer
Modified: 2022-07-22 18:24 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rstoecklmayer 2022-06-29 16:59:03 UTC
Application: kalendarac (5.20.2)

Qt Version: 5.15.2
Frameworks Version: 5.95.0
Operating System: Linux 5.18.6-1-default x86_64
Windowing System: Wayland
Distribution: "openSUSE Tumbleweed"
DrKonqi: 5.25.1 [KCrashBackend]

-- Information about the crash:
Reminders Crashes instantly when starting Plasma or Korganizer

The crash can be reproduced every time.

-- Backtrace:
Application: Erinnerungen (kalendarac), signal: Segmentation fault

[KCrash Handler]
#4  0x00007f175f81c863 in QHashData::nextNode(QHashData::Node*) () from /lib64/libQt5Core.so.5
#5  0x000056491d2bc447 in ?? ()
#6  0x00007f175f9fdb3f in ?? () from /lib64/libQt5Core.so.5
#7  0x00007f17606e9b42 in Akonadi::EntityTreeModel::collectionPopulated(long long) () from /lib64/libKF5AkonadiCore.so.5
#8  0x00007f17606f2901 in ?? () from /lib64/libKF5AkonadiCore.so.5
#9  0x00007f175f9fdb3f in ?? () from /lib64/libQt5Core.so.5
#10 0x00007f17605125d5 in KJob::result(KJob*, KJob::QPrivateSignal) () from /lib64/libKF5CoreAddons.so.5
#11 0x00007f176051677b in KJob::finishJob(bool) () from /lib64/libKF5CoreAddons.so.5
#12 0x00007f175f9f2490 in QObject::event(QEvent*) () from /lib64/libQt5Core.so.5
#13 0x00007f175f9c6ce8 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /lib64/libQt5Core.so.5
#14 0x00007f175f9c9c81 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /lib64/libQt5Core.so.5
#15 0x00007f175fa1e903 in ?? () from /lib64/libQt5Core.so.5
#16 0x00007f175d400ea0 in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#17 0x00007f175d401258 in ?? () from /lib64/libglib-2.0.so.0
#18 0x00007f175d4012ec in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#19 0x00007f175fa1e106 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#20 0x00007f175f9c575b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#21 0x00007f175f9cd8c6 in QCoreApplication::exec() () from /lib64/libQt5Core.so.5
#22 0x000056491d2b84d5 in ?? ()
#23 0x00007f175f2ad5b0 in __libc_start_call_main () from /lib64/libc.so.6
#24 0x00007f175f2ad679 in __libc_start_main_impl () from /lib64/libc.so.6
#25 0x000056491d2b8ad5 in ?? ()
[Inferior 1 (process 15204) detached]

The reporter indicates this bug may be a duplicate of or related to bug 453395, bug 450377, bug 455902, bug 452848.

Reported using DrKonqi
Comment 1 Claudio Cambra 2022-07-22 18:24:04 UTC
Hi, this has now been fixed with https://invent.kde.org/pim/akonadi-calendar/-/merge_requests/32