Bug 455902 - Kalendar event reminders crash on startup (every time)
Summary: Kalendar event reminders crash on startup (every time)
Status: RESOLVED FIXED
Alias: None
Product: kalendar
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Claudio Cambra
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2022-06-24 23:00 UTC by Kanwar Plaha
Modified: 2022-07-19 14:54 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kanwar Plaha 2022-06-24 23:00:30 UTC
Application: kalendarac (5.20.2)

Qt Version: 5.15.3
Frameworks Version: 5.95.0
Operating System: Linux 5.18.5-200.fc36.x86_64 x86_64
Windowing System: Wayland
Distribution: Fedora Linux 36 (KDE Plasma)
DrKonqi: 5.25.0 [KCrashBackend]

-- Information about the crash:
Kalendar 22.04.2-1 on Fedora 36 crashes and it crashes on startup when attempting to show event reminders.

The crash can be reproduced every time.

-- Backtrace:
Application: Reminders (kalendarac), signal: Segmentation fault

[KCrash Handler]
#4  0x00007f7828b239a7 in QHashData::nextNode(QHashData::Node*) () from /lib64/libQt5Core.so.5
#5  0x0000561b8edad64a in KalendarAlarmClient::checkAlarms() ()
#6  0x00007f7828cdac36 in void doActivate<false>(QObject*, int, void**) () from /lib64/libQt5Core.so.5
#7  0x00007f78299a78f6 in Akonadi::EntityTreeModel::collectionPopulated(long long) () from /lib64/libKF5AkonadiCore.so.5
#8  0x00007f78299b2d52 in Akonadi::EntityTreeModelPrivate::itemFetchJobDone(long long, KJob*) () from /lib64/libKF5AkonadiCore.so.5
#9  0x00007f7828cdac36 in void doActivate<false>(QObject*, int, void**) () from /lib64/libQt5Core.so.5
#10 0x00007f78297b5de9 in KJob::result(KJob*, KJob::QPrivateSignal) () from /lib64/libKF5CoreAddons.so.5
#11 0x00007f78297ba1fb in KJob::finishJob(bool) () from /lib64/libKF5CoreAddons.so.5
#12 0x00007f7828cd1694 in QObject::event(QEvent*) () from /lib64/libQt5Core.so.5
#13 0x00007f7828ca7658 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /lib64/libQt5Core.so.5
#14 0x00007f7828caa9b4 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /lib64/libQt5Core.so.5
#15 0x00007f7828cf8807 in postEventSourceDispatch(_GSource*, int (*)(void*), void*) () from /lib64/libQt5Core.so.5
#16 0x00007f7826698faf in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#17 0x00007f78266ee2c8 in g_main_context_iterate.constprop () from /lib64/libglib-2.0.so.0
#18 0x00007f7826696940 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#19 0x00007f7828cf82fa in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#20 0x00007f7828ca60ba in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#21 0x00007f7828cae162 in QCoreApplication::exec() () from /lib64/libQt5Core.so.5
#22 0x0000561b8eda8efd in main ()
[Inferior 1 (process 3928) detached]

The reporter indicates this bug may be a duplicate of or related to bug 447836, bug 450377, bug 452848, bug 455687, bug 454678, bug 453395.

Reported using DrKonqi
Comment 1 Claudio Cambra 2022-07-19 14:54:14 UTC
Hi, this bug is now fixed with https://invent.kde.org/pim/akonadi-calendar/-/merge_requests/32 and this fix will be included in upcoming updates

Thanks for reporting!