Bug 455882 - [REGRESSION] $KDEWM is ignored, kwin_x11 starts instead
Summary: [REGRESSION] $KDEWM is ignored, kwin_x11 starts instead
Status: RESOLVED DUPLICATE of bug 439481
Alias: None
Product: plasmashell
Classification: Plasma
Component: Startup process (show other bugs)
Version: 5.25.1
Platform: Archlinux Linux
: NOR normal
Target Milestone: 1.0
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-06-24 11:29 UTC by Konstantin Kharlamov
Modified: 2022-06-24 12:40 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Konstantin Kharlamov 2022-06-24 11:29:51 UTC
SUMMARY

After upgrading `plasma-workspace` from 5.24.5 to 5.25.1 when starting a plasma-i3 session¹, instead of i3 (as defined in KDEWM environment variable) it starts a kwin_x11 window manager.

Downgrading `plasma-workspace` to 5.24.5 and restarting SDDM fixes the problem.

1: Documented here https://userbase.kde.org/Tutorials/Using_Other_Window_Managers_with_Plasma#System_Wide:_Adding_an_XSession

STEPS TO REPRODUCE
1. Make sure you have installed Plasma and i3wm
2. Create `/usr/share/xsessions/plasma-i3.desktop` with the following content:
    [Desktop Entry]
    Type=XSession
    Exec=env KDEWM=/usr/bin/i3 --shmlog-size=26214400 /usr/bin/startplasma-x11
    DesktopNames=KDE
    Name=Plasma with i3
    Comment=Plasma with i3
3. Restart DM and start a graphics session called "Plasma with i3"
4. Once the session loaded, execute `ps aux | grep "[k]win"`

OBSERVED RESULT

Last command has output (the running kwin_x11 process)

EXPECTED RESULT

There's no output

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: Archlinux
KDE Plasma Version: 5.25.1
KDE Frameworks Version: 5.95.0
Qt Version: 5.15.5
Comment 1 Antonio Rojas 2022-06-24 12:40:23 UTC

*** This bug has been marked as a duplicate of bug 455452 ***
Comment 2 Antonio Rojas 2022-06-24 12:40:59 UTC

*** This bug has been marked as a duplicate of bug 439481 ***