Bug 455452 - Plasma 5.25 Update breaks the ability to use other window managers by setting the KDEWM environment variable
Summary: Plasma 5.25 Update breaks the ability to use other window managers by setting...
Status: RESOLVED DUPLICATE of bug 439481
Alias: None
Product: kde
Classification: I don't know
Component: general (show other bugs)
Version: unspecified
Platform: Archlinux Linux
: NOR major (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-06-17 01:20 UTC by Jonah
Modified: 2022-06-24 12:40 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:
jonah.chen: version_5_applied+
jonah.chen: Usability+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jonah 2022-06-17 01:20:14 UTC
I run the i3 window manager and it has been working alongside KDE for me for years. When I updated to plasma 5.25 this broke and I was not able to use my other window manager. I checked the environment variable with `echo $KDEWM` and the output is still the expected `/usr/bin/i3`

STEPS TO REPRODUCE
1.  Upgrade to plasma 5.25
2. Create a new desktop in `/usr/share/xsessions` with 
```
[Desktop Entry]
Type=XSession                                                                  
Exec=env KDEWM=/usr/bin/i3 /usr/bin/startplasma-x11                            
DesktopNames=KDE
Name=Plasma with i3
Comment=Plasma with i3
```
3. Log in to the new session you just created. 

OBSERVED RESULT
Plasma starts up with the kwin window manager.

EXPECTED RESULT
Plasma should start up with the i3 window manager.

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: Arch Linux x86_64 with Linux 5.18.3
(available in About System)
KDE Plasma Version: 5.25.0
KDE Frameworks Version: 5.95
Qt Version: 5.15.4

ADDITIONAL INFORMATION
Everything works after downgrading the kde packages (on arch) to 2022 june 15. This is plasma 5.24.5.
Comment 1 Antonio Rojas 2022-06-17 06:07:34 UTC

*** This bug has been marked as a duplicate of bug 439481 ***
Comment 2 Antonio Rojas 2022-06-24 12:40:23 UTC
*** Bug 455882 has been marked as a duplicate of this bug. ***