Bug 455617 - Flicker when I tile my windows left or right.
Summary: Flicker when I tile my windows left or right.
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Unclassified
Component: effects-window-management (show other bugs)
Version: 5.25.0
Platform: Archlinux Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL: https://webmshare.com/5KWEL
Keywords:
: 455445 455594 455675 (view as bug list)
Depends on:
Blocks:
 
Reported: 2022-06-19 17:41 UTC by Roope Kiviniemi
Modified: 2022-06-24 07:53 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.25.1
vlad.zahorodnii: Wayland-
vlad.zahorodnii: X11+


Attachments
Short clip (38 bytes, text/plain)
2022-06-19 17:41 UTC, Roope Kiviniemi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roope Kiviniemi 2022-06-19 17:41:23 UTC
Created attachment 149933 [details]
Short clip

SUMMARY
***
After plasma 5.25  some apps like Firefox and Thunderbird I had this strange flicker/error effect when I tile my windows left or right. This happens only with traditional panel layout if I change floating panel then error goes away.
Short clip: https://webmshare.com/5KWEL
***


STEPS TO REPRODUCE
Tile your window on left or right then move out and you see strange errors

OBSERVED RESULT
Happens only with traditional panel layout, If I change floating panel the error goes away.

EXPECTED RESULT
No flicker and errors

SOFTWARE/OS VERSIONS
KDE Plasma Version:  Plasma 5.25
KDE Frameworks Version: 5.95.0
Qt Version: 5.15.5

ADDITIONAL INFORMATION
Short clip: https://webmshare.com/5KWEL
Comment 1 Vlad Zahorodnii 2022-06-20 08:10:31 UTC
Can't reproduce it. Are you on Wayland or X11?
Comment 2 Roope Kiviniemi 2022-06-20 08:11:03 UTC
(In reply to Vlad Zahorodnii from comment #1)
> Can't reproduce it. Are you on Wayland or X11?

X11
Comment 3 Vlad Zahorodnii 2022-06-20 08:16:59 UTC
*** Bug 455445 has been marked as a duplicate of this bug. ***
Comment 4 Vlad Zahorodnii 2022-06-20 08:19:03 UTC
Can reproduce on X11.
Comment 5 Bug Janitor Service 2022-06-20 09:03:50 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/kwin/-/merge_requests/2549
Comment 6 Vlad Zahorodnii 2022-06-20 13:15:52 UTC
Git commit 35a3184ea3cbfcb0a66a49b466f9f6793c466d10 by Vlad Zahorodnii.
Committed on 20/06/2022 at 10:18.
Pushed by vladz into branch 'master'.

Fix computation of effective opaque region of SurfaceItemX11

The value of _NET_WM_OPAQUE_REGION can be out of sync with the geometry
of the window. The NETWM spec suggests to compute the effective opaque
region by taking intersection of _NET_WM_OPAQUE_REGION and the bounding
region set by the shape extension.

SurfaceItemX11::opaque() got broken after refactoring opaque region
handling in wayland surfaces so SurfaceInterface::opaque() always
returns a sane value, the computation of effective opaque region is done
in SurfaceInterface at commit time.

M  +5    -1    src/surfaceitem_x11.cpp

https://invent.kde.org/plasma/kwin/commit/35a3184ea3cbfcb0a66a49b466f9f6793c466d10
Comment 7 Vlad Zahorodnii 2022-06-20 13:16:59 UTC
Git commit 6f5caa60fe3e33c4850c0bb933a88019da88f2ce by Vlad Zahorodnii.
Committed on 20/06/2022 at 13:16.
Pushed by vladz into branch 'Plasma/5.25'.

Fix computation of effective opaque region of SurfaceItemX11

The value of _NET_WM_OPAQUE_REGION can be out of sync with the geometry
of the window. The NETWM spec suggests to compute the effective opaque
region by taking intersection of _NET_WM_OPAQUE_REGION and the bounding
region set by the shape extension.

SurfaceItemX11::opaque() got broken after refactoring opaque region
handling in wayland surfaces so SurfaceInterface::opaque() always
returns a sane value, the computation of effective opaque region is done
in SurfaceInterface at commit time.


(cherry picked from commit 35a3184ea3cbfcb0a66a49b466f9f6793c466d10)

M  +5    -1    src/surfaceitem_x11.cpp

https://invent.kde.org/plasma/kwin/commit/6f5caa60fe3e33c4850c0bb933a88019da88f2ce
Comment 8 Vlad Zahorodnii 2022-06-21 07:01:39 UTC
*** Bug 455675 has been marked as a duplicate of this bug. ***
Comment 9 Vlad Zahorodnii 2022-06-24 07:53:07 UTC
*** Bug 455594 has been marked as a duplicate of this bug. ***