Bug 455227 - Password field in lock screen is not cleared and focused after failed login attempt
Summary: Password field in lock screen is not cleared and focused after failed login a...
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Theme - Breeze (show other bugs)
Version: 5.24.90
Platform: Other Linux
: VHI normal
Target Milestone: 1.0
Assignee: Plasma Bugs List
URL:
Keywords: regression
: 455322 (view as bug list)
Depends on:
Blocks:
 
Reported: 2022-06-13 20:57 UTC by Derek Christ
Modified: 2022-07-13 22:42 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.25.3


Attachments
unexpected unlock button (1.79 MB, image/jpeg)
2022-06-29 19:23 UTC, galder
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Derek Christ 2022-06-13 20:57:18 UTC
SUMMARY
Since https://invent.kde.org/plasma/plasma-workspace/-/merge_requests/1754/ the password field in the lock screen does not get cleared after a failed login attempt.


STEPS TO REPRODUCE
1. Lock screen (Ctrl+L)
2. Enter false password

OBSERVED RESULT
False password not cleared

EXPECTED RESULT
Cleared text field
Comment 1 Raphaël Jakse 2022-06-13 21:02:54 UTC
It was a surprising behavior when I noticed it the first time, but I started taking advantage of it. It happens that I fat finger the enter key and add a star at the end of the password for example. I fix the problem by removing the last character instead of retyping the whole password.

It would be fine if the password gets selected, so if the user tries to type their password, the not deleted password is deleted when typing the first character.

I just tried to reproduce this by locking the screen with CTRL+Shift+L and the password actually gets removed so it might just be the login screen, or the issue is already fixed.

Operating System: openSUSE Tumbleweed 20220612
KDE Plasma Version: 5.24.5
KDE Frameworks Version: 5.94.0
Qt Version: 5.15.2
Comment 2 Nate Graham 2022-06-15 16:38:39 UTC
*** Bug 455322 has been marked as a duplicate of this bug. ***
Comment 3 Nate Graham 2022-06-29 15:58:24 UTC
Git commit 923ce7e5887db1471c7c9b547c8682068648f458 by Nate Graham, on behalf of Derek Christ.
Committed on 29/06/2022 at 15:58.
Pushed by ngraham into branch 'master'.

Fix password field in lock screen not clearing after failed login attempt

This bug was introduced by plasma/plasma-workspace!1754.

`lockScreenUi.hadPrompt` was set to `false` in `onFailed()` to avoid
unintentionally clearing the password after the text field had faded
out after 10 seconds and the user pressed a button. Unfortunately this
also caused the password field to not clear right after the failed event.

So instead the statement is moved into the trigger of `fadeoutTimer` which
fixes both issues.
FIXED-IN: 5.25.3

M  +4    -7    lookandfeel/contents/lockscreen/LockScreenUi.qml

https://invent.kde.org/plasma/plasma-workspace/commit/923ce7e5887db1471c7c9b547c8682068648f458
Comment 4 Nate Graham 2022-06-29 16:30:57 UTC
Git commit 298ffbc22253bb96dc2b08e482856c6a01d250d6 by Nate Graham, on behalf of Derek Christ.
Committed on 29/06/2022 at 16:02.
Pushed by ngraham into branch 'Plasma/5.25'.

Fix password field in lock screen not clearing after failed login attempt

This bug was introduced by plasma/plasma-workspace!1754.

`lockScreenUi.hadPrompt` was set to `false` in `onFailed()` to avoid
unintentionally clearing the password after the text field had faded
out after 10 seconds and the user pressed a button. Unfortunately this
also caused the password field to not clear right after the failed event.

So instead the statement is moved into the trigger of `fadeoutTimer` which
fixes both issues.
FIXED-IN: 5.25.3
(cherry picked from commit 923ce7e5887db1471c7c9b547c8682068648f458)

M  +6    -9    lookandfeel/contents/lockscreen/LockScreenUi.qml

https://invent.kde.org/plasma/plasma-workspace/commit/298ffbc22253bb96dc2b08e482856c6a01d250d6
Comment 5 galder 2022-06-29 19:23:15 UTC
Created attachment 150273 [details]
unexpected unlock button
Comment 6 Nate Graham 2022-06-29 19:24:34 UTC
That's a separate issue, either Bug 454706 or Bug 455712.
Comment 7 galder 2022-06-29 19:28:59 UTC
Is weird.
I didn't have this issue in 5.25.2
Comment 8 galder 2022-06-29 19:30:38 UTC
worst is I cant unlock ui.
It force me to restart my laptop.
Comment 9 Nate Graham 2022-06-29 19:37:00 UTC
(In reply to galder from comment #8)
> worst is I cant unlock ui.
> It force me to restart my laptop.

Why not? What's broken? Please report that in a new bug reporta, as it's something different from what this bug reports describes. Thanks!
Comment 10 galder 2022-06-29 19:42:07 UTC
Sorry, let me explain.
I was testing latest 5.25 because I got curious.

Then I got this issue.  
Finally compiling rest to 5.25.2 and just plasma-workspace to 5.25 is fine.

I got the problem when I compiled all with 
kdesrc-build plasma-desktop plasma-workspace kwin --include-dependencies --stop-on-failure --branch=Plasma/5.25 --resume-from=kwin
Maybe is me. If works for you is fine.

Regards
Galder
Comment 11 Aleksandar 2022-07-13 07:05:51 UTC
Bug is still present here. Plasma 5.25.3
Comment 12 Nate Graham 2022-07-13 16:51:30 UTC
Cannot reproduce with 5.25.3. Can you please attach a phone recording of the screen that shows the issue happening?
Comment 13 galder 2022-07-13 17:18:52 UTC
works for me too in --branch=Plasma/5.25
Comment 14 Aleksandar 2022-07-13 18:07:56 UTC
(In reply to Nate Graham from comment #12)
> Cannot reproduce with 5.25.3. Can you please attach a phone recording of the
> screen that shows the issue happening?
here's video
https://youtube.com/shorts/2GlBout0wcU?feature=share
Comment 15 Nate Graham 2022-07-13 18:32:48 UTC
That's not the screen locker, it's the login screen.

Does it work with the *screen locker*?
Comment 16 Aleksandar 2022-07-13 22:17:18 UTC
(In reply to Nate Graham from comment #15)
> That's not the screen locker, it's the login screen.
> 
> Does it work with the *screen locker*?

it works. mea culpa
Comment 17 Nate Graham 2022-07-13 22:42:37 UTC
Cool. Feel free to file a separate bug report about it not working on the login screen, as we do want it to work there too. :)