Bug 453996 - windows can't be moved between different screens anymore
Summary: windows can't be moved between different screens anymore
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Plasma
Component: effects-desktop-grid (show other bugs)
Version: git master
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords: regression
: 454148 (view as bug list)
Depends on:
Blocks:
 
Reported: 2022-05-18 16:10 UTC by bastimeyer123
Modified: 2022-06-07 22:36 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.25


Attachments
Screenrecording of the desktop grid (master) + MR applied (2.39 MB, video/x-matroska)
2022-05-23 15:47 UTC, postix
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bastimeyer123 2022-05-18 16:10:44 UTC
Initial report: BUG 453943

SUMMARY
After the recent QML rewrite of the desktopgrid effect, windows can't be moved between different screens anymore. While dragging, the cursor still shows the four-directional arrow, but when releasing the mouse button, the window snaps back to its original position.

See https://youtu.be/A0ydBC6tvUQ


STEPS TO REPRODUCE
1. set up a grid
2. open some windows on each desktop
3. move windows between desktops on the grid


SOFTWARE/OS VERSIONS
Linux/KDE Plasma: Arch Linux
KDE Plasma Version: 5.24.5
KDE Frameworks Version: 5.94.0
Qt Version: 5.15.4


ADDITIONAL INFORMATION
- KWin built from 09ba8729fc12 (current master) using the modified PKGBUILD of the Arch repos
- kdecoration built from 4123ec8c1993 (current master) using the modified PKGBUILD of the Arch repos
- plasma-wayland-protocols built from 26fb07b9f8d3 (current master) using the modified PKGBUILD of the Arch repos
- the remaining dependencies were all from the official Arch repos
Comment 1 Nate Graham 2022-05-19 16:24:12 UTC
I believe this is in progress with https://invent.kde.org/plasma/kwin/-/merge_requests/2388
Comment 2 postix 2022-05-21 20:58:52 UTC
*** Bug 454148 has been marked as a duplicate of this bug. ***
Comment 3 postix 2022-05-21 21:04:41 UTC
(In reply to Nate Graham from comment #1)
> I believe this is in progress with
> https://invent.kde.org/plasma/kwin/-/merge_requests/2388

Will this also resolve bug 448566 ?
Comment 4 Nate Graham 2022-05-23 15:10:28 UTC
Yes, it will!
Comment 5 postix 2022-05-23 15:14:16 UTC
(In reply to Nate Graham from comment #4)
> Yes, it will!

And also for bug 283333 ? :-D
Comment 6 Nate Graham 2022-05-23 15:21:04 UTC
It should!
Comment 7 postix 2022-05-23 15:47:59 UTC
Created attachment 149139 [details]
Screenrecording of the desktop grid (master) + MR applied

> https://invent.kde.org/plasma/kwin/-/merge_requests/2388

I have tested the MR and it works, but it has some flaws as you can see in the screen recording: 
Dragging a window from (2,1) on screen 2 to (2,1) on screen 1, 
makes the windows move to (1,1) on screen 1.
Comment 8 Nate Graham 2022-05-23 15:50:55 UTC
Please mention those issues in separate comment threads in the MR itself. Thanks!
Comment 9 Marco Martin 2022-06-06 13:49:21 UTC
Git commit 3d0beae8285fb82ea6b51ba10f2e47dc515727e2 by Marco Martin.
Committed on 06/06/2022 at 13:48.
Pushed by mart into branch 'master'.

Drag windows between screens in WindowHeap

Allow dragging windows between screens, using a placeholder thumbnail item to
render part of the thumbnail on the other screen.
Related: bug 283333, bug 448566

M  +13   -0    src/effects/desktopgrid/qml/DesktopView.qml
M  +60   -3    src/effects/private/qml/WindowHeap.qml
M  +0    -1    src/effects/windowview/qml/main.qml
M  +10   -0    src/libkwineffects/kwineffects.cpp
M  +3    -0    src/libkwineffects/kwineffects.h
M  +49   -0    src/libkwineffects/kwinquickeffect.cpp
M  +7    -0    src/libkwineffects/kwinquickeffect.h
M  +5    -0    src/scripting/workspace_wrapper.cpp
M  +2    -0    src/scripting/workspace_wrapper.h

https://invent.kde.org/plasma/kwin/commit/3d0beae8285fb82ea6b51ba10f2e47dc515727e2
Comment 10 Marco Martin 2022-06-06 14:18:11 UTC
Git commit 6c14ae78e8f5f4f4bbfa17f012164a5b4d3dc0cd by Marco Martin.
Committed on 06/06/2022 at 14:17.
Pushed by mart into branch 'Plasma/5.25'.

Drag windows between screens in WindowHeap

Allow dragging windows between screens, using a placeholder thumbnail item to
render part of the thumbnail on the other screen.
Related: bug 283333, bug 448566

M  +13   -0    src/effects/desktopgrid/qml/DesktopView.qml
M  +60   -3    src/effects/private/qml/WindowHeap.qml
M  +0    -1    src/effects/windowview/qml/main.qml
M  +10   -0    src/libkwineffects/kwineffects.cpp
M  +3    -0    src/libkwineffects/kwineffects.h
M  +49   -0    src/libkwineffects/kwinquickeffect.cpp
M  +7    -0    src/libkwineffects/kwinquickeffect.h
M  +5    -0    src/scripting/workspace_wrapper.cpp
M  +2    -0    src/scripting/workspace_wrapper.h

https://invent.kde.org/plasma/kwin/commit/6c14ae78e8f5f4f4bbfa17f012164a5b4d3dc0cd