Bug 453348 - Global menu text color do not follow plasma style, but follows colors in appearance settings.
Summary: Global menu text color do not follow plasma style, but follows colors in appe...
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Global Menu (show other bugs)
Version: 5.24.5
Platform: Archlinux Packages Linux
: VHI normal
Target Milestone: 1.0
Assignee: Plasma Bugs List
URL:
Keywords: regression
: 453886 453923 454329 (view as bug list)
Depends on:
Blocks:
 
Reported: 2022-05-03 15:24 UTC by sunghwan
Modified: 2022-05-24 16:57 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.24.6


Attachments
global menu with breeze twilight (28.98 KB, image/png)
2022-05-03 15:24 UTC, sunghwan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sunghwan 2022-05-03 15:24:15 UTC
Created attachment 148538 [details]
global menu with breeze twilight

STEPS TO REPRODUCE
1. set global theme as breeze twilight (plasma style: breeze dark, colors: breeze light (or breeze classic))
2. add a global menu to a application menu bar or a panel
3. run any application

OBSERVED RESULT
text color do not follow plasma style but follows colors in appearance settings

EXPECTED RESULT
text color follows plasma style and text is visible

SOFTWARE/OS VERSIONS
Operating System: Arch Linux
KDE Plasma Version: 5.24.5
KDE Frameworks Version: 5.93.0
Qt Version: 5.15.3
Kernel Version: 5.17.5-arch1-1 (64-bit)
Graphics Platform: X11

In previous version(5.24.4), global menu text is visible with breeze twilight theme. But after update(5.24.5),  it follows color in appearance and is not visible.
Comment 1 Nate Graham 2022-05-04 16:42:34 UTC
Can confirm, seems like it was caused by https://invent.kde.org/plasma/plasma-workspace/-/commit/28537cf3ff3cd9210f7568f40334ac3a2c9bed18.
Comment 2 Nate Graham 2022-05-04 16:48:57 UTC
Will be fixed with https://invent.kde.org/plasma/plasma-workspace/-/merge_requests/1704.
Comment 3 Nate Graham 2022-05-04 18:07:52 UTC
Git commit 19d9bc7e395d8c6e007afdc3b3b5c11a7d02190e by Nate Graham.
Committed on 04/05/2022 at 17:13.
Pushed by ngraham into branch 'master'.

applets/appmenu: fix top-level menu text coloration

28537cf3ff3cd9210f7568f40334ac3a2c9bed18 made the color dynamic, but
neglected to respect the Plasma color scheme, if any. This causes
problems with Plasma themes that have their own colors and don't
respect the systemwide color scheme, such as Breeze Twilight.

Fix it by using the appropriate colors from the PlasmaCore color scheme
object, not the systemwide object provided by Qt.
FIXED-IN: 5.24.6

M  +1    -4    applets/appmenu/package/contents/ui/MenuDelegate.qml

https://invent.kde.org/plasma/plasma-workspace/commit/19d9bc7e395d8c6e007afdc3b3b5c11a7d02190e
Comment 4 Nate Graham 2022-05-04 18:19:32 UTC
Git commit e87e94e3f8e86c3ec74d02291e91ecd34c9b0be2 by Nate Graham.
Committed on 04/05/2022 at 18:19.
Pushed by ngraham into branch 'cherry-pick-19d9bc7e'.

applets/appmenu: fix top-level menu text coloration

28537cf3ff3cd9210f7568f40334ac3a2c9bed18 made the color dynamic, but
neglected to respect the Plasma color scheme, if any. This causes
problems with Plasma themes that have their own colors and don't
respect the systemwide color scheme, such as Breeze Twilight.

Fix it by using the appropriate colors from the PlasmaCore color scheme
object, not the systemwide object provided by Qt.
FIXED-IN: 5.24.6


(cherry picked from commit 19d9bc7e395d8c6e007afdc3b3b5c11a7d02190e)

M  +1    -4    applets/appmenu/package/contents/ui/MenuDelegate.qml

https://invent.kde.org/plasma/plasma-workspace/commit/e87e94e3f8e86c3ec74d02291e91ecd34c9b0be2
Comment 5 Nate Graham 2022-05-04 18:21:56 UTC
Git commit 4d3f99558cff95259590e70dfbf854a479f772ce by Nate Graham.
Committed on 04/05/2022 at 18:21.
Pushed by ngraham into branch 'Plasma/5.24'.

applets/appmenu: fix top-level menu text coloration

28537cf3ff3cd9210f7568f40334ac3a2c9bed18 made the color dynamic, but
neglected to respect the Plasma color scheme, if any. This causes
problems with Plasma themes that have their own colors and don't
respect the systemwide color scheme, such as Breeze Twilight.

Fix it by using the appropriate colors from the PlasmaCore color scheme
object, not the systemwide object provided by Qt.
FIXED-IN: 5.24.6


(cherry picked from commit 19d9bc7e395d8c6e007afdc3b3b5c11a7d02190e)

M  +1    -4    applets/appmenu/package/contents/ui/MenuDelegate.qml

https://invent.kde.org/plasma/plasma-workspace/commit/4d3f99558cff95259590e70dfbf854a479f772ce
Comment 6 Nate Graham 2022-05-16 18:23:05 UTC
*** Bug 453886 has been marked as a duplicate of this bug. ***
Comment 7 Nate Graham 2022-05-17 15:36:06 UTC
*** Bug 453923 has been marked as a duplicate of this bug. ***
Comment 8 Nate Graham 2022-05-24 16:57:50 UTC
*** Bug 454329 has been marked as a duplicate of this bug. ***