Bug 452507 - Item details no longer shown in sidebar
Summary: Item details no longer shown in sidebar
Status: RESOLVED DUPLICATE of bug 452480
Alias: None
Product: korganizer
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Other Other
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-04-11 15:53 UTC by Kishore Gopalakrishnan
Modified: 2022-05-07 19:52 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kishore Gopalakrishnan 2022-04-11 15:53:37 UTC
SUMMARY
Item details (Settings > sidebar > item viewer) are no longer shown for events (checked with both Google calendar and local calendar)

STEPS TO REPRODUCE
1. Open Korganizer
2. Make sure 'Settings > Sidebar > Show Item viewer' is checked
3. Click on any event

OBSERVED RESULTS
Nothing is shown

EXPECTED RESULTS
Event details should be shown in the sidebar

SOFTWARE VERSIONS
korganizer 5.19.90 rc (22.03.90) (not 'version' dropdown box)
Operating System: Arch Linux
KDE Plasma Version: 5.24.4
KDE Frameworks Version: 5.92.0
Qt Version: 5.15.3
Kernel Version: 5.15.33-1-lts (64-bit)
Graphics Platform: X11
Processors: 8 × AMD Ryzen 5 3500U with Radeon Vega Mobile Gfx
Memory: 21.5 GiB of RAM
Graphics Processor: AMD Radeon Vega 8 Graphics

ADDITIONAL INFORMATION
Also reproducible on KDE Neon unstable. On Arch, downgrading all KDE applications to 21.12.3 fixes the issue.

Not sure if related to this bug, but when I launch korganizer, I get 
```
Apr 11 19:45:01 kishore-thinkpad-e495 korganizer[240021]: org.kde.pim.incidenceeditor: free slot calculation: invalid range. range(  0 ) / mSlotResolutionSeconds( 900 ) =  0
``` 
in my system logs.
Comment 1 Max 2022-04-25 05:28:10 UTC
I confirm one
korganizer 5.20.0 (22.04.0)
Operating System: Gentoo
KDE Plasma Version: 5.24.4
KDE Frameworks Version: 5.93.0
Qt Version: 5.15.3
Kernel Version: 5.15.32 (64-bit)
Graphics Platform: X11
Comment 2 Kishore Gopalakrishnan 2022-04-25 06:04:14 UTC
FWIW, Kalendar shows the event details correctly for the same calendars, so it does not seem to be an akonadi bug.
Comment 3 natherul0 2022-04-26 05:16:02 UTC
Same here
version 5.20.0 (22.04.0)
Operating System: Arch Linux
KDE Plasma Version: 5.24.4
KDE Frameworks Version: 5.93.0
Qt Version: 5.15.3
Kernel Version: 5.17.4-zen1-1-zen (64-bit)
Graphics Platform: X11 (but the same applies for wayland)
Processors: 16 × AMD Ryzen 7 5800X 8-Core Processor
Memory: 31.3 GiB of RAM
Graphics Processor: AMD Radeon RX 5700 XT
Comment 4 gjditchfield 2022-04-28 23:00:58 UTC
If you run korganizer from the command line, does it print anything when you select an event?
(The "free slot calculation" message is not important.)
Comment 5 natherul0 2022-04-29 05:25:55 UTC
For me it seems to have solved itself. I did another update in between but organizer was not updated so Im guessing it was a problem in some library maybe?
Comment 6 Kishore Gopalakrishnan 2022-04-29 13:25:33 UTC
(In reply to natherul0 from comment #5)
> For me it seems to have solved itself. I did another update in between but
> organizer was not updated so Im guessing it was a problem in some library
> maybe?

Yes. It is fixed on Arch after upgrading to kcalutils 22.04.0-2. On this version, the Arch maintainer has applied the patch: https://invent.kde.org/pim/kcalutils/-/commit/494331a2

If anyone can reproduce this after applying that patch, please unmark as duplicate.

*** This bug has been marked as a duplicate of bug 452480 ***
Comment 7 gjditchfield 2022-04-29 15:58:13 UTC
*** Bug 453195 has been marked as a duplicate of this bug. ***
Comment 8 Bob Mattes 2022-04-29 16:10:15 UTC
Not resolved in OpenSUSE Tumbleweed as of 4/29/2022.
Comment 9 gjditchfield 2022-04-29 17:56:12 UTC
(In reply to gjditchfield from comment #4)
> If you run korganizer from the command line, does it print anything when you
> select an event?

"Plugin library 'kcalendar_grantlee_plugin' not found."