Bug 452187 - Wrong Meta+(Number) behaviour using "Shows tooltip window thumbnails" setting on grouped task
Summary: Wrong Meta+(Number) behaviour using "Shows tooltip window thumbnails" setting...
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Task Manager and Icons-Only Task Manager (show other bugs)
Version: 5.24.3
Platform: Other Linux
: NOR normal
Target Milestone: 1.0
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-04-02 19:17 UTC by Aurora Robb Kristiansen
Modified: 2022-04-11 19:47 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.24.5
mopylre05: Usability+


Attachments
My Plasma panel settings (5.11 KB, text/plain)
2022-04-09 16:28 UTC, Aurora Robb Kristiansen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aurora Robb Kristiansen 2022-04-02 19:17:14 UTC
SUMMARY
(Example: Meta+5 to open the fifth entry on the icons only task manager)
When using the behaviour setting "Shows tooltip window thumbnails", and then pressing a Meta+(Number) shortcut on a grouped entry on the task manager, it instead only highlights an adjacent entry, without opening it.

STEPS TO REPRODUCE
1. Configure your Icons Only Task Manager's Behaviour settings to "Shows tooltip window thumbnails"
2. Open multiple instances of a task
3. Pin or open more tasks, doesn't matter if they're single or grouped
4. Use a grouped task's respective Meta+(Number) shortcut

OBSERVED RESULT
Plasma highlights a nearby task without opening it

EXPECTED RESULT
Plasma cycles through the grouped tasks' windows on each button press

SOFTWARE/OS VERSIONS
Linux: Void Linux 64-bit, Kernel 5.16.18_1
KDE Plasma Version: 5.24.3
KDE Frameworks Version: 5.92.0
Qt Version: 5.15.2

HARDWARE
Processor: Intel Pentium N3540
Graphics: Intel HD Graphics (Mesa DRI)s

ADDITIONAL INFORMATION
Single tasks (not grouped) behave as intended. Happens in both the X11 and Wayland sessions.
Also tested on my Arch Linux desktop system in an X11 session, using the proprietary Nvidia graphics driver and same KDE/Qt software versions as above.

At the time of writing I cannot supply a video recording due to the poor hardware I am using, but will attempt to supply one during the coming week.
Comment 1 Aurora Robb Kristiansen 2022-04-02 19:26:50 UTC
A personal example that hopefully helps make this report more clear: I have two PDFs opened with Okular, on the fifth spot on my icons only task manager. To the left of it I have the DeaDBeeF music player pinned, but it is not running. When I press Meta+5, Plasma only presents an empty preview window above DeaDBeeF, with the text being DeaDBeeF's last state (Song title etc.) before I closed it long ago.

Doesn't matter if Okular is pinned or not, it has the same behaviour.
Comment 2 Aurora Robb Kristiansen 2022-04-03 20:48:20 UTC
I just performed another test on this, and found out that the task manager simply attempts to create a preview window where there last was one.

This means that, if you hover your mouse over a different application on the task manager and let the tooltip window thumbnail appear, pressing Meta+(Number) on a grouped task will re-spawn the window thumbnail you just created with your mouse.
Comment 3 Nate Graham 2022-04-06 17:57:55 UTC
Weird, cannot reproduce.
Comment 4 Aurora Robb Kristiansen 2022-04-07 22:05:06 UTC
Hi Nate, thank you very much for attempting to reproduce the issue.
I have created a short video and uploaded it to YouTube.
You can see it here:
https://youtu.be/ljuXR-2lLpA

Here's a rundown of what I do in it:
0:02 - First I open another Dolphin window to create a grouped icon.

0:08 - Then I hover over Firefox, to view that window's preview.
0:12 - When I then press Meta + 1 (Dolphin's position), it shows the last previewed window. In this case, Firefox.

0:25 - By previewing Dolphin and removing the cursor from the preview, it can show Dolphin's windows correctly, but only because that was the last preview.
Comment 5 Aurora Robb Kristiansen 2022-04-07 22:09:03 UTC
This is on my desktop by the way, not sure if it matters, but as mentioned the same issue occurs on my laptops in the Wayland session. In the video the bug is reproduced in the X11 session.
Comment 6 Nate Graham 2022-04-08 16:50:17 UTC
Thanks for the video. It's very clear. Unfortunately when I do the exact same thing I still cannot reproduce it!

Are you using any non-default Task Manager settings, by any chance?
Comment 7 Aurora Robb Kristiansen 2022-04-09 16:28:10 UTC
Created attachment 148074 [details]
My Plasma panel settings

These are the settings for my Plasma panel, just in case they're needed. I couldn't see any settings in it that I personally think might be related to the bug, but you never know.
Comment 8 Aurora Robb Kristiansen 2022-04-09 16:30:40 UTC
Good catch! Can't believe I didn't think to include my task manager settings..
I had to double check now that you mentioned it, but with all default settings (except for tooltip window thumbnails, as per step 1), it still exhibits this same behaviour. But thank you, I'll make sure to include my settings in future reports.

On the other hand I have a lot changes in my Plasma System Settings, but I'm unsure if any of them could affect the bug and which ones I should share here, without dumping thousands of lines of unrelated settings here.
I uploaded my "plasma-org.kde.plasma.desktop-appletsrc" file, just in case. Lemme know if I can share are any other files or settings that might affect this.
Comment 9 Fushan Wen 2022-04-11 10:45:19 UTC
Can't reproduce either, but the Meta+N keyboard shortcut doesn't switch among the grouped tasks, which should be fixed.
Comment 10 Fushan Wen 2022-04-11 10:47:10 UTC
I was hurried. I can reproduce now. Need to drag the task to change its order before reproducing the bug.
Comment 11 Fushan Wen 2022-04-11 10:54:29 UTC
STEPS TO REPRODUCE
1. Open multiple Konsole windows (at pos 1)
2. Open Firefox (at pos 2)
3. Drag Firefox to pos 1
4. Press Meta+2
Comment 12 Nate Graham 2022-04-11 19:44:50 UTC
Git commit 130f32eeefdc514ce102ffc8b2dab9d0232d1c4f by Nate Graham, on behalf of Fushan Wen.
Committed on 11/04/2022 at 19:44.
Pushed by ngraham into branch 'master'.

applets/taskmanager: Update tooltip bindings when activating from keyboard

When activating a task from keyboard, there is no containsMouse changed
signal, so we need to update the tooltip properties here.
FIXED-IN: 5.24.5

M  +28   -25   applets/taskmanager/package/contents/ui/Task.qml
M  +10   -0    applets/taskmanager/package/contents/ui/main.qml

https://invent.kde.org/plasma/plasma-desktop/commit/130f32eeefdc514ce102ffc8b2dab9d0232d1c4f
Comment 13 Nate Graham 2022-04-11 19:47:59 UTC
Git commit 7ae51e545c44e885e98d35c78ab0df7cb369e779 by Nate Graham, on behalf of Fushan Wen.
Committed on 11/04/2022 at 19:47.
Pushed by ngraham into branch 'Plasma/5.24'.

applets/taskmanager: Update tooltip bindings when activating from keyboard

When activating a task from keyboard, there is no containsMouse changed
signal, so we need to update the tooltip properties here.
FIXED-IN: 5.24.5


(cherry picked from commit 130f32eeefdc514ce102ffc8b2dab9d0232d1c4f)

M  +28   -25   applets/taskmanager/package/contents/ui/Task.qml
M  +10   -0    applets/taskmanager/package/contents/ui/main.qml

https://invent.kde.org/plasma/plasma-desktop/commit/7ae51e545c44e885e98d35c78ab0df7cb369e779