Bug 427103 - Pressing Win+n on "show window tooltip thumbnails" shows wrong window (most of the time)
Summary: Pressing Win+n on "show window tooltip thumbnails" shows wrong window (most o...
Status: RESOLVED DUPLICATE of bug 452187
Alias: None
Product: plasmashell
Classification: Plasma
Component: Task Manager and Icons-Only Task Manager (show other bugs)
Version: 5.19.90
Platform: Archlinux Linux
: NOR normal
Target Milestone: 1.0
Assignee: Eike Hein
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-09-29 05:54 UTC by modelmat
Modified: 2022-07-05 05:45 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
demonstrating observed (666.66 KB, video/x-matroska)
2020-09-29 05:54 UTC, modelmat
Details

Note You need to log in before you can comment on or make changes to this bug.
Description modelmat 2020-09-29 05:54:58 UTC
Created attachment 132001 [details]
demonstrating observed

SUMMARY
Related bug report/MR: https://bugs.kde.org/show_bug.cgi?id=424268 with https://invent.kde.org/plasma/plasma-desktop/-/merge_requests/71

Demonstrating this behaviour: https://invent.kde.org/plasma/plasma-desktop/uploads/e82c122652b47a42aeca345e2773f253/thumbnail-bug.webm

This does not occur on the stacked window list, only on the thumbnails one.

STEPS TO REPRODUCE
1. Configure Icons-Only Task Manager to use "clicking grouped task: show tooltip window thumbnails"
2. Hover a particular window using your mouse, then use Win+n keys to select other windows.

OBSERVED RESULT
(first part of the attachment) A window with one window open hovered, pressing win+n will move the preview box between the designated positions.

If a window with multiple windows open has been hovered, pressing win+n will result it staying open as the same window in the same position, despite the button for other windows being pressed. (second part of the attachment)

Various strange behaviours occur if you move your mouse around, though it's difficult to see what exactly caused it.

EXPECTED RESULT
Pressing Win+N should always highlight the Nth windows, not the currently hovered window.

SOFTWARE/OS VERSIONS
Operating System: Arch Linux
KDE Plasma Version: 5.19.90
KDE Frameworks Version: 5.74.0
Qt Version: 5.15.1
Kernel Version: 5.8.12-arch1-1
OS Type: 64-bit
Processors: 4 × Intel® Core™ i5-6500 CPU @ 3.20GHz
Memory: 7.6 GiB of RAM
Graphics Processor: Mesa Intel® HD Graphics 530

ADDITIONAL INFORMATION
Comment 1 Fushan Wen 2022-07-05 05:45:25 UTC

*** This bug has been marked as a duplicate of bug 452187 ***