Bug 451088 - Unknown Error on the Collaborative Services API (0)
Summary: Unknown Error on the Collaborative Services API (0)
Status: RESOLVED DUPLICATE of bug 451165
Alias: None
Product: frameworks-knewstuff
Classification: Unclassified
Component: general (show other bugs)
Version: 5.91.0
Platform: Other Linux
: NOR grave
Target Milestone: ---
Assignee: Alexander Lohnau
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-03-03 15:18 UTC by xicomaia2610
Modified: 2022-03-27 04:03 UTC (History)
8 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Error screenshot (88.76 KB, image/png)
2022-03-03 15:18 UTC, xicomaia2610
Details
screenshot for the plasma widgets explorer (197.39 KB, image/png)
2022-03-21 07:56 UTC, Bernie Innocenti
Details

Note You need to log in before you can comment on or make changes to this bug.
Description xicomaia2610 2022-03-03 15:18:14 UTC
Created attachment 147262 [details]
Error screenshot

SUMMARY
***
Hello! Every time I try to download an icon theme, window decoration or splash screen, I get this error: "Unknown Error on the Collaborative Services API (0)" and nothing shows up.
***


STEPS TO REPRODUCE
1. Open the "Get new icons" // "Get new Window Decorations" // "Get new Splash Screens"

OBSERVED RESULT

The error shows up and nothing loads.

EXPECTED RESULT

Themes should show and be able to be installed.

SOFTWARE/OS VERSIONS
Operating System: Fedora Linux 35
KDE Plasma Version: 5.24.2
KDE Frameworks Version: 5.91.0
Qt Version: 5.15.2
Kernel Version: 5.16.11-200.fc35.x86_64 (64-bit)
Graphics Platform: X11
Processors: 6 × AMD Ryzen 5 3500X 6-Core Processor
Memory: 15.6 GiB of RAM
Graphics Processor: AMD Radeon RX 6700 XT

ADDITIONAL INFORMATION
Comment 1 Mosklia 2022-03-07 02:50:07 UTC
It seems that i cannot download anything via systemsettings.
From icon, cursor, to desktop wallpaper or wallpaper plugin, it just shows me that "Unknown Error on the Open Collaborative Services API (0)"(In Chinese, "Open Collaboration Services 的 API 出现了未知错误。(0)")
I'm sure that i can visit store.kde.org.

SOFTWARE/OS VERSIONS
Operating System: ArchLinux
KDE Plasma Version: 5.24.2
KDE Frameworks Version: 5.91.0
Qt Version: 5.15.3
Kernel Version: 5.16.12-zen1-1-zen (64-bit)
Graphics Platform: X11
Processors: 16 × AMD Ryzen 9 4900HS with Radeon Graphics
Memory: 15.1 GiB of RAM
Graphics Processor: AMD RENOIR
Comment 2 Mosklia 2022-03-07 03:08:31 UTC
(In reply to Mosklia from comment #1)
> It seems that i cannot download anything via systemsettings.
> From icon, cursor, to desktop wallpaper or wallpaper plugin, it just shows
> me that "Unknown Error on the Open Collaborative Services API (0)"(In
> Chinese, "Open Collaboration Services 的 API 出现了未知错误。(0)")
> I'm sure that i can visit store.kde.org.
> 
> SOFTWARE/OS VERSIONS
> Operating System: ArchLinux
> KDE Plasma Version: 5.24.2
> KDE Frameworks Version: 5.91.0
> Qt Version: 5.15.3
> Kernel Version: 5.16.12-zen1-1-zen (64-bit)
> Graphics Platform: X11
> Processors: 16 × AMD Ryzen 9 4900HS with Radeon Graphics
> Memory: 15.1 GiB of RAM
> Graphics Processor: AMD RENOIR

The error does not come out when the window says `Initializing...`(`正在初始化...`),until the next stage `Loading more...`(`正在加载更多内容...`)
Comment 3 Antonio Rojas 2022-03-10 16:19:09 UTC
*** Bug 451364 has been marked as a duplicate of this bug. ***
Comment 4 José Ribeiro 2022-03-14 18:24:49 UTC
I am unable to download new wallpapers, new windows decorations, new icon and new splash screens.

Additional info:

KDE Plasma: 5.24.3
KDE Frameworks: 5.92.0
Qt: 5.15.3
Kernel: 5.16.14-arch1-1
Comment 5 Antonio Rojas 2022-03-17 10:39:46 UTC
*** Bug 451611 has been marked as a duplicate of this bug. ***
Comment 6 Johannes 2022-03-17 11:27:31 UTC
(In reply to Antonio Rojas from comment #5)
> *** Bug 451611 has been marked as a duplicate of this bug. ***

I see that the bug report I made was marked duplicate of this one, but in fact I found out interesting things which I mention in bug 451611. I repeat them here so that they don't get lost.

First, it occurs only if the language is not English. 
As a corollary, you can run "LANG=C systemsettings" as a workaround; it will be in English but it will work.

Second, the bug affects also plasma-discover; when there is an icon set or kwin script or color scheme that gets an update in Discover, if Discover runs in a language other than English, it will fail to update, while "LANG=C plasma-discover" fixes it, but is in English.

Finally, I confirm the bug in a KDE Neon fresh install done this morning.
Comment 7 Bernie Innocenti 2022-03-21 07:55:28 UTC
It just happened to me as well upon opening the "Download New Plasma Widgets" explorer.
Comment 8 Bernie Innocenti 2022-03-21 07:56:45 UTC
Created attachment 147645 [details]
screenshot for the plasma widgets explorer
Comment 10 Nate Graham 2022-03-27 04:03:59 UTC

*** This bug has been marked as a duplicate of bug 451165 ***