Bug 450867 - KDE Plasma (Wayland) - System Settings Crash after turning Main (Primary) Monitor off then on again
Summary: KDE Plasma (Wayland) - System Settings Crash after turning Main (Primary) Mon...
Status: RESOLVED DUPLICATE of bug 451028
Alias: None
Product: systemsettings
Classification: Applications
Component: generic-crash (show other bugs)
Version: 5.24.2
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-02-26 09:16 UTC by Ben
Modified: 2022-03-02 16:50 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
systemsettings crash when main monitor turned off then on again (3.54 KB, text/vnd.kde.kcrash-report)
2022-02-26 09:16 UTC, Ben
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ben 2022-02-26 09:16:41 UTC
Created attachment 147135 [details]
systemsettings crash when main monitor turned off then on again

STEPS TO REPRODUCE

Turn Main (Primary Monitor) off then back on again

OBSERVED RESULT
systemsettings crash





KDE Plasma (Wayland) - System Settings Crash after turning Main (Primary) Monitor off then on again:




DATE: Saturday the 26th of February, 2022

We are sorry, System Settings closed unexpectedley
You can help us improve KDE Software by reporting this error.

Details:

Executable: systemsettings PID: 11041 Signal: Segmentation fault(11) Time: 2/26/22 9:40:26 PM NZDT


KDE INFO:


Operating System: openSUSE Tumbleweed 20220224
KDE Plasma Version: 5.24.2
KDE Frameworks Version: 5.91.0
Qt Version: 5.15.2
Kernel Version: 5.16.10-1-default (64-bit)
Graphics Platform: Wayland
Processors: 4 × Intel® Core™ i5-3570K CPU @ 3.40GHz
Memory: 15.5 GiB of RAM
Graphics Processor: AMD PITCAIRN



POSSIBLY RELATED:

https://bugs.kde.org/show_bug.cgi?id=409778
https://bugs.kde.org/show_bug.cgi?id=409817
Comment 1 Nate Graham 2022-03-02 16:50:07 UTC
Application: systemsettings (5.24.2)

Qt Version: 5.15.2
Frameworks Version: 5.91.0
Operating System: Linux 5.16.10-1-default x86_64
Windowing System: Wayland
Distribution: "openSUSE Tumbleweed"
DrKonqi: 5.24.2 [KCrashBackend]

-- Information about the crash:
<In detail, tell us what you were doing  when the application crashed.>

The reporter is unsure if this crash is reproducible.

-- Backtrace:
Application: System Settings (systemsettings), signal: Segmentation fault
Content of s_kcrashErrorMessage: std::unique_ptr<char []> = {get() = <optimized out>}
[KCrash Handler]
#6  0x00007f14c6cac74a in QtWayland::wl_output::handle_done (data=0x5602ed3bab90, object=0x5602ed20dad0) at qwayland-wayland.cpp:2247
#7  0x00007f14c6599572 in ffi_call_unix64 () at ../src/x86/unix64.S:105
#8  0x00007f14c6596296 in ffi_call_int (cif=<optimized out>, fn=<optimized out>, rvalue=<optimized out>, avalue=<optimized out>, closure=<optimized out>) at ../src/x86/ffi64.c:672
#9  0x00007f14c6bf99c0 in wl_closure_invoke (closure=closure@entry=0x7f14b400c260, target=<optimized out>, target@entry=0x5602ed20dad0, opcode=opcode@entry=2, data=<optimized out>, flags=<optimized out>) at ../src/connection.c:1025
#10 0x00007f14c6bfa103 in dispatch_event (display=display@entry=0x5602eb5ed060, queue=<optimized out>, queue=<optimized out>) at ../src/wayland-client.c:1583
#11 0x00007f14c6bfa2dc in dispatch_queue (queue=0x5602eb5ed130, display=0x5602eb5ed060) at ../src/wayland-client.c:1729
#12 wl_display_dispatch_queue_pending (display=0x5602eb5ed060, queue=0x5602eb5ed130) at ../src/wayland-client.c:1971
#13 0x00007f14c6c84d0a in QtWaylandClient::QWaylandDisplay::flushRequests (this=<optimized out>) at qwaylanddisplay.cpp:253
#14 0x00007f14c995f4ae in QObject::event (this=0x5602eb5e8b40, e=0x7f14bc008c20) at kernel/qobject.cpp:1314
#15 0x00007f14ca5e6a7f in QApplicationPrivate::notify_helper (this=<optimized out>, receiver=0x5602eb5e8b40, e=0x7f14bc008c20) at kernel/qapplication.cpp:3632
#16 0x00007f14c9932e3a in QCoreApplication::notifyInternal2 (receiver=0x5602eb5e8b40, event=0x7f14bc008c20) at kernel/qcoreapplication.cpp:1064
#17 0x00007f14c9935e77 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x5602eb5a2480) at kernel/qcoreapplication.cpp:1821
#18 0x00007f14c998ad03 in postEventSourceDispatch (s=s@entry=0x5602eb611a40) at kernel/qeventdispatcher_glib.cpp:277
#19 0x00007f14c7448e22 in g_main_dispatch (context=0x5602eb5e88a0) at ../glib/gmain.c:3381
#20 g_main_context_dispatch (context=0x5602eb5e88a0) at ../glib/gmain.c:4099
#21 0x00007f14c74491b8 in g_main_context_iterate (context=context@entry=0x5602eb5e88a0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at ../glib/gmain.c:4175
#22 0x00007f14c744926f in g_main_context_iteration (context=0x5602eb5e88a0, may_block=1) at ../glib/gmain.c:4240
#23 0x00007f14c998a384 in QEventDispatcherGlib::processEvents (this=0x5602eb6056d0, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#24 0x00007f14c993183b in QEventLoop::exec (this=this@entry=0x7ffefb777480, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:69
#25 0x00007f14c9939b10 in QCoreApplication::exec () at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#26 0x00007f14c9e8825c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1867
#27 0x00007f14ca5e69f5 in QApplication::exec () at kernel/qapplication.cpp:2824
#28 0x00005602e9a1fe97 in main (argc=<optimized out>, argv=<optimized out>) at /usr/src/debug/systemsettings5-5.24.2-1.1.x86_64/app/main.cpp:183
[Inferior 1 (process 11041) detached]

*** This bug has been marked as a duplicate of bug 451028 ***