Bug 409778 - System Settings, Tumbleeweed KCMs crashes.
Summary: System Settings, Tumbleeweed KCMs crashes.
Status: RESOLVED FIXED
Alias: None
Product: systemsettings
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords: drkonqi
: 409794 409817 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-07-14 02:12 UTC by Tony
Modified: 2019-07-16 15:41 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tony 2019-07-14 02:12:30 UTC
Application: systemsettings5 (5.16.80)

Qt Version: 5.13.0
Frameworks Version: 5.61.0
Operating System: Linux 5.1.16-1-default x86_64
Distribution: openSUSE Tumbleweed

-- Information about the crash:
- What I was doing when the application crashed:

Clicked on "look and feel"

Most of the items in system settings crash it no matter the type of view used, wth the exception of:
Window Management, Shorcuts, Startup and Shutdown, Search, Account Details, Online accounts, Connections, Input devices, Power management.

The crash can be reproduced every time.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f83f67d5900 (LWP 7915))]

Thread 4 (Thread 0x7f83e214f700 (LWP 7921)):
#0  0x00007f83f54855ea in std::__atomic_base<QMutexData*>::compare_exchange_strong (__m2=std::memory_order_relaxed, __m1=std::memory_order_release, __p2=0x0, __p1=<synthetic pointer>: 0x1, this=this@entry=0x55aeb4f38980) at /usr/include/c++/9/bits/atomic_base.h:769
#1  std::atomic<QMutexData*>::compare_exchange_strong (__m2=std::memory_order_relaxed, __m1=std::memory_order_release, __p2=0x0, __p1=<synthetic pointer>: 0x1, this=this@entry=0x55aeb4f38980) at /usr/include/c++/9/atomic:565
#2  QAtomicOps<QMutexData*>::testAndSetRelease<QMutexData*> (currentValue=<synthetic pointer>, newValue=0x0, expectedValue=0x1, _q_value=...) at ../../include/QtCore/../../src/corelib/thread/qatomic_cxx11.h:299
#3  QBasicAtomicPointer<QMutexData>::testAndSetRelease (currentValue=<synthetic pointer>: <optimized out>, newValue=0x0, expectedValue=0x1, this=this@entry=0x55aeb4f38980) at ../../include/QtCore/../../src/corelib/thread/qbasicatomic.h:265
#4  QBasicMutex::fastTryUnlock (current=<synthetic pointer>: <optimized out>, this=this@entry=0x55aeb4f38980) at thread/qmutex.h:110
#5  QMutex::unlock (this=this@entry=0x55aeb4f38980) at thread/qmutex.cpp:335
#6  0x00007f83f56a2bee in QMutexLocker::unlock (this=<synthetic pointer>) at ../../include/QtCore/../../src/corelib/thread/qmutex.h:240
#7  QMutexLocker::~QMutexLocker (this=<synthetic pointer>, __in_chrg=<optimized out>) at ../../include/QtCore/../../src/corelib/thread/qmutex.h:213
#8  QThreadData::canWaitLocked (this=0x55aeb4f38950) at ../../include/QtCore/5.13.0/QtCore/private/../../../../../src/corelib/thread/qthread_p.h:272
#9  postEventSourcePrepare (s=0x7f83dc004780, timeout=0x7f83e214eab4) at kernel/qeventdispatcher_glib.cpp:260
#10 0x00007f83f347929f in g_main_context_prepare () from /usr/lib64/libglib-2.0.so.0
#11 0x00007f83f3479c5b in ?? () from /usr/lib64/libglib-2.0.so.0
#12 0x00007f83f3479e4f in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#13 0x00007f83f56a2ceb in QEventDispatcherGlib::processEvents (this=0x7f83dc000b20, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#14 0x00007f83f564b2eb in QEventLoop::exec (this=this@entry=0x7f83e214ec80, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:140
#15 0x00007f83f5483f91 in QThread::exec (this=this@entry=0x55aeb4e0b790) at ../../include/QtCore/../../src/corelib/global/qflags.h:120
#16 0x00007f83f4964595 in QQmlThreadPrivate::run (this=0x55aeb4e0b790) at /usr/src/debug/libqt5-qtdeclarative-5.13.0-ku.1.3.x86_64/src/qml/qml/ftw/qqmlthread.cpp:152
#17 0x00007f83f5485112 in QThreadPrivate::start (arg=0x55aeb4e0b790) at thread/qthread_unix.cpp:360
#18 0x00007f83f3e28faa in start_thread () from /lib64/libpthread.so.0
#19 0x00007f83f6ccd73f in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7f83eb9af700 (LWP 7918)):
#0  0x00007f83f34c4898 in g_mutex_lock () from /usr/lib64/libglib-2.0.so.0
#1  0x00007f83f34792aa in g_main_context_prepare () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f83f3479c5b in ?? () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f83f3479e4f in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#4  0x00007f83f56a2ceb in QEventDispatcherGlib::processEvents (this=0x7f83e4000b20, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#5  0x00007f83f564b2eb in QEventLoop::exec (this=this@entry=0x7f83eb9aec70, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:140
#6  0x00007f83f5483f91 in QThread::exec (this=<optimized out>) at ../../include/QtCore/../../src/corelib/global/qflags.h:120
#7  0x00007f83f459f4f6 in ?? () from /usr/lib64/libQt5DBus.so.5
#8  0x00007f83f5485112 in QThreadPrivate::start (arg=0x7f83f4621d80) at thread/qthread_unix.cpp:360
#9  0x00007f83f3e28faa in start_thread () from /lib64/libpthread.so.0
#10 0x00007f83f6ccd73f in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f83f08af700 (LWP 7917)):
#0  0x00007f83f6cc2cbf in poll () from /lib64/libc.so.6
#1  0x00007f83f3dddcc2 in ?? () from /usr/lib64/libxcb.so.1
#2  0x00007f83f3ddf8ba in xcb_wait_for_event () from /usr/lib64/libxcb.so.1
#3  0x00007f83f0b1af48 in QXcbEventQueue::run (this=0x55aeb48f09f0) at qxcbeventqueue.cpp:228
#4  0x00007f83f5485112 in QThreadPrivate::start (arg=0x55aeb48f09f0) at thread/qthread_unix.cpp:360
#5  0x00007f83f3e28faa in start_thread () from /lib64/libpthread.so.0
#6  0x00007f83f6ccd73f in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f83f67d5900 (LWP 7915)):
[KCrash Handler]
#6  0x00007f83f567d9a8 in qGetPtrHelper<QScopedPointer<QObjectData, QScopedPointerDeleter<QObjectData> > > (ptr=...) at kernel/qobject.cpp:3970
#7  QObject::d_func (this=<optimized out>) at kernel/qobject.h:121
#8  QObject::property (this=0x0, name=name@entry=0x7f83f6b9e70c "pageStack") at kernel/qobject.cpp:3971
#9  0x00007f83f6b9982d in KCModuleQml::KCModuleQml (args=..., parent=<optimized out>, configModule=<optimized out>, this=0x55aeb4f3b730) at /usr/src/debug/kcmutils-5.60.0git.20190713T082840~4bb80c1-ku.49.1.x86_64/src/kcmoduleqml.cpp:162
#10 KCModuleLoader::loadModule (mod=..., report=<optimized out>, parent=<optimized out>, args=...) at /usr/src/debug/kcmutils-5.60.0git.20190713T082840~4bb80c1-ku.49.1.x86_64/src/kcmoduleloader.cpp:106
#11 0x00007f83f6b91aef in KCModuleProxyPrivate::loadModule (this=this@entry=0x55aeb4f363f0) at /usr/src/debug/kcmutils-5.60.0git.20190713T082840~4bb80c1-ku.49.1.x86_64/src/kcmoduleproxy.cpp:102
#12 0x00007f83f6b92308 in KCModuleProxy::realModule (this=<optimized out>) at /usr/src/debug/kcmutils-5.60.0git.20190713T082840~4bb80c1-ku.49.1.x86_64/src/kcmoduleproxy.cpp:75
#13 0x00007f83f6bc0b37 in ModuleView::updatePageIconHeader(KPageWidgetItem*, bool) () from /usr/lib64/libsystemsettingsview.so.3
#14 0x00007f83f6bc1ee1 in ModuleView::addModule(KCModuleInfo*) () from /usr/lib64/libsystemsettingsview.so.3
#15 0x00007f83f6bc360d in ModuleView::loadModule(QModelIndex const&) () from /usr/lib64/libsystemsettingsview.so.3
#16 0x00007f83f5677a08 in QtPrivate::QSlotObjectBase::call (a=0x7ffe9de2aee0, r=0x55aeb4cc9830, this=0x55aeb4bec8e0) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:394
#17 QMetaObject::activate (sender=0x55aeb4ced750, signalOffset=<optimized out>, local_signal_index=<optimized out>, argv=<optimized out>) at kernel/qobject.cpp:3787
#18 0x00007f83f62e1985 in QAbstractItemView::activated (this=this@entry=0x55aeb4ced750, _t1=...) at .moc/moc_qabstractitemview.cpp:668
#19 0x00007f83f62e5b35 in QAbstractItemView::mouseReleaseEvent (this=0x55aeb4ced750, event=<optimized out>) at itemviews/qabstractitemview.cpp:1939
#20 0x00007f83f632c53f in QListView::mouseReleaseEvent (this=<optimized out>, e=<optimized out>) at itemviews/qlistview.cpp:798
#21 0x00007f83f504fd83 in KCategorizedView::mouseReleaseEvent (this=0x55aeb4ced750, event=0x7ffe9de2b8c0) at /usr/src/debug/kitemviews-5.60.0git.20190713T083120~b66c829-ku.34.1.x86_64/src/kcategorizedview.cpp:1048
#22 0x00007f83f60c3d06 in QWidget::event (this=this@entry=0x55aeb4ced750, event=event@entry=0x7ffe9de2b8c0) at kernel/qwidget.cpp:8962
#23 0x00007f83f6171a1e in QFrame::event (this=0x55aeb4ced750, e=0x7ffe9de2b8c0) at widgets/qframe.cpp:550
#24 0x00007f83f62ef8de in QAbstractItemView::viewportEvent (this=0x55aeb4ced750, event=0x7ffe9de2b8c0) at itemviews/qabstractitemview.cpp:1753
#25 0x00007f83f564c3a3 in QCoreApplicationPrivate::sendThroughObjectEventFilters (event=<optimized out>, receiver=<optimized out>) at kernel/qcoreapplication.cpp:1191
#26 QCoreApplicationPrivate::sendThroughObjectEventFilters (receiver=receiver@entry=0x55aeb4d024f0, event=event@entry=0x7ffe9de2b8c0) at kernel/qcoreapplication.cpp:1180
#27 0x00007f83f6081c31 in QApplicationPrivate::notify_helper (this=this@entry=0x55aeb48cae70, receiver=receiver@entry=0x55aeb4d024f0, e=e@entry=0x7ffe9de2b8c0) at kernel/qapplication.cpp:3734
#28 0x00007f83f608b113 in QApplication::notify (this=<optimized out>, receiver=0x55aeb4d024f0, e=0x7ffe9de2b8c0) at kernel/qapplication.cpp:3200
#29 0x00007f83f564c692 in QCoreApplication::notifyInternal2 (receiver=0x55aeb4d024f0, event=0x7ffe9de2b8c0) at ../../include/QtCore/../../src/corelib/kernel/qobject.h:142
#30 0x00007f83f608a203 in QApplicationPrivate::sendMouseEvent (receiver=receiver@entry=0x55aeb4d024f0, event=event@entry=0x7ffe9de2b8c0, alienWidget=alienWidget@entry=0x55aeb4d024f0, nativeWidget=0x55aeb4997a00, buttonDown=buttonDown@entry=0x7f83f65ab8b0 <qt_button_down>, lastMouseReceiver=..., spontaneous=true, onlyDispatchEnterLeave=false) at kernel/qapplication.cpp:2686
#31 0x00007f83f60df9c9 in QWidgetWindow::handleMouseEvent (this=0x55aeb4af0780, event=0x7ffe9de2bd40) at /usr/include/c++/9/bits/atomic_base.h:413
#32 0x00007f83f60e2a24 in QWidgetWindow::event (event=0x7ffe9de2bd40, this=0x55aeb4af0780) at kernel/qwidgetwindow.cpp:280
#33 QWidgetWindow::event (this=0x55aeb4af0780, event=0x7ffe9de2bd40) at kernel/qwidgetwindow.cpp:224
#34 0x00007f83f6081c42 in QApplicationPrivate::notify_helper (this=this@entry=0x55aeb48cae70, receiver=receiver@entry=0x55aeb4af0780, e=e@entry=0x7ffe9de2bd40) at kernel/qapplication.cpp:3740
#35 0x00007f83f608aec0 in QApplication::notify (this=0x7ffe9de2c1d0, receiver=0x55aeb4af0780, e=0x7ffe9de2bd40) at kernel/qapplication.cpp:3486
#36 0x00007f83f564c692 in QCoreApplication::notifyInternal2 (receiver=0x55aeb4af0780, event=0x7ffe9de2bd40) at ../../include/QtCore/../../src/corelib/kernel/qobject.h:142
#37 0x00007f83f5a524b8 in QGuiApplicationPrivate::processMouseEvent (e=e@entry=0x55aeb4e54b90) at kernel/qguiapplication.cpp:2111
#38 0x00007f83f5a53d3b in QGuiApplicationPrivate::processWindowSystemEvent (e=e@entry=0x55aeb4e54b90) at kernel/qguiapplication.cpp:1846
#39 0x00007f83f5a2cacb in QWindowSystemInterface::sendWindowSystemEvents (flags=flags@entry=...) at kernel/qwindowsysteminterface.cpp:1148
#40 0x00007f83f0b1be7a in xcbSourceDispatch (source=<optimized out>) at qxcbeventdispatcher.cpp:105
#41 0x00007f83f3479b33 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#42 0x00007f83f3479dc0 in ?? () from /usr/lib64/libglib-2.0.so.0
#43 0x00007f83f3479e4f in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#44 0x00007f83f56a2cd1 in QEventDispatcherGlib::processEvents (this=0x55aeb49977a0, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#45 0x00007f83f564b2eb in QEventLoop::exec (this=this@entry=0x7ffe9de2c0e0, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:140
#46 0x00007f83f5652e62 in QCoreApplication::exec () at ../../include/QtCore/../../src/corelib/global/qflags.h:120
#47 0x000055aeb42ae9b0 in ?? ()
#48 0x00007f83f6bf6bcb in __libc_start_main () from /lib64/libc.so.6
#49 0x000055aeb42aea3a in _start ()
[Inferior 1 (process 7915) detached]

The reporter indicates this bug may be a duplicate of or related to bug 405023.

Possible duplicates by query: bug 406341, bug 405402, bug 405023, bug 403037, bug 402458.

Reported using DrKonqi
Comment 1 Tony 2019-07-15 21:50:39 UTC
No more crashes for me after updating to this:

https://cgit.kde.org/kirigami.git/commit/?id=b6bf03e738e36da1daf5fa0b295d457915949510
Comment 2 Nate Graham 2019-07-15 22:00:37 UTC
*** Bug 409794 has been marked as a duplicate of this bug. ***
Comment 3 Nate Graham 2019-07-16 15:41:05 UTC
*** Bug 409817 has been marked as a duplicate of this bug. ***