Bug 450806 - Under a Plasma Wayland session application size and location not retained after closing application
Summary: Under a Plasma Wayland session application size and location not retained aft...
Status: RESOLVED DUPLICATE of bug 15329
Alias: None
Product: kwin
Classification: Plasma
Component: effects-window-management (show other bugs)
Version: 5.24.0
Platform: openSUSE Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-02-24 14:59 UTC by tneo
Modified: 2022-03-20 14:20 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tneo 2022-02-24 14:59:20 UTC
SUMMARY
Under KDE Plasma Wayland my applications don't re-open on the location where I have saved them. I have my windows always taking up half, quarters or full-screen. Under X11 the location where I have closed my window is saved. With Wayland the location varies and is not what I want it to be.

STEPS TO REPRODUCE
1. Start Wayland session
2. Open konsole and set it to cover the bottom-half of the screen horizontally
3. Close konsole
4. Re-open konsole

OBSERVED RESULT
- Konsole is not opened in the bottom-half but opened in the top-left. It does cover the screen half horizontally, but the location is not correct. 
- KeepassXC is always starting with my plasma session. I want it to show up on the right side of the screen for my flow. But it consistently opens on the left side and without the right size that I left it. 

EXPECTED RESULT
Applications open in the location I have closed them as they do under X11. Windows retain the correct size as I have closed them as under X11

SOFTWARE/OS VERSIONS
Operating System: openSUSE Tumbleweed 20220216
KDE Plasma Version: 5.24.0
KDE Frameworks Version: 5.90.0
Qt Version: 5.15.2
Kernel Version: 5.16.8-1-default (64-bit)
Graphics Platform: Wayland


ADDITIONAL INFORMATION
1. I'm not sure this is the correct product and component. Please update accordingly.
2. Windows are set to open with minimal overlap.
Comment 1 Nate Graham 2022-03-20 14:20:58 UTC
Yeah, this doesn't work on Wayland the way we could make it (kind of) work on X11. It needs Bug 15329 to be implemented.

*** This bug has been marked as a duplicate of bug 15329 ***