Bug 450322 - numpad stops working after changing keyboard delay/rate
Summary: numpad stops working after changing keyboard delay/rate
Status: REPORTED
Alias: None
Product: systemsettings
Classification: Applications
Component: kcm_keyboard (show other bugs)
Version: 5.26.90
Platform: Archlinux Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-02-15 17:15 UTC by Patrick Silva
Modified: 2023-01-23 21:33 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Silva 2022-02-15 17:15:48 UTC
STEPS TO REPRODUCE
1. use Wayland
2. make sure the numpad (numeric keys in the right side) of your keyboard is enabled
3. open Keyboard KCM
4. change delay or rate on bottom and apply the change
5. try to type any number in the 'Test area' field on bottom using the numpad: typed number does no appear
6. press alt key
7. type any number in 'Test area' again: now the typed number appears

EXPECTED RESULT
numpad always work

SOFTWARE/OS VERSIONS
Operating System: Arch Linux
KDE Plasma Version: 5.24.1
KDE Frameworks Version: 5.91.0
Qt Version: 5.15.2
Graphics Platform: Wayland
Comment 1 Andrey 2022-02-15 19:27:41 UTC
Does NumLock help also?
Please test on 5.23, possibly a regression
Comment 2 Patrick Silva 2022-02-15 19:38:10 UTC
Pressing numlock in the step 6 instead of alt does not help. It just turns my numpad off.
Comment 3 Patrick Silva 2022-02-16 12:39:46 UTC
Also reproducible on neon user.

Operating System: KDE neon 5.23
KDE Plasma Version: 5.23.4
KDE Frameworks Version: 5.89.0
Qt Version: 5.15.3
Kernel Version: 5.11.0-43-generic (64-bit)
Graphics Platform: Wayland
Comment 4 Bug Janitor Service 2022-03-03 04:35:49 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 5 Patrick Silva 2022-03-06 15:15:41 UTC
Requested info was provided.