Bug 449348 - Unable to launch recently used apps from "history" and "frequently used" tabs
Summary: Unable to launch recently used apps from "history" and "frequently used" tabs
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Application Launcher (Kickoff) (show other bugs)
Version: 5.23.5
Platform: Manjaro Linux
: VHI normal
Target Milestone: 1.0
Assignee: David Edmundson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-01-29 23:12 UTC by xmilosobilic
Modified: 2022-02-14 19:16 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.24.1


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description xmilosobilic 2022-01-29 23:12:28 UTC
STEPS TO REPRODUCE
1. Run few apps to populate recent apps
2. go to application launcher (kickoff) -> places -> history or frequently used (same behaviour)
3. try to start any app from those recent apps

OBSERVED RESULT
nothing happens, except for the apps that were there when adding widget for kickoff, only those launch

EXPECTED RESULT
recent apps to launch

ADDITIONAL INFORMATION
having same problem when using fullscreen "application dashboard" as well
Comment 1 Patrick Silva 2022-01-30 14:01:21 UTC
related to bug 445331
Comment 2 Nate Graham 2022-02-01 22:29:24 UTC
Works for me FWIW.
Comment 3 xmilosobilic 2022-02-02 17:04:48 UTC
Try for example clearing all the recent apps first, then start some app normally, close it, wait for it to show up in recent apps, and then run it from there, it never works for me that way
Comment 4 Nate Graham 2022-02-02 20:34:04 UTC
Nope, that works for me too.
Comment 5 xmilosobilic 2022-02-02 21:06:13 UTC
is there a way to launch app menu through konsole to see the output when i click on recent apps, it could be helpful?
Comment 6 xmilosobilic 2022-02-02 21:59:43 UTC
UPDATE: I used commands "plasmawindowed org.kde.plasma.kicker" and "plasmawindowed org.kde.plasma.kickerdash" to start menus in konsole, repeated the previous steps, and the output when it doesn't want to start recent app is "kf.service.services: KApplicationTrader: mimeType " " not found", does that sound anything helpful? so it's the same output no matter which appmenu i use
Comment 7 Nate Graham 2022-02-02 23:17:43 UTC
That is helpful, yes!
Comment 8 Oleg Solovyov 2022-02-10 14:46:26 UTC
Just reproduced on fresh Neon Unstable
Comment 9 Oleg Solovyov 2022-02-11 07:55:06 UTC
in RecentUsageModel::trigger:

if (!mimeType.isEmpty()) { // mimeType == " ", isEmpty() == false

I don't think it's what we want
Comment 10 Patrick Silva 2022-02-13 13:10:05 UTC
I can reproduce with apps launched after restarting plasma by running 'plasmashell --replace' with krunner.
Possibly related to bug 439159.

1. restarting plasma by running 'plasmashell --replace' with krunner
2. launch an app via kickoff (tested Ark on my system)
3. close the app used in the step 2
3. try to re-open the app used in the step 2 via kickoff > Places > History

Result: nothing happens.

Operating System: Arch Linux
KDE Plasma Version: 5.24.0
KDE Frameworks Version: 5.90.0
Qt Version: 5.15.2
Graphics Platform: Wayland
Comment 11 Nate Graham 2022-02-14 15:02:44 UTC
Fixed by Oleg Solovyov with https://invent.kde.org/plasma/plasma-workspace/-/commit/f73c6b49104aed89e861316d68350cf2841d9e18 in Plasma 5.24.1!