Bug 445331 - An app installed during current Plasma session can not be re-launched via 'History' section of Kickoff until plasmashell process is restarted
Summary: An app installed during current Plasma session can not be re-launched via 'Hi...
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Application Launcher (Kickoff) (show other bugs)
Version: master
Platform: Other Linux
: NOR normal
Target Milestone: 1.0
Assignee: David Edmundson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-11-11 12:59 UTC by Patrick Silva
Modified: 2022-05-23 19:51 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Silva 2021-11-11 12:59:48 UTC
STEPS TO REPRODUCE
1. install an app (I installed Filelight by running APT in Konsole)
2. open the app installed in the step 1
3. close the app
4. open Kickoff, click on 'Places' on bottom, hover over 'History', click on the app used in the step 2

OBSERVED RESULT
Nothing happens. If I restart Plasma with 'plasmashell --replace' and then repeat the last step, kickoff launches the app as
expected.

EXPECTED RESULT
kickoff should always launch an app clicked under 'History' section.

SOFTWARE/OS VERSIONS
Operating System: KDE neon Unstable Edition
KDE Plasma Version: 5.23.80
KDE Frameworks Version: 5.88.0
Qt Version: 5.15.3
Graphics Platform: Wayland
Comment 1 Patrick Silva 2022-05-23 19:51:34 UTC
Cannot reproduce either on Arch Linux or neon unstable. :)

Operating System: Arch Linux
KDE Plasma Version: 5.24.90
KDE Frameworks Version: 5.94.0
Qt Version: 5.15.4
Graphics Platform: Wayland