Bug 449024 - Unable to fetch google calendar events
Summary: Unable to fetch google calendar events
Status: RESOLVED FIXED
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: Google Resource (show other bugs)
Version: 5.18.1
Platform: Kubuntu Linux
: NOR major with 202 votes (vote)
Target Milestone: ---
Assignee: Daniel Vrátil
URL:
Keywords:
: 448879 449062 449072 449089 449300 449466 449512 449542 (view as bug list)
Depends on:
Blocks:
 
Reported: 2022-01-23 18:08 UTC by sai
Modified: 2022-06-11 19:32 UTC (History)
41 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Patch to disable sync of google contacts (722 bytes, patch)
2022-01-25 16:06 UTC, Radek Hušek
Details
attachment-18194-0.html (3.53 KB, text/html)
2022-02-02 10:29 UTC, B. Scheichl
Details
attachment-10630-0.html (2.44 KB, text/html)
2022-02-20 07:08 UTC, B. Scheichl
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sai 2022-01-23 18:08:43 UTC
SUMMARY
***
NOTE: If you are reporting a crash, please try to attach a backtrace with debug symbols.
See https://community.kde.org/Guidelines_and_HOWTOs/Debugging/How_to_create_useful_crash_reports
***
I am trying to get my google calendar events in Korganizer, but I am unable to do so with google groupware. After I add the google groupware from settings > calendar > add google groupware > configure I am able to see the calendars and they are selected automatically. But, after I close the window the main settings window shows that it is trying to retrieve the tasks but I don't see any message about calendars. Then It says its ready, but no google calendars are visible in the main korganizer window.

Also, is it possible to have a manual sync button available? It is important as you cannot force the user to wait for a long time until it syncs automatically for every event added in another platform.


OBSERVED RESULT
No google calendars are visible

EXPECTED RESULT
Google Calendars are visible and synced automatically.

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: 5.15.16-1-MANJARO
(available in About System)
KDE Plasma Version: 5.23.5
KDE Frameworks Version: 5.90.0
Qt Version: 5.15.2

ADDITIONAL INFORMATION
Comment 1 Jack 2022-01-23 19:45:12 UTC
Currently happening with 5.19.1(21.12.1).

I have what I think is the same problem, and it has recently gotten worse, on both Gentoo and Artix Linux instances.  The Artix system has been doing it for several weeks, but the Gentoo system only started this within the past days.
Previously, when I started KOrganizer, no events were shown at all, and the Google stuff was NOT shown in the list of calendars/items in the lower left pane.  At that point, I could Settings/Configure KOrganizer Calendar tabs, select Google Groupware and click Restart. and all calendar items would appear, and the Google items showed up on the lower left pane list.  Now, when I click Restart, it briefly shows Retrieving Tasks (0%) and never does retrieve anything.
The Akonadi log shows:
-----
org.kde.pim.akonadiserver: Subscriber "AgentBaseChangeRecorder - 94412740835952" disconnected
org.kde.pim.akonadicontrol: Restarting application '/usr/bin/akonadi_google_resource'.
org.kde.pim.akonadiserver: New notification connection (registered as Akonadi::Server::NotificationSubscriber(0x7f8c9c04fa50) )
org.kde.pim.akonadiserver: Subscriber Akonadi::Server::NotificationSubscriber(0x7f8c9c04fa50) identified as "AgentBaseChangeRecorder - 94654227339024"
org.kde.kgapi: Bad request, Google replied ' "Contacts API is being deprecated. Migrate to People API to retain programmatic access to Google Contacts. See https://developers.google.com/people/contacts-api-migration." '
org.kde.pim.google: Got error: KGAPI2::ContactsGroupFetchJob(0x5616679d8200) "Bad request."
-----
when I click Restart.

I am not intentionally requesting to sync contacts, so I'm not sure why it's trying to retrieve them.

I can delete the Google  Groupware entry and re-create it with no errors, but am still unable to retrieve any actual data.
Comment 2 Michael D 2022-01-24 11:49:25 UTC
Same issue on Manjaro testing. I've tried removing and adding the calendar to no avail. Calendars don't show in korganizer, kalendar, or the pim plug-in for the digital clock, so it's not really a korganizer bug, but seems an akonadi bug.
Comment 3 Simon 2022-01-24 15:52:30 UTC
Same issue on Arch.
Comment 4 Anna Ochab-Marcinek 2022-01-24 17:49:21 UTC
same here. Kubuntu 21.04, KOrganizer Version 5.16.3 (20.12.3)
Comment 5 Thibaud de Borggraef 2022-01-24 18:46:39 UTC
Same here 
OpenSUSE Tumbleweed KOrganizer 5.19.1 (21.12.1)
Comment 6 Torsten Bielen 2022-01-25 09:12:32 UTC
same for kontact 5.19.1 (21.12.1)
kde neon (latest version)
Comment 7 Lars Scheiter 2022-01-25 12:00:04 UTC
is there a chance to disable google-contacts sync, maybe sync stopps at the "Contacts API is being deprecated.." point?
Comment 8 Radek Hušek 2022-01-25 16:06:40 UTC
Created attachment 145926 [details]
Patch to disable sync of google contacts
Comment 9 Radek Hušek 2022-01-25 16:08:46 UTC
The attached patch to kdepim-runtime which disables contacts sync resolves the issue with calendar sync for me. Of course it is more of a band aid than real solution which is to port the contacts to the new api.
Comment 10 Jack 2022-01-25 18:16:39 UTC
Thanks.  That patch works for me, allowing korganizer to fetch my google calendar.  Fortunately, I don't use google contacts, so I'm not missing anything.
Comment 11 Terry Barnaby 2022-01-25 19:41:05 UTC
Same issue on Fedora35, recently stopped working.
Comment 12 Terry Barnaby 2022-01-25 20:16:32 UTC
Actually it may be a slightly different bug on Fedora35 this is using kdepim-runtime-21.08.3-2.fc35.x86_64.rpm and looking at the code the "m_handlers.push_back(GenericHandler::Ptr(new ContactHandler(m_iface, m_settings)));" line as patched in the above patch is not present.
Otherwise the result is the same: The calendar is in the Settings and you can use the restart button and the calendar is reported as Ready, but it does not appear in the KOganizer's main window  bottom left panel and no calendar items appear. No error messages, just nothing happening (Oh why doesn't software print/display error messages and issue info these days :( ).
Not sure where the Akonadi log mentioned above is, but the file ~.local/share/akonadi/Akonadi.error does not appear to have any errors reported.
Comment 13 sai 2022-01-25 23:19:29 UTC
*** This bug has been confirmed by popular vote. ***
Comment 14 Senén 2022-01-27 11:37:37 UTC
Same problem in Debian 11.2, Kontact and Akonadi 5.15.3 (20.08.3).
org.kde.kgapi: Bad request, Google replied ' "Contacts API is being deprecated. Migrate to People API to retain programmatic access to Google Contacts. See https://developers.google.com/people/contacts-api-migration." '
org.kde.pim.google: Got error: KGAPI2::ContactsGroupFetchJob(0x55894e3477f0) "Petición incorrecta."
Comment 15 Geoffrey Clements 2022-01-27 13:39:38 UTC
*** Bug 449072 has been marked as a duplicate of this bug. ***
Comment 16 Nataniel 2022-01-27 14:49:19 UTC
(In reply to Radek Hušek from comment #8)
> Created attachment 145926 [details]
> Patch to disable sync of google contacts

Looking for a way to run this patch. How are we supposed to use it? I tried copying the contents on kate and then make it executable but nothing happens... Thanks
Comment 17 Geoffrey Clements 2022-01-27 15:00:17 UTC
(In reply to Nataniel from comment #16)

> Looking for a way to run this patch. How are we supposed to use it? I tried
> copying the contents on kate and then make it executable but nothing
> happens... Thanks

Patches are "run" using the patch command but you'll need the full source to run it on and then compile, link and install. I respectfully suggest that if you don't know how to apply a patch then you're probably best waiting for the binary update.
Comment 18 bginsburg 2022-01-27 15:25:03 UTC
I am not sure if this helps or not, but I switched over to Thunderbird 91.5.1 and it is displaying and editing the Google calendars normally. I did have to delete and re-subscribe to them before they were fully functional. I just mention this in case the developers can find useful info from the Thunderbird plugin.
Comment 19 Francisco Cribari 2022-01-28 16:08:52 UTC
I am also experiencing this bug on Arch Linux.
Comment 20 Anna Ochab-Marcinek 2022-01-28 19:28:31 UTC
The bug is still present after system upgrade: Now Kubuntu 21.10, KOrganizer version 5.18.1 (21.08.1)
Comment 21 bginsburg 2022-01-28 19:34:42 UTC
I am running:
Korganizer: Version 5.19.1 (21.12.1)

KDE Plasma: Version 5.23.5

KDE Frameworks: Version 5.90.0

on Arch: Kernel 5.16.2-arch1-1

and am experiencing this bug.
Comment 22 Antonio Rojas 2022-01-28 22:40:45 UTC
*** Bug 449300 has been marked as a duplicate of this bug. ***
Comment 23 Antonio Rojas 2022-02-01 19:11:51 UTC
*** Bug 449466 has been marked as a duplicate of this bug. ***
Comment 24 Kedar Apte 2022-02-02 08:46:48 UTC
I am able to add google calendar, but it is not seen in Korganizer. When I click on Add calendar, it shows, I have the calendar, but events are not seen. Neither can I accept events in the google calendar. 

Below is my version levels
KDE Neon 5.23 - user edition
KDE Plasma Version: 5.23.5
KDE Frameworks Version: 5.90.0
QT Version: 5.15.3
Kernel Version: 5.13.0-28-generic
Graphics Platform: X11
Korganizer Version: 5.19.1 (21.12.1)
Comment 25 Kedar Apte 2022-02-02 08:48:12 UTC
(In reply to Terry Barnaby from comment #11)
> Same issue on Fedora35, recently stopped working.

correctly articulated
Comment 26 B. Scheichl 2022-02-02 10:29:02 UTC
Created attachment 146159 [details]
attachment-18194-0.html

Dear Antonio,


many thanks for this. Do you know a time schedule for solving the issue & implementing an update into the distros? There is another well-known bug (I did not file) and may be resolved simultaneously: Google dates entered in external devices, such as under Android, are synced and displayed correctly in KOrganizer - but it does not work the other way round. That is, Google dates scheduled directly in KOrganizer are not synced. Is this going to be solved as well?


Kind regards,

Bernhard


On Tuesday, 1 February 2022 20:11:51 CET you wrote:

> https://bugs.kde.org/show_bug.cgi?id=449024

>

> Antonio Rojas <arojas@archlinux.org> changed:

>

>            What    |Removed                     |Added

> ----------------------------------------------------------------------------

> CC|                            |bernhard.scheichl@tuwien.ac

>                    |                            |.at

>

> --- Comment #23 from Antonio Rojas <arojas@archlinux.org> ---

> *** Bug 449466 has been marked as a duplicate of this bug. ***



________________________________

Priv.-Doz. DI Dr. Bernhard Scheichl

Technische Universität Wien | Institute of Fluid Mechanics and Heat Transfer

Tower BA/E322 | Getreidemarkt 9 | 1060 Vienna | Austria

T: +43-1-58801-32225 | www.fluid.tuwien.ac.at<http://www.fluid.tuwien.ac.at/>
Comment 27 bginsburg 2022-02-02 14:18:32 UTC
(In reply to bginsburg from comment #21)
> I am running:
> Korganizer: Version 5.19.1 (21.12.1)
> 
> KDE Plasma: Version 5.23.5
> 
> KDE Frameworks: Version 5.90.0
> 
> on Arch: Kernel 5.16.2-arch1-1
> 
> and am experiencing this bug.

I can confirm the attached patch restored google calendar function to KOrganizer and Event Calendar widget.
Comment 28 Antonio Rojas 2022-02-02 17:35:26 UTC
*** Bug 449512 has been marked as a duplicate of this bug. ***
Comment 29 Antonio Rojas 2022-02-02 17:36:28 UTC
*** Bug 449062 has been marked as a duplicate of this bug. ***
Comment 30 Antonio Rojas 2022-02-03 09:07:22 UTC
*** Bug 449089 has been marked as a duplicate of this bug. ***
Comment 31 Antonio Rojas 2022-02-03 09:07:54 UTC
*** Bug 449542 has been marked as a duplicate of this bug. ***
Comment 32 a.key 2022-02-03 14:06:18 UTC
The patch does work on Fedora 35 KDE.
Comment 33 siauderman 2022-02-06 15:22:04 UTC
(In reply to a.key from comment #32)
> The patch does work on Fedora 35 KDE.

Hi, does anyone know how to apply the patch on Kubuntu? Would like to use KDE PIM Events plugin. Thanks.
Comment 34 Laurent Montel 2022-02-07 06:00:23 UTC
Git commit 624ef213e50ae4712bfe2a254c5f444caaacfa22 by Laurent Montel.
Committed on 07/02/2022 at 05:58.
Pushed by mlaurent into branch 'release/21.12'.

Apply patch for disable sync contact as it don't ported yet.

M  +2    -0    resources/google-groupware/googleresource.cpp

https://invent.kde.org/pim/kdepim-runtime/commit/624ef213e50ae4712bfe2a254c5f444caaacfa22
Comment 35 siauderman 2022-02-20 06:49:48 UTC
(In reply to siauderman from comment #33)
> (In reply to a.key from comment #32)
> > The patch does work on Fedora 35 KDE.
> 
> Hi, does anyone know how to apply the patch on Kubuntu? Would like to use
> KDE PIM Events plugin. Thanks.

I just did a plasma update today and it still doesn't work. Version 5.19.2 (21.12.2).
Comment 36 B. Scheichl 2022-02-20 07:08:05 UTC
Created attachment 146964 [details]
attachment-10630-0.html

Same experience - several updates over the last weeks (Tumbleweed), still not working. Very annoying, as it had worked until January.

B. Scheichl (TU Wien). From my mobile.
________________________________
Von: bugzilla_noreply@kde.org
Gesendet: Sonntag, 20. Februar 2022 07:50
An: Scheichl, Bernhard
Betreff: [Akonadi] [Bug 449024] Unable to fetch google calendar events

https://bugs.kde.org/show_bug.cgi?id=449024

--- Comment #35 from siauderman@hotmail.com ---
(In reply to siauderman from comment #33)
> (In reply to a.key from comment #32)
> > The patch does work on Fedora 35 KDE.
>
> Hi, does anyone know how to apply the patch on Kubuntu? Would like to use
> KDE PIM Events plugin. Thanks.

I just did a plasma update today and it still doesn't work. Version 5.19.2
(21.12.2).

--
You are receiving this mail because:
You are on the CC list for the bug.
Comment 37 Torsten Bielen 2022-02-21 11:30:13 UTC
Same behavior under kde neon. The bug still exists, unfortunately. The bug is really very annoying.

KDE-Neon: 5.24
Plasma: 5.24.1
Framework: 5.91.0
Comment 38 Michael D 2022-02-21 11:37:37 UTC
Works again on Manjaro testing.
Comment 39 a.key 2022-02-21 12:25:29 UTC
(In reply to B. Scheichl from comment #36)
> Created attachment 146964 [details]
> attachment-10630-0.html
> 
> Same experience - several updates over the last weeks (Tumbleweed), still
> not working. Very annoying, as it had worked until January.
> 
> B. Scheichl (TU Wien). From my mobile.
> ________________________________
> Von: bugzilla_noreply@kde.org
> Gesendet: Sonntag, 20. Februar 2022 07:50
> An: Scheichl, Bernhard
> Betreff: [Akonadi] [Bug 449024] Unable to fetch google calendar events
> 
> https://bugs.kde.org/show_bug.cgi?id=449024
> 
> --- Comment #35 from siauderman@hotmail.com ---
> (In reply to siauderman from comment #33)
> > (In reply to a.key from comment #32)
> > > The patch does work on Fedora 35 KDE.
> >
> > Hi, does anyone know how to apply the patch on Kubuntu? Would like to use
> > KDE PIM Events plugin. Thanks.
> 
> I just did a plasma update today and it still doesn't work. Version 5.19.2
> (21.12.2).
> 
> --
> You are receiving this mail because:
> You are on the CC list for the bug.

Yeah, I meant that a package with the patch applied does fix this on Fedora.
The version of kdepim-runtime from marcdeop/plasma copr is unpatched hence I had to apply the patch manually and recompile.
Comment 40 Michael D 2022-02-21 12:31:09 UTC
By working, I mean event fetching only. Obviously contacts don't sync which affects kaddressbook and kmail. Should a separate bug be filed about this?
Comment 41 siauderman 2022-03-05 06:57:22 UTC
Thank you for fixing it! It works now, I just updated on Kubuntu!
Comment 42 Iraklis Tsoupouroglou 2022-03-05 14:35:54 UTC
On a Neon 5.24 the problem still persists. On a sidenote, tit affects Kalendar, as well.
Comment 43 Kishore Gopalakrishnan 2022-04-11 14:09:52 UTC
*** Bug 448879 has been marked as a duplicate of this bug. ***
Comment 44 kaeslaek 2022-06-04 10:45:33 UTC
Since this is marked as resolved/fixed I would like to ask which version contains this patch? I'm using Fedora 36 with kontact 5.19.2 (21.12.2)
and I can't see Google Calendar.
Comment 45 aleskandro 2022-06-11 19:32:44 UTC
(In reply to kaeslaek from comment #44)
> Since this is marked as resolved/fixed I would like to ask which version
> contains this patch? I'm using Fedora 36 with kontact 5.19.2 (21.12.2)
> and I can't see Google Calendar.

The patch landed on 21.12.3. To overcome the issue on Fedora 35 (21.12.2), I cherry-picked the commit 624ef213e50ae4712bfe2a254c5f444caaacfa22 in a branch based on the v21.12.2 tag and rebuilt kfrpim-runtime.