Bug 448479 - [Systemd, Wayland] kwallet-pam no longer unlocks wallet on login
Summary: [Systemd, Wayland] kwallet-pam no longer unlocks wallet on login
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Plasma
Component: general (show other bugs)
Version: 5.23.90
Platform: Other Linux
: VHI normal
Target Milestone: 1.0
Assignee: David Edmundson
URL:
Keywords: regression, wayland
: 448402 (view as bug list)
Depends on:
Blocks:
 
Reported: 2022-01-14 17:07 UTC by Antonio Rojas
Modified: 2022-06-17 15:33 UTC (History)
10 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.24


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Antonio Rojas 2022-01-14 17:07:05 UTC
Since plasma-workspace commit 7884f53d3c07699dc16f07cf0aa3966802c503c8, kwallet-pam no longer unlocks the wallet after login on Wayland. It works on X11. Using systemd startup.
Comment 1 Nate Graham 2022-01-14 21:39:38 UTC
Merging my earlier bug into this since this one pinpoints the bad commit.
Comment 2 Nate Graham 2022-01-14 21:40:16 UTC
*** Bug 445706 has been marked as a duplicate of this bug. ***
Comment 3 Nicolas Fella 2022-01-20 12:56:57 UTC
*** Bug 448402 has been marked as a duplicate of this bug. ***
Comment 4 Bug Janitor Service 2022-01-20 13:37:49 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/kwallet-pam/-/merge_requests/8
Comment 5 David Edmundson 2022-01-20 15:20:37 UTC
Git commit 2da16355cbbfd01da881f4d3394a46adb268e9a7 by David Edmundson.
Committed on 20/01/2022 at 13:36.
Pushed by ngraham into branch 'master'.

Specify plasma-kwallet should be after wayland

Anything in the old "phase 0" needs dependencies set manually. We need
kwin to be up on wayland.

M  +1    -0    plasma-kwallet-pam.service.in

https://invent.kde.org/plasma/kwallet-pam/commit/2da16355cbbfd01da881f4d3394a46adb268e9a7
Comment 6 Nate Graham 2022-01-20 15:21:55 UTC
Git commit 13d98e5370075b0028fe1ff4266cff9e0fcf4c6a by Nate Graham, on behalf of David Edmundson.
Committed on 20/01/2022 at 15:21.
Pushed by ngraham into branch 'Plasma/5.24'.

Specify plasma-kwallet should be after wayland

Anything in the old "phase 0" needs dependencies set manually. We need
kwin to be up on wayland.


(cherry picked from commit 2da16355cbbfd01da881f4d3394a46adb268e9a7)

M  +1    -0    plasma-kwallet-pam.service.in

https://invent.kde.org/plasma/kwallet-pam/commit/13d98e5370075b0028fe1ff4266cff9e0fcf4c6a