Bug 448402 - Kwallet fails to automatically unlock, even if the login password is the same as the kwallet password, when using systemd startup
Summary: Kwallet fails to automatically unlock, even if the login password is the same...
Status: RESOLVED DUPLICATE of bug 448479
Alias: None
Product: kwallet-pam
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: 5.23.90
Platform: Arch Linux Linux
: NOR normal
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords: regression, usability
Depends on:
Blocks:
 
Reported: 2022-01-13 21:45 UTC by Samuel Reddy
Modified: 2022-01-20 12:56 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Samuel Reddy 2022-01-13 21:45:07 UTC
SUMMARY:
When using systemd startup, kwallet with kwallet-pam fails to automatically unlock, even if the kwallet password is the same as the login password

STEPS TO REPRODUCE:
1. Have systemd startup enabled
2. log into Plasma
3. Kwallet prompt to unlock wallet

OBSERVED RESULT:
A kwallet prompt asks me to unlock kdewallet

EXPECTED RESULT:
The wallet automatically unlocks

SOFTWARE/OS VERSIONS:
Operating System: Arch Linux
KDE Plasma Version: 5.23.90
KDE Frameworks Version: 5.90.0
Qt Version: 5.15.2
Kernel Version: 5.16.0-arch1-1 (64-bit)
Graphics Platform: Wayland
Processors: 8 × AMD Ryzen 5 3450U with Radeon Vega Mobile Gfx
Memory: 5.7 GiB of RAM
Graphics Processor: AMD Radeon Vega 8 Graphics

ADDITIONAL INFORMATION:
I used kde-unstable to get plasma 5.23.90 on Arch
Comment 1 Nicolas Fella 2022-01-20 12:56:57 UTC

*** This bug has been marked as a duplicate of bug 448479 ***