Bug 447456 - Wayland: Drop-down animation not working
Summary: Wayland: Drop-down animation not working
Status: VERIFIED FIXED
Alias: None
Product: yakuake
Classification: Applications
Component: general (show other bugs)
Version: 21.12.2
Platform: Archlinux Linux
: NOR normal with 5 votes (vote)
Target Milestone: ---
Assignee: Eike Hein
URL:
Keywords:
: 443275 454444 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-12-24 03:52 UTC by Josesk Volpe
Modified: 2022-10-25 14:56 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In: 22.04


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Josesk Volpe 2021-12-24 03:52:58 UTC
SUMMARY
Drop-down animation for Yakuake is not working on Wayland, only on X11


STEPS TO REPRODUCE
1. Start your graphical interface on Wayland (I'm using KDE Plasma)
2. Open Yakuake

OBSERVED RESULT
Yakuake is displaying with growing animation

EXPECTED RESULT
Yakuake should display with a drop-down animation

SOFTWARE/OS VERSIONS
Operating System: Manjaro Linux
KDE Plasma Version: 5.23.4
KDE Frameworks Version: 5.89.0
Qt Version: 5.15.2
Kernel Version: 5.10.85-1-MANJARO (64-bit)
Graphics Platform: Wayland
Processors: 4 × Intel® Core™ i3-7100U CPU @ 2.40GHz
Memory: 11.6 GiB of RAM
Graphics Processor: Mesa Intel® HD Graphics 620
Comment 1 misketmuskat 2022-02-09 21:34:30 UTC
Can reproduce.
Comment 2 Kochka 2022-02-17 09:54:16 UTC
For me, the drop-down animation happen only once on the first opening.
All subsequent opening animations are the growing one.
(ArchLinux, Wayland)
Comment 3 Josesk Volpe 2022-02-17 17:40:24 UTC
(In reply to Kochka from comment #2)
> For me, the drop-down animation happen only once on the first opening.
> All subsequent opening animations are the growing one.
> (ArchLinux, Wayland)

That was the same on me. Sorry, i forgot to mention that
Comment 4 Bug Janitor Service 2022-02-26 21:54:35 UTC
A possibly relevant merge request was started @ https://invent.kde.org/utilities/yakuake/-/merge_requests/53
Comment 5 Nate Graham 2022-02-28 18:30:59 UTC
*** Bug 443275 has been marked as a duplicate of this bug. ***
Comment 6 Nate Graham 2022-02-28 18:33:14 UTC
Git commit 7a319db432c13343b6da2203171b2cc5e70c8f1c by Nate Graham, on behalf of Tiernan Hubble.
Committed on 28/02/2022 at 18:33.
Pushed by ngraham into branch 'master'.

Fix Slide effect on Wayland

Qt Wayland windows have their internal Wayland surface destroyed when they're
hidden, and re-created when they're shown. Since `KWindowEffects::slideWindow()`
requires the Wayland surface, it doesn't work when called after `hide()` and
before `show()`. The solution is simply to call it directly after `show()`; window
opening animations are asynchronous so the effect is applied to the window as
it's opening.
FIXED-IN: 22.04

M  +12   -2    app/mainwindow.cpp
M  +2    -0    app/mainwindow.h

https://invent.kde.org/utilities/yakuake/commit/7a319db432c13343b6da2203171b2cc5e70c8f1c
Comment 7 Patrick Silva 2022-03-15 12:28:10 UTC
This bug persists on neon unstable.

Operating System: KDE neon Unstable Edition
KDE Plasma Version: 5.24.80
KDE Frameworks Version: 5.93.0
Qt Version: 5.15.3
Graphics Platform: Wayland
Comment 8 Nate Graham 2022-03-15 18:06:18 UTC
Its working for me now, which means that we solved the original bug of it not working for anyone, and now we have a new bug that only affects some people. Let's get a new bug report for that.
Comment 9 Nate Graham 2022-05-26 17:26:11 UTC
*** Bug 454444 has been marked as a duplicate of this bug. ***
Comment 10 analoginterface0 2022-10-25 11:19:33 UTC
I'm the reporter of Bug #454444. I confirm now that this bug is solved. On the latest 5.99 KDE Frameworks, and 22.08.2 (forgive me if I'm mistaken with version numbers). Yakuake now properly slides in from the top on Wayland as on X11 - as was always expected.

I'm really, really happy about this fix, in-fact was the only "wayland showstopper" for me for two years now (on Fedora). Thanks a lot, I can't appreciate this enough!
Comment 11 Nate Graham 2022-10-25 14:09:12 UTC
Wonderful news!
Comment 12 analoginterface0 2022-10-25 14:54:22 UTC
I was eager to know what commit/change actually fixed it here. Specifically, I'm running Yakuake v22.08.1, Plasma v5.25.0, KDE Frameworks v5.99.0 & Qt v5.15.6 on Fedora KDE with updates installed upto 22-Oct-2022. As far as I inspected, this fix was incorporated months ago => https://invent.kde.org/utilities/yakuake/commit/7a319db432c13343b6da2203171b2cc5e70c8f1c on Yakuake v22.04. I went through 21.12->22.08, every versions of Plasma, KDE Frameworks, Qt versions even the last Fedora (since Nvidia added GBM) since then, and I tested yakuake every time I did an update. It's only in this specific versions combination (G22.08.1+P5.25.0+F5.99.0+Q5.15.6) that resolved it - although Manjaro, as I stated earlier, was immune to this even before Yakuake v21.12 on wayland.
Comment 13 analoginterface0 2022-10-25 14:56:24 UTC
(In reply to analoginterface0 from comment #12)
> I was eager to know what commit/change actually fixed it here. Specifically,
> I'm running Yakuake v22.08.1, Plasma v5.25.0, KDE Frameworks v5.99.0 & Qt
> v5.15.6 on Fedora KDE with updates installed upto 22-Oct-2022. As far as I
> inspected, this fix was incorporated months ago =>
> https://invent.kde.org/utilities/yakuake/commit/
> 7a319db432c13343b6da2203171b2cc5e70c8f1c on Yakuake v22.04. I went through
> 21.12->22.08, every versions of Plasma, KDE Frameworks, Qt versions even the
> last Fedora (since Nvidia added GBM) since then, and I tested yakuake every
> time I did an update. It's only in this specific versions combination
> (G22.08.1+P5.25.0+F5.99.0+Q5.15.6) that resolved it - although Manjaro, as I
> stated earlier, was immune to this even before Yakuake v21.12 on wayland.

sorry it's Plasma 5.25.5, Fedora 36 KDE