Bug 446553 - Window thumbnails aren't displayed on Wayland (pipewire broken?)
Summary: Window thumbnails aren't displayed on Wayland (pipewire broken?)
Status: RESOLVED DUPLICATE of bug 446061
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Task Manager and Icons-Only Task Manager (show other bugs)
Version: 5.23.4
Platform: Archlinux Packages Linux
: NOR normal
Target Milestone: 1.0
Assignee: Eike Hein
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-12-06 13:16 UTC by pmargeti34
Modified: 2021-12-08 12:33 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
journal entries when task manager item got hovered (11.30 KB, text/plain)
2021-12-06 13:16 UTC, pmargeti34
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pmargeti34 2021-12-06 13:16:28 UTC
Created attachment 144263 [details]
journal entries when task manager item got hovered

SUMMARY
***
Window thumbnails are not working for me under Wayland. 
***


STEPS TO REPRODUCE
1.  hover the running application icons in the task manager
2.  
3. 

OBSERVED RESULT
no window previews are displayed in wayland session
journal records pipewire debug code

EXPECTED RESULT
window previews are displayed

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: Arch Linux
KDE Plasma Version: 5.23.4
KDE Frameworks Version: 5.88
Qt Version: 5.15.2

ADDITIONAL INFORMATION
previews function normally in X11 session
it doesn't matter which of the pipewire session managers is being used, bug is always reproducible
it doesn't matter which task manager applet is being used, neither are displaying the window previews
note that this is different to https://bugs.kde.org/show_bug.cgi?id=443719
here's a downstream bug report: https://bugs.archlinux.org/task/72935
Comment 1 pmargeti34 2021-12-08 12:33:32 UTC

*** This bug has been marked as a duplicate of bug 446061 ***