Bug 443719 - Window thumbnails aren't displayed on Wayland
Summary: Window thumbnails aren't displayed on Wayland
Status: RESOLVED DUPLICATE of bug 446061
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Task Manager and Icons-Only Task Manager (show other bugs)
Version: 5.23.0
Platform: Gentoo Packages Linux
: NOR normal
Target Milestone: 1.0
Assignee: Eike Hein
URL:
Keywords: wayland
Depends on:
Blocks:
 
Reported: 2021-10-14 15:02 UTC by Till Schäfer
Modified: 2021-12-08 12:33 UTC (History)
9 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
screenshot of the bug (288.89 KB, image/png)
2021-10-14 15:02 UTC, Till Schäfer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Till Schäfer 2021-10-14 15:02:53 UTC
Created attachment 142434 [details]
screenshot of the bug

Window thumbnails are still not working for me under Wayland. 

Also see previous bugreports: Bug 428284 and Bug 427826


Operating System: Gentoo Linux
KDE Plasma Version: 5.23.0
KDE Frameworks Version: 5.87.0
Qt Version: 5.15.2
Kernel Version: 5.14.10-gentoo (64-bit)
Graphics Platform: Wayland
Processors: 8 × Intel® Core™ i7-4810MQ CPU @ 2.80GHz
Memory: 15.5 GiB of RAM
Graphics Processor: Mesa DRI Intel® HD Graphics 4600


EXPECTED RESULT


SOFTWARE/OS VERSIONS
Windows: 
macOS: 
Linux/KDE Plasma: 
(available in About System)
KDE Plasma Version: 
KDE Frameworks Version: 
Qt Version: 

ADDITIONAL INFORMATION
Comment 1 Till Schäfer 2021-10-14 15:06:54 UTC
$ eglinfo 
EGL client extensions string:
    EGL_EXT_device_base EGL_EXT_device_enumeration EGL_EXT_device_query
    EGL_EXT_platform_base EGL_KHR_client_get_all_proc_addresses
    EGL_EXT_client_extensions EGL_KHR_debug EGL_EXT_platform_device
    EGL_EXT_platform_wayland EGL_KHR_platform_wayland
    EGL_EXT_platform_x11 EGL_KHR_platform_x11 EGL_MESA_platform_xcb
    EGL_MESA_platform_gbm EGL_KHR_platform_gbm
    EGL_MESA_platform_surfaceless

GBM platform:
EGL API version: 1.4
EGL vendor string: Mesa Project
EGL version string: 1.4
EGL client APIs: OpenGL OpenGL_ES 
EGL extensions string:
    EGL_ANDROID_blob_cache EGL_ANDROID_native_fence_sync
    EGL_EXT_buffer_age EGL_EXT_create_context_robustness
    EGL_EXT_image_dma_buf_import EGL_EXT_image_dma_buf_import_modifiers
    EGL_KHR_config_attribs EGL_KHR_create_context
    EGL_KHR_create_context_no_error EGL_KHR_fence_sync
    EGL_KHR_get_all_proc_addresses EGL_KHR_gl_colorspace
    EGL_KHR_gl_renderbuffer_image EGL_KHR_gl_texture_2D_image
    EGL_KHR_gl_texture_3D_image EGL_KHR_gl_texture_cubemap_image
    EGL_KHR_image EGL_KHR_image_base EGL_KHR_image_pixmap
    EGL_KHR_no_config_context EGL_KHR_reusable_sync
    EGL_KHR_surfaceless_context EGL_EXT_pixel_format_float
    EGL_KHR_wait_sync EGL_MESA_configless_context EGL_MESA_drm_image
    EGL_MESA_image_dma_buf_export EGL_MESA_query_driver
    EGL_WL_bind_wayland_display
Configurations:
     bf lv colorbuffer dp st  ms    vis   cav bi  renderable  supported
  id sz  l  r  g  b  a th cl ns b    id   eat nd gl es es2 vg surfaces 
---------------------------------------------------------------------
0x01 16  0  5  6  5  0  0  0  0 0 0x36314752--         y  y  y     win
0x02 16  0  5  6  5  0 24  8  0 0 0x36314752--         y  y  y     win
0x03 32  0  8  8  8  8  0  0  0 0 0x34325241--         y  y  y     win
0x04 32  0  8  8  8  8 24  8  0 0 0x34325241--         y  y  y     win
0x05 24  0  8  8  8  0  0  0  0 0 0x34325258--         y  y  y     win
0x06 24  0  8  8  8  0 24  8  0 0 0x34325258--         y  y  y     win
0x07 16  0  5  6  5  0  0  0  4 1 0x36314752--         y  y  y     win
0x08 16  0  5  6  5  0  0  0  8 1 0x36314752--         y  y  y     win
0x09 16  0  5  6  5  0 24  8  4 1 0x36314752--         y  y  y     win
0x0a 16  0  5  6  5  0 24  8  8 1 0x36314752--         y  y  y     win
0x0b 32  0  8  8  8  8  0  0  4 1 0x34325241--         y  y  y     win
0x0c 32  0  8  8  8  8  0  0  8 1 0x34325241--         y  y  y     win
0x0d 32  0  8  8  8  8 24  8  4 1 0x34325241--         y  y  y     win
0x0e 32  0  8  8  8  8 24  8  8 1 0x34325241--         y  y  y     win
0x0f 24  0  8  8  8  0  0  0  4 1 0x34325258--         y  y  y     win
0x10 24  0  8  8  8  0  0  0  8 1 0x34325258--         y  y  y     win
0x11 24  0  8  8  8  0 24  8  4 1 0x34325258--         y  y  y     win
0x12 24  0  8  8  8  0 24  8  8 1 0x34325258--         y  y  y     win

Wayland platform:
EGL API version: 1.4
EGL vendor string: Mesa Project
EGL version string: 1.4
EGL client APIs: OpenGL OpenGL_ES 
EGL extensions string:
    EGL_ANDROID_blob_cache EGL_ANDROID_native_fence_sync
    EGL_EXT_buffer_age EGL_EXT_create_context_robustness
    EGL_EXT_image_dma_buf_import EGL_EXT_image_dma_buf_import_modifiers
    EGL_EXT_swap_buffers_with_damage EGL_KHR_config_attribs
    EGL_KHR_create_context EGL_KHR_create_context_no_error
    EGL_KHR_fence_sync EGL_KHR_get_all_proc_addresses
    EGL_KHR_gl_colorspace EGL_KHR_gl_renderbuffer_image
    EGL_KHR_gl_texture_2D_image EGL_KHR_gl_texture_3D_image
    EGL_KHR_gl_texture_cubemap_image EGL_KHR_image_base
    EGL_KHR_no_config_context EGL_KHR_reusable_sync
    EGL_KHR_surfaceless_context EGL_KHR_swap_buffers_with_damage
    EGL_EXT_pixel_format_float EGL_KHR_wait_sync
    EGL_MESA_configless_context EGL_MESA_drm_image
    EGL_MESA_image_dma_buf_export EGL_MESA_query_driver
    EGL_WL_bind_wayland_display EGL_WL_create_wayland_buffer_from_image
Configurations:
     bf lv colorbuffer dp st  ms    vis   cav bi  renderable  supported
  id sz  l  r  g  b  a th cl ns b    id   eat nd gl es es2 vg surfaces 
---------------------------------------------------------------------
0x01 16  0  5  6  5  0  0  0  0 0 0x00--         y  y  y     win
0x02 16  0  5  6  5  0 24  8  0 0 0x00--         y  y  y     win
0x03 32  0  8  8  8  8  0  0  0 0 0x00--         y  y  y     win
0x04 32  0  8  8  8  8 24  8  0 0 0x00--         y  y  y     win
0x05 24  0  8  8  8  0  0  0  0 0 0x00--         y  y  y     win
0x06 24  0  8  8  8  0 24  8  0 0 0x00--         y  y  y     win
0x07 16  0  5  6  5  0  0  0  4 1 0x00--         y  y  y     win
0x08 16  0  5  6  5  0  0  0  8 1 0x00--         y  y  y     win
0x09 16  0  5  6  5  0 24  8  4 1 0x00--         y  y  y     win
0x0a 16  0  5  6  5  0 24  8  8 1 0x00--         y  y  y     win
0x0b 32  0  8  8  8  8  0  0  4 1 0x00--         y  y  y     win
0x0c 32  0  8  8  8  8  0  0  8 1 0x00--         y  y  y     win
0x0d 32  0  8  8  8  8 24  8  4 1 0x00--         y  y  y     win
0x0e 32  0  8  8  8  8 24  8  8 1 0x00--         y  y  y     win
0x0f 24  0  8  8  8  0  0  0  4 1 0x00--         y  y  y     win
0x10 24  0  8  8  8  0  0  0  8 1 0x00--         y  y  y     win
0x11 24  0  8  8  8  0 24  8  4 1 0x00--         y  y  y     win
0x12 24  0  8  8  8  0 24  8  8 1 0x00--         y  y  y     win

X11 platform:
EGL API version: 1.4
EGL vendor string: Mesa Project
EGL version string: 1.4
EGL client APIs: OpenGL OpenGL_ES 
EGL extensions string:
    EGL_ANDROID_blob_cache EGL_ANDROID_native_fence_sync
    EGL_CHROMIUM_sync_control EGL_EXT_buffer_age
    EGL_EXT_create_context_robustness EGL_EXT_image_dma_buf_import
    EGL_EXT_image_dma_buf_import_modifiers
    EGL_EXT_swap_buffers_with_damage EGL_KHR_config_attribs
    EGL_KHR_create_context EGL_KHR_create_context_no_error
    EGL_KHR_fence_sync EGL_KHR_get_all_proc_addresses
    EGL_KHR_gl_colorspace EGL_KHR_gl_renderbuffer_image
    EGL_KHR_gl_texture_2D_image EGL_KHR_gl_texture_3D_image
    EGL_KHR_gl_texture_cubemap_image EGL_KHR_image EGL_KHR_image_base
    EGL_KHR_image_pixmap EGL_KHR_no_config_context EGL_KHR_reusable_sync
    EGL_KHR_surfaceless_context EGL_KHR_swap_buffers_with_damage
    EGL_EXT_pixel_format_float EGL_KHR_wait_sync
    EGL_MESA_configless_context EGL_MESA_drm_image
    EGL_MESA_image_dma_buf_export EGL_MESA_query_driver
    EGL_NOK_texture_from_pixmap EGL_WL_bind_wayland_display
Configurations:
     bf lv colorbuffer dp st  ms    vis   cav bi  renderable  supported
  id sz  l  r  g  b  a th cl ns b    id   eat nd gl es es2 vg surfaces 
---------------------------------------------------------------------
0x01 32  0  8  8  8  8  0  0  0 0 0x3bTC      a  y  y  y     win,pb,pix
0x02 32  0  8  8  8  8 24  8  0 0 0x3bTC      a  y  y  y     win,pb,pix
0x03 24  0  8  8  8  0  0  0  0 0 0x3bTC      y  y  y  y     win,pb,pix
0x04 24  0  8  8  8  0 24  8  0 0 0x3bTC      y  y  y  y     win,pb,pix
0x05 32  0  8  8  8  8  0  0  4 1 0x3bTC      a  y  y  y     win
0x06 32  0  8  8  8  8  0  0  8 1 0x3bTC      a  y  y  y     win
0x07 32  0  8  8  8  8 24  8  4 1 0x3bTC      a  y  y  y     win
0x08 32  0  8  8  8  8 24  8  8 1 0x3bTC      a  y  y  y     win
0x09 24  0  8  8  8  0  0  0  4 1 0x3bTC      y  y  y  y     win
0x0a 24  0  8  8  8  0  0  0  8 1 0x3bTC      y  y  y  y     win
0x0b 24  0  8  8  8  0 24  8  4 1 0x3bTC      y  y  y  y     win
0x0c 24  0  8  8  8  0 24  8  8 1 0x3bTC      y  y  y  y     win
0x0d 32  0  8  8  8  8  0  0  0 0 0x3cDC      a  y  y  y     win,pb,pix
0x0e 32  0  8  8  8  8 24  8  0 0 0x3cDC      a  y  y  y     win,pb,pix
0x0f 24  0  8  8  8  0  0  0  0 0 0x3cDC      y  y  y  y     win,pb,pix
0x10 24  0  8  8  8  0 24  8  0 0 0x3cDC      y  y  y  y     win,pb,pix
0x11 32  0  8  8  8  8  0  0  4 1 0x3cDC      a  y  y  y     win
0x12 32  0  8  8  8  8  0  0  8 1 0x3cDC      a  y  y  y     win
0x13 32  0  8  8  8  8 24  8  4 1 0x3cDC      a  y  y  y     win
0x14 32  0  8  8  8  8 24  8  8 1 0x3cDC      a  y  y  y     win
0x15 24  0  8  8  8  0  0  0  4 1 0x3cDC      y  y  y  y     win
0x16 24  0  8  8  8  0  0  0  8 1 0x3cDC      y  y  y  y     win
0x17 24  0  8  8  8  0 24  8  4 1 0x3cDC      y  y  y  y     win
0x18 24  0  8  8  8  0 24  8  8 1 0x3cDC      y  y  y  y     win

Device platform:
eglinfo: eglInitialize failed
Comment 2 Nate Graham 2021-10-14 17:40:19 UTC
Working for me FWIW, so this isn't a universal issue.
Comment 3 Till Schäfer 2021-10-14 17:45:21 UTC
If I can provide any useful additional information to debug / find the cause, please let me know.
Comment 4 Igor Poboiko 2021-10-15 09:44:57 UTC
Hey, I had the same issue with Gentoo.

Turned out I had to enable "screencast" USE-flag both for kde-plasma/kwin, kde-plasma/plasma-workspace  and sys-apps/xdg-desktop-portal, and it fixed the issue for me.
Comment 5 Till Schäfer 2021-10-15 10:56:06 UTC
(In reply to Igor Poboiko from comment #4)
> Hey, I had the same issue with Gentoo.
> 
> Turned out I had to enable "screencast" USE-flag both for kde-plasma/kwin,
> kde-plasma/plasma-workspace  and sys-apps/xdg-desktop-portal, and it fixed
> the issue for me.

Thanks a lot. This was indeed the problem. Thus, I guess it is a downstream packaging problem here. I have opened a downstream bug report: 

  https://bugs.gentoo.org/818253
Comment 6 pmargeti34 2021-12-05 14:30:29 UTC
What exactly does the screencast use flag entail on gentoo? I'm having this issue on archlinux.
Comment 7 Igor Poboiko 2021-12-05 20:53:49 UTC
(In reply to pmargeti34 from comment #6)
> What exactly does the screencast use flag entail on gentoo? I'm having this
> issue on archlinux.

Hey!
For KWin: it adds a PipeWire dependency (so that KWin compiles with PipeWire support).
For Plasma Workspace: it adds dependencies on QtGui (with EGL support), libglvnd, again PipeWire and libdrm.
For xdg-desktop-portal: it adds dependency on PipeWire and enables "pipewire" flag for autotools.
Comment 8 pmargeti34 2021-12-06 02:35:37 UTC
(In reply to Igor Poboiko from comment #7)
> (In reply to pmargeti34 from comment #6)
> > What exactly does the screencast use flag entail on gentoo? I'm having this
> > issue on archlinux.
> 
> Hey!
> For KWin: it adds a PipeWire dependency (so that KWin compiles with PipeWire
> support).
> For Plasma Workspace: it adds dependencies on QtGui (with EGL support),
> libglvnd, again PipeWire and libdrm.
> For xdg-desktop-portal: it adds dependency on PipeWire and enables
> "pipewire" flag for autotools.

Thank you for your quick reply. I'm at a loss here, all of these are already enabled on arch.
Comment 9 oiiu19 2021-12-07 02:16:21 UTC
(In reply to pmargeti34 from comment #8)
> (In reply to Igor Poboiko from comment #7)
> > (In reply to pmargeti34 from comment #6)
> > > What exactly does the screencast use flag entail on gentoo? I'm having this
> > > issue on archlinux.
> > 
> > Hey!
> > For KWin: it adds a PipeWire dependency (so that KWin compiles with PipeWire
> > support).
> > For Plasma Workspace: it adds dependencies on QtGui (with EGL support),
> > libglvnd, again PipeWire and libdrm.
> > For xdg-desktop-portal: it adds dependency on PipeWire and enables
> > "pipewire" flag for autotools.
> 
> Thank you for your quick reply. I'm at a loss here, all of these are already
> enabled on arch.

IMHO your issue might be caused by Bug 446061. You can try patching libtaskmanager to see if it helps.
Comment 10 pmargeti34 2021-12-07 02:25:39 UTC
(In reply to oiiu19 from comment #9)
> (In reply to pmargeti34 from comment #8)
> > (In reply to Igor Poboiko from comment #7)
> > > (In reply to pmargeti34 from comment #6)
> > > > What exactly does the screencast use flag entail on gentoo? I'm having this
> > > > issue on archlinux.
> > > 
> > > Hey!
> > > For KWin: it adds a PipeWire dependency (so that KWin compiles with PipeWire
> > > support).
> > > For Plasma Workspace: it adds dependencies on QtGui (with EGL support),
> > > libglvnd, again PipeWire and libdrm.
> > > For xdg-desktop-portal: it adds dependency on PipeWire and enables
> > > "pipewire" flag for autotools.
> > 
> > Thank you for your quick reply. I'm at a loss here, all of these are already
> > enabled on arch.
> 
> IMHO your issue might be caused by Bug 446061. You can try patching
> libtaskmanager to see if it helps.

I've opened a bug report here https://bugs.kde.org/show_bug.cgi?id=446553
The journal entries seem to indicate what you are suggesting is correct. Kindly see the attached file in the bug report for details.
Comment 11 pmargeti34 2021-12-08 12:31:43 UTC
(In reply to oiiu19 from comment #9)
> (In reply to pmargeti34 from comment #8)
> > (In reply to Igor Poboiko from comment #7)
> > > (In reply to pmargeti34 from comment #6)
> > > > What exactly does the screencast use flag entail on gentoo? I'm having this
> > > > issue on archlinux.
> > > 
> > > Hey!
> > > For KWin: it adds a PipeWire dependency (so that KWin compiles with PipeWire
> > > support).
> > > For Plasma Workspace: it adds dependencies on QtGui (with EGL support),
> > > libglvnd, again PipeWire and libdrm.
> > > For xdg-desktop-portal: it adds dependency on PipeWire and enables
> > > "pipewire" flag for autotools.
> > 
> > Thank you for your quick reply. I'm at a loss here, all of these are already
> > enabled on arch.
> 
> IMHO your issue might be caused by Bug 446061. You can try patching
> libtaskmanager to see if it helps.

I have finally found some time to tackle this. Turns out you were right! I've increased the buffer size to 4096 and now I've got window previews in the taskbar on wayland. So in summary, my bug is a dupe of your bug and there definitely needs to be a larger buffer value. Thank you very much!
Comment 12 David Edmundson 2021-12-08 12:33:53 UTC

*** This bug has been marked as a duplicate of bug 446061 ***