Bug 446090 - Dolphin crashes when creating a directory inside a path accessed with smb://
Summary: Dolphin crashes when creating a directory inside a path accessed with smb://
Status: RESOLVED DUPLICATE of bug 433993
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 20.12.3
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2021-11-25 20:46 UTC by wodencafe
Modified: 2021-12-14 00:50 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.18 KB, text/plain)
2021-11-30 19:14 UTC, frnobre
Details

Note You need to log in before you can comment on or make changes to this bug.
Description wodencafe 2021-11-25 20:46:43 UTC
Application: dolphin (20.12.3)

Qt Version: 5.15.2
Frameworks Version: 5.80.0
Operating System: Linux 5.11.0-40-generic x86_64
Windowing System: X11
Drkonqi Version: 5.21.4
Distribution: Ubuntu 21.04

-- Information about the crash:
- What I was doing when the application crashed:

I navigated through the path in dolphin via smb://, to a spot in which a directory needed to be created, and a file copied. I used the context menu to create the directory, and name it. After I hit "enter" to complete the entry of the directory name, Dolphin crashed. This has happened multiple times. When I restarted Dolphin and returned to the path, the directory I attempted to create did exist. So, Dolphin created it successfully, but then crashed.

- Unusual behavior I noticed:

This only seems to affect network locations accessed via smb://.

The crash can be reproduced sometimes.

-- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault

[KCrash Handler]
#4  std::__atomic_base<int>::load (__m=std::memory_order_relaxed, this=0x6d61000000670065) at /usr/include/c++/10/bits/atomic_base.h:420
#5  QAtomicOps<int>::loadRelaxed<int> (_q_value=...) at ../../include/QtCore/../../src/corelib/thread/qatomic_cxx11.h:239
#6  QBasicAtomicInteger<int>::loadRelaxed (this=0x6d61000000670065) at ../../include/QtCore/../../src/corelib/thread/qbasicatomic.h:107
#7  QtPrivate::RefCount::ref (this=0x6d61000000670065) at ../../include/QtCore/../../src/corelib/tools/qrefcount.h:55
#8  QString::QString (other=..., this=0x7ffd960d3b08) at ../../include/QtCore/../../src/corelib/text/qstring.h:1094
#9  QWidgetLineControl::text (this=0x562e088cc900) at ../../include/QtWidgets/5.15.2/QtWidgets/private/../../../../../src/widgets/widgets/qwidgetlinecontrol_p.h:241
#10 QLineEdit::text (this=<optimized out>) at widgets/qlineedit.cpp:312
#11 0x00007f75c510b90c in ?? () from /lib/x86_64-linux-gnu/libKF5KIOFileWidgets.so.5
#12 0x00007f75c32e15c7 in QtPrivate::QSlotObjectBase::call (a=0x7ffd960d3cd0, r=0x562e0743fb50, this=0x562e096b8ef0) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:398
#13 doActivate<false> (sender=0x7f75b8011dc0, signal_index=6, argv=0x7ffd960d3cd0) at kernel/qobject.cpp:3886
#14 0x00007f75c44dafa0 in KJob::result(KJob*, KJob::QPrivateSignal) () from /lib/x86_64-linux-gnu/libKF5CoreAddons.so.5
#15 0x00007f75c44dbd1b in KJob::finishJob(bool) () from /lib/x86_64-linux-gnu/libKF5CoreAddons.so.5
#16 0x00007f75c32e15c7 in QtPrivate::QSlotObjectBase::call (a=0x7ffd960d3e10, r=0x7f75b8011dc0, this=0x562e14ac4c40) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:398
#17 doActivate<false> (sender=0x562e3886a790, signal_index=5, argv=0x7ffd960d3e10) at kernel/qobject.cpp:3886
#18 0x00007f75c4c78b8a in KIO::SlaveInterface::error(int, QString const&) () from /lib/x86_64-linux-gnu/libKF5KIOCore.so.5
#19 0x00007f75c4c7aeec in KIO::SlaveInterface::dispatch(int, QByteArray const&) () from /lib/x86_64-linux-gnu/libKF5KIOCore.so.5
#20 0x00007f75c4c792ed in KIO::SlaveInterface::dispatch() () from /lib/x86_64-linux-gnu/libKF5KIOCore.so.5
#21 0x00007f75c4c7cce2 in KIO::Slave::gotInput() () from /lib/x86_64-linux-gnu/libKF5KIOCore.so.5
#22 0x00007f75c32e15c7 in QtPrivate::QSlotObjectBase::call (a=0x7ffd960d4050, r=0x562e3886a790, this=0x562e27dc72a0) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:398
#23 doActivate<false> (sender=0x562e13358660, signal_index=3, argv=0x7ffd960d4050) at kernel/qobject.cpp:3886
#24 0x00007f75c32d710c in QObject::event (this=0x562e13358660, e=0x562e14036330) at kernel/qobject.cpp:1314
#25 0x00007f75c3d99783 in QApplicationPrivate::notify_helper (this=<optimized out>, receiver=0x562e13358660, e=0x562e14036330) at kernel/qapplication.cpp:3632
#26 0x00007f75c32a97ba in QCoreApplication::notifyInternal2 (receiver=0x562e13358660, event=0x562e14036330) at kernel/qcoreapplication.cpp:1063
#27 0x00007f75c32ac7e1 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x562e070c4890) at kernel/qcoreapplication.cpp:1817
#28 0x00007f75c3303ba7 in postEventSourceDispatch (s=0x562e072018f0) at kernel/qeventdispatcher_glib.cpp:277
#29 0x00007f75c10ee8eb in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f75c1141d28 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f75c10ec023 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#32 0x00007f75c3303204 in QEventDispatcherGlib::processEvents (this=0x562e0720eca0, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#33 0x00007f75c32a811b in QEventLoop::exec (this=this@entry=0x7ffd960d4440, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:69
#34 0x00007f75c32b0604 in QCoreApplication::exec () at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#35 0x00007f75c54d3570 in kdemain (argc=<optimized out>, argv=<optimized out>) at ./src/main.cpp:222
#36 0x00007f75c52bc565 in __libc_start_main (main=0x562e05a93060 <main>, argc=1, argv=0x7ffd960d4708, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffd960d46f8) at ../csu/libc-start.c:332
#37 0x0000562e05a9309e in _start ()
[Inferior 1 (process 3178893) detached]

Possible duplicates by query: bug 443784, bug 440840, bug 439877, bug 436988, bug 435992.

Reported using DrKonqi
Comment 1 frnobre 2021-11-30 19:14:16 UTC
Created attachment 144097 [details]
New crash information added by DrKonqi

dolphin (21.11.90) using Qt 5.15.2

- What I was doing when the application crashed:
create a folder on smb://*

- Unusual behavior I noticed:
dolphin's windows closed

-- Backtrace (Reduced):
#4  QString::QString (other=..., this=0x7ffe192bb1c8) at ../../include/QtCore/../../src/corelib/text/qstring.h:1093
#5  QWidgetLineControl::text (this=0x0) at ../../include/QtWidgets/5.15.2/QtWidgets/private/../../../../../src/widgets/widgets/qwidgetlinecontrol_p.h:241
#6  QLineEdit::text (this=<optimized out>) at widgets/qlineedit.cpp:312
#7  0x00007f635b353a5c in KNewFileMenuPrivate::_k_slotStatResult (this=0x55d6a6dc5ce0, job=0x55d6a7628cb0) at /usr/src/debug/kio-5.88.0-lp153.343.2.x86_64/src/filewidgets/knewfilemenu.cpp:1274
#8  0x00007f635518cea7 in QtPrivate::QSlotObjectBase::call (a=0x7ffe192bb390, r=0x55d6a6ddcb20, this=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:398
Comment 2 Andrey 2021-12-08 22:40:25 UTC
I have the same issue, dolphin is crashing and i get following message in console:
kf.kio.core: Internal error: itemsInUse did not contain QUrl("smb://Гость@10.10.10.5/")
kf.kio.core: Fatal Error: HUH? Lister KFileItemModelDirLister(0x558daa9ef940) is supposed to be listing, but has no job!
Аварийный останов

Additional info:
system - Gentoo Linux
kde-plasma/plasma-desktop 5.22.5 (USE handbook kaccounts policykit semantic-desktop)
kde-apps/dolphin 21.08.3 (USE handbook)
kde-frameworks/kio 5.85.0-r2 (USE acl handbook kwallet)
kde-apps/kio-extras 21.08.3 (USE X handbook man nfs samba sftp taglib)
net-fs/samba 4.14.10-r1 (USE acl client cups pam regedit system-mitkrb5 winbind)

Backtrace - will attach a bit later
Comment 3 Andrey 2021-12-08 22:43:48 UTC
Crash backtrace:
Application: Dolphin (dolphin), signal: Aborted

[KCrash Handler]
#4  0x00007f2be5238ee1 in raise () from /lib64/libc.so.6
#5  0x00007f2be5223536 in abort () from /lib64/libc.so.6
#6  0x00007f2be7101fff in ?? () from /usr/lib64/libKF5KIOCore.so.5
#7  0x00007f2be721bfab in ?? () from /usr/lib64/libKF5KIOCore.so.5
#8  0x00007f2be5876f52 in ?? () from /usr/lib64/libQt5Core.so.5
#9  0x00007f2be68dc3ec in KJob::result(KJob*, KJob::QPrivateSignal) () from /usr/lib64/libKF5CoreAddons.so.5
#10 0x00007f2be68dd173 in KJob::finishJob(bool) () from /usr/lib64/libKF5CoreAddons.so.5
#11 0x00007f2be71bce80 in KIO::SimpleJob::slotFinished() () from /usr/lib64/libKF5KIOCore.so.5
#12 0x00007f2be71b34ca in KIO::ListJob::slotFinished() () from /usr/lib64/libKF5KIOCore.so.5
#13 0x00007f2be5876f52 in ?? () from /usr/lib64/libQt5Core.so.5
#14 0x00007f2be718d33a in KIO::SlaveInterface::dispatch(int, QByteArray const&) () from /usr/lib64/libKF5KIOCore.so.5
#15 0x00007f2be718b04b in KIO::SlaveInterface::dispatch() () from /usr/lib64/libKF5KIOCore.so.5
#16 0x00007f2be7193e9a in KIO::Slave::gotInput() () from /usr/lib64/libKF5KIOCore.so.5
#17 0x00007f2be5876f52 in ?? () from /usr/lib64/libQt5Core.so.5
#18 0x00007f2be586eead in QObject::event(QEvent*) () from /usr/lib64/libQt5Core.so.5
#19 0x00007f2be62a7d8f in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQt5Widgets.so.5
#20 0x00007f2be62b0a78 in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQt5Widgets.so.5
#21 0x00007f2be58437f8 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /usr/lib64/libQt5Core.so.5
#22 0x00007f2be5846311 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib64/libQt5Core.so.5
#23 0x00007f2be5898ee3 in ?? () from /usr/lib64/libQt5Core.so.5
#24 0x00007f2be36e86cd in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#25 0x00007f2be36e8948 in ?? () from /usr/lib64/libglib-2.0.so.0
#26 0x00007f2be36e89df in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#27 0x00007f2be5898c90 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#28 0x00007f2be584263b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#29 0x00007f2be584a5d0 in QCoreApplication::exec() () from /usr/lib64/libQt5Core.so.5
#30 0x000055837961d5f9 in ?? ()
#31 0x00007f2be522480e in __libc_start_main () from /lib64/libc.so.6
#32 0x000055837961d9ba in ?? ()
[Inferior 1 (process 16854) detached]
Comment 4 Andrey 2021-12-08 22:51:40 UTC
Note about problem reproduction: if i use just left click to open remote smb server - dolphin crashing, but all is fine when i use right click + "open in new tab" button instead - in this case dolphin stays alive and i'm able to use remote shares as usual.
Comment 5 Nicolas Fella 2021-12-14 00:50:39 UTC

*** This bug has been marked as a duplicate of bug 433993 ***