Bug 433993 - Dolphin Crash when creating a folder in remote folder (kio-Gdrive, FTP)
Summary: Dolphin Crash when creating a folder in remote folder (kio-Gdrive, FTP)
Status: RESOLVED DUPLICATE of bug 433347
Alias: None
Product: frameworks-kio
Classification: Unclassified
Component: general (show other bugs)
Version: 5.80.0
Platform: Ubuntu Packages Linux
: HI crash
Target Milestone: ---
Assignee: KIO Bugs
URL:
Keywords: drkonqi
: 431722 433682 433701 434260 434298 435539 436988 437442 444861 446090 446636 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-03-05 09:29 UTC by treds102
Modified: 2021-12-14 00:52 UTC (History)
19 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
attachment-11691-0.html (deleted)
2021-03-28 15:34 UTC, Daz
Details
attachment-12767-0.html (1.47 KB, text/html)
2021-03-28 16:04 UTC, Daz
Details
New crash information added by DrKonqi (16.48 KB, text/plain)
2021-09-20 19:11 UTC, Florian Edelmann
Details
New crash information added by DrKonqi (5.24 KB, text/plain)
2021-10-20 21:16 UTC, ltstarwarskid
Details

Note You need to log in before you can comment on or make changes to this bug.
Description treds102 2021-03-05 09:29:26 UTC
Application: dolphin (20.12.2)

Qt Version: 5.15.2
Frameworks Version: 5.79.0
Operating System: Linux 5.4.0-66-generic x86_64
Windowing System: X11
Drkonqi Version: 5.21.2
Distribution: KDE neon User Edition 5.21

-- Information about the crash:
- What I was doing when the application crashed:

Creating a folder in my gdrive using either F10 or right click menu

The crash can be reproduced every time.

-- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault

[New LWP 6087]
[New LWP 6088]
[New LWP 6089]
[New LWP 6090]
[New LWP 6091]
[New LWP 6094]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
0x00007f5c30582aff in __GI___poll (fds=0x7ffe1091ade8, nfds=1, timeout=1000) at ../sysdeps/unix/sysv/linux/poll.c:29
[Current thread is 1 (Thread 0x7f5c296148c0 (LWP 6085))]

Thread 7 (Thread 0x7f5c197fa700 (LWP 6094)):
#0  0x00007f5c30582aff in __GI___poll (fds=0x7f5bf8004e60, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f5c2c01818e in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f5c2c0182c3 in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f5c2e2adfbb in QEventDispatcherGlib::processEvents (this=0x7f5bf8000b60, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#4  0x00007f5c2e2521ab in QEventLoop::exec (this=this@entry=0x7f5c197f9ce0, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:141
#5  0x00007f5c2e06ca12 in QThread::exec (this=<optimized out>) at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#6  0x00007f5c2e06dbac in QThreadPrivate::start (arg=0x5654e792d360) at thread/qthread_unix.cpp:329
#7  0x00007f5c2c9e7609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#8  0x00007f5c3058f293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 6 (Thread 0x7f5c1affd700 (LWP 6091)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x5654e7a48678) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x5654e7a48628, cond=0x5654e7a48650) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x5654e7a48650, mutex=0x5654e7a48628) at pthread_cond_wait.c:638
#3  0x00007f5c20d07e6b in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#4  0x00007f5c20d07a6b in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#5  0x00007f5c2c9e7609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#6  0x00007f5c3058f293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 5 (Thread 0x7f5c13fff700 (LWP 6090)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x5654e7a48678) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x5654e7a48628, cond=0x5654e7a48650) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x5654e7a48650, mutex=0x5654e7a48628) at pthread_cond_wait.c:638
#3  0x00007f5c20d07e6b in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#4  0x00007f5c20d07a6b in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#5  0x00007f5c2c9e7609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#6  0x00007f5c3058f293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 4 (Thread 0x7f5c1b7fe700 (LWP 6089)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x5654e7a48678) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x5654e7a48628, cond=0x5654e7a48650) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x5654e7a48650, mutex=0x5654e7a48628) at pthread_cond_wait.c:638
#3  0x00007f5c20d07e6b in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#4  0x00007f5c20d07a6b in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#5  0x00007f5c2c9e7609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#6  0x00007f5c3058f293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 3 (Thread 0x7f5c1bfff700 (LWP 6088)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x5654e7a48678) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x5654e7a48628, cond=0x5654e7a48650) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x5654e7a48650, mutex=0x5654e7a48628) at pthread_cond_wait.c:638
#3  0x00007f5c20d07e6b in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#4  0x00007f5c20d07a6b in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#5  0x00007f5c2c9e7609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#6  0x00007f5c3058f293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 2 (Thread 0x7f5c23c45700 (LWP 6087)):
#0  0x00007f5c30582aff in __GI___poll (fds=0x7f5c1c014ad0, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f5c2c01818e in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f5c2c0182c3 in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f5c2e2adfbb in QEventDispatcherGlib::processEvents (this=0x7f5c1c000b60, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#4  0x00007f5c2e2521ab in QEventLoop::exec (this=this@entry=0x7f5c23c44cb0, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:141
#5  0x00007f5c2e06ca12 in QThread::exec (this=<optimized out>) at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#6  0x00007f5c2f303f4b in ?? () from /usr/lib/x86_64-linux-gnu/libQt5DBus.so.5
#7  0x00007f5c2e06dbac in QThreadPrivate::start (arg=0x7f5c2f387d80) at thread/qthread_unix.cpp:329
#8  0x00007f5c2c9e7609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#9  0x00007f5c3058f293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7f5c296148c0 (LWP 6085)):
[KCrash Handler]
#4  QString::QString (other=..., this=0x7ffe1091b4a8) at ../../include/QtCore/../../src/corelib/text/qstring.h:1093
#5  QWidgetLineControl::text (this=0x3ff0000000000000) at ../../include/QtWidgets/5.15.2/QtWidgets/private/../../../../../src/widgets/widgets/qwidgetlinecontrol_p.h:241
#6  QLineEdit::text (this=<optimized out>) at widgets/qlineedit.cpp:312
#7  0x00007f5c302ca36c in ?? () from /usr/lib/x86_64-linux-gnu/libKF5KIOFileWidgets.so.5
#8  0x00007f5c2e28a6be in QtPrivate::QSlotObjectBase::call (a=0x7ffe1091b670, r=0x5654e79e6050, this=0x5654e7f18eb0) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:398
#9  doActivate<false> (sender=0x5654e7f18fd0, signal_index=6, argv=0x7ffe1091b670) at kernel/qobject.cpp:3886
#10 0x00007f5c2e283a87 in QMetaObject::activate (sender=sender@entry=0x5654e7f18fd0, m=m@entry=0x7f5c2f500580 <KJob::staticMetaObject>, local_signal_index=local_signal_index@entry=3, argv=argv@entry=0x7ffe1091b670) at kernel/qobject.cpp:3946
#11 0x00007f5c2f49a340 in KJob::result (this=this@entry=0x5654e7f18fd0, _t1=<optimized out>, _t1@entry=0x5654e7f18fd0, _t2=...) at ./obj-x86_64-linux-gnu/src/lib/KF5CoreAddons_autogen/include/moc_kjob.cpp:576
#12 0x00007f5c2f49ae6b in KJob::finishJob (this=0x5654e7f18fd0, emitResult=<optimized out>) at ./src/lib/jobs/kjob.cpp:92
#13 0x00007f5c2fda1438 in KIO::SimpleJob::slotFinished() () from /usr/lib/x86_64-linux-gnu/libKF5KIOCore.so.5
#14 0x00007f5c2fda6d7e in KIO::StatJob::slotFinished() () from /usr/lib/x86_64-linux-gnu/libKF5KIOCore.so.5
#15 0x00007f5c2fd9f750 in KIO::SimpleJob::slotError(int, QString const&) () from /usr/lib/x86_64-linux-gnu/libKF5KIOCore.so.5
#16 0x00007f5c2e28a6be in QtPrivate::QSlotObjectBase::call (a=0x7ffe1091b910, r=0x5654e7f18fd0, this=0x5654e8228380) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:398
#17 doActivate<false> (sender=0x5654e809a000, signal_index=5, argv=0x7ffe1091b910) at kernel/qobject.cpp:3886
#18 0x00007f5c2fd6fa9a in KIO::SlaveInterface::error(int, QString const&) () from /usr/lib/x86_64-linux-gnu/libKF5KIOCore.so.5
#19 0x00007f5c2fd725b6 in KIO::SlaveInterface::dispatch(int, QByteArray const&) () from /usr/lib/x86_64-linux-gnu/libKF5KIOCore.so.5
#20 0x00007f5c2fd7025f in KIO::SlaveInterface::dispatch() () from /usr/lib/x86_64-linux-gnu/libKF5KIOCore.so.5
#21 0x00007f5c2fd79462 in KIO::Slave::gotInput() () from /usr/lib/x86_64-linux-gnu/libKF5KIOCore.so.5
#22 0x00007f5c2e28a6be in QtPrivate::QSlotObjectBase::call (a=0x7ffe1091bb60, r=0x5654e809a000, this=0x5654e81d0cd0) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:398
#23 doActivate<false> (sender=0x5654e81d1bd0, signal_index=3, argv=0x7ffe1091bb60) at kernel/qobject.cpp:3886
#24 0x00007f5c2e281239 in QObject::event (this=0x5654e81d1bd0, e=0x5654e82271d0) at kernel/qobject.cpp:1314
#25 0x00007f5c2ed2adc3 in QApplicationPrivate::notify_helper (this=<optimized out>, receiver=0x5654e81d1bd0, e=0x5654e82271d0) at kernel/qapplication.cpp:3632
#26 0x00007f5c2ed33bb8 in QApplication::notify(QObject*, QEvent*) () at kernel/qapplication.cpp:3156
#27 0x00007f5c2e25369a in QCoreApplication::notifyInternal2 (receiver=0x5654e81d1bd0, event=0x5654e82271d0) at ../../include/QtCore/5.15.2/QtCore/private/../../../../../src/corelib/thread/qthread_p.h:325
#28 0x00007f5c2e255fa1 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x5654e7644830) at kernel/qcoreapplication.cpp:1817
#29 0x00007f5c2e2ae947 in postEventSourceDispatch (s=0x5654e76ffe40) at kernel/qeventdispatcher_glib.cpp:277
#30 0x00007f5c2c017f9d in g_main_context_dispatch () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f5c2c018220 in ?? () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#32 0x00007f5c2c0182c3 in g_main_context_iteration () from /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#33 0x00007f5c2e2adfa2 in QEventDispatcherGlib::processEvents (this=0x5654e770cc20, flags=...) at kernel/qeventdispatcher_glib.cpp:423
#34 0x00007f5c2e2521ab in QEventLoop::exec (this=this@entry=0x7ffe1091c110, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:141
#35 0x00007f5c2e25a354 in QCoreApplication::exec () at ../../include/QtCore/../../src/corelib/global/qflags.h:121
#36 0x00007f5c306b2fa2 in kdemain () from /usr/lib/x86_64-linux-gnu/libkdeinit5_dolphin.so
#37 0x00007f5c304940b3 in __libc_start_main (main=0x5654e739a060, argc=1, argv=0x7ffe1091c3e8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffe1091c3d8) at ../csu/libc-start.c:308
#38 0x00005654e739a09e in _start ()
[Inferior 1 (process 6085) detached]

The reporter indicates this bug may be a duplicate of or related to bug 433701.

Possible duplicates by query: bug 433701, bug 433682, bug 431722, bug 429973, bug 428546.

Reported using DrKonqi
Comment 1 Nate Graham 2021-03-11 18:00:13 UTC
*** Bug 434260 has been marked as a duplicate of this bug. ***
Comment 2 Nate Graham 2021-03-11 18:01:22 UTC
*** Bug 433682 has been marked as a duplicate of this bug. ***
Comment 3 Nate Graham 2021-03-11 18:19:15 UTC
*** Bug 433701 has been marked as a duplicate of this bug. ***
Comment 4 Nate Graham 2021-03-11 18:19:18 UTC
*** Bug 431722 has been marked as a duplicate of this bug. ***
Comment 5 Nate Graham 2021-03-11 20:46:52 UTC
*** Bug 434298 has been marked as a duplicate of this bug. ***
Comment 6 Daz 2021-03-12 12:40:36 UTC
If its from same source as mine user 'root'
Password :'root'
I blew my chance to remove it cause i didnt Understand code.
It has a page on wiki and source code on github name 'pester' if its same as mine.If you boot from usb with tails os,,you'll find folders quickly,,goodluck
Comment 7 Elvis Angelaccio 2021-03-21 15:54:48 UTC
Crash seems to be in kio, but I can't reproduce it.
Comment 8 Kishore Gopalakrishnan 2021-03-28 11:18:28 UTC
Would additional backtraces help?
Comment 11 Daz 2021-03-28 16:04:23 UTC
Created attachment 137136 [details]
attachment-12767-0.html

Similar to mine,bit different name, I hope you have you folders unhidden
and are careful what you do on it. I know mine had 'Events' ,usually
banking or crypto ect but keywords that trigger it,,all the good stuff I
entered got sent off until I realised,,also look for programs you don't
usually have,mine had Facebook kept appearing,among others,,,and size of
file that are unusually large,,had to get a laptop for now and swap
connection methods,,I just use it every now and then,,don't know what cpu
you have but been reading AMD are close to releasing some software and
intel might be even closer,have a look.
Nothing but grief.

On Sun, 28 Mar 2021, 16:44 Nicolás Alvarez, <bugzilla_noreply@kde.org>
wrote:

> https://bugs.kde.org/show_bug.cgi?id=433993
>
> --- Comment #10 from Nicolás Alvarez <nalvarez@kde.org> ---
> The content of attachment 137135 [details] has been deleted for the following reason:
>
> spam
>
> --
> You are receiving this mail because:
> You are on the CC list for the bug.
Comment 12 Nate Graham 2021-04-09 20:04:56 UTC
*** Bug 435539 has been marked as a duplicate of this bug. ***
Comment 13 Patrick Silva 2021-06-01 11:49:45 UTC
*** Bug 437442 has been marked as a duplicate of this bug. ***
Comment 14 Patrick Silva 2021-06-01 11:50:06 UTC
*** Bug 436988 has been marked as a duplicate of this bug. ***
Comment 15 Florian Edelmann 2021-09-20 19:11:31 UTC
Created attachment 141745 [details]
New crash information added by DrKonqi

dolphin (21.08.1) using Qt 5.15.3

- What I was doing when the application crashed:

Created a new folder in a Google Drive network filesystem (which was mounted with `kio-gdrive`).

-- Backtrace (Reduced):
#4  QString::QString (other=..., this=0x7ffea1f41d38) at ../../include/QtCore/../../src/corelib/text/qstring.h:1093
#5  QWidgetLineControl::text (this=0x800000005) at ../../include/QtWidgets/5.15.3/QtWidgets/private/../../../../../src/widgets/widgets/qwidgetlinecontrol_p.h:241
#6  QLineEdit::text (this=<optimized out>) at widgets/qlineedit.cpp:312
[...]
#8  0x00007f6286868d9e in QtPrivate::QSlotObjectBase::call (a=0x7ffea1f41f00, r=0x56077f0a0360, this=0x56077e5edb10) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:398
#9  doActivate<false> (sender=0x56077f8697a0, signal_index=6, argv=0x7ffea1f41f00) at kernel/qobject.cpp:3886
Comment 16 ltstarwarskid 2021-10-20 21:16:19 UTC
Created attachment 142697 [details]
New crash information added by DrKonqi

dolphin (21.08.1) using Qt 5.15.2

- What I was doing when the application crashed:
Creating new folder in google drive using right click menu.

- Unusual behavior I noticed:
Dolphin spammed Examining (Failed) Application closed unexpectedly messages. It seemed like a new one was generated for every additional character entered. Eventually the whole window closed, but if I was able to type a short name, it didn't lose the window, though seemed to recover either with incorrect back button folders or an old state.

ADDITIONAL INFORMATION
Hardware:
CPU: Ryzen 3950X
GPU: AMD 5700 XT
RAM: 32GB ECC 3200 MHz, JDEC default timings
Motherboard: ASrock x570 Creator
OS Drive: Corsair Force Series MP600 2TB NVMe

Note, system is dual boot with Win10.

System is set up to get updates from the kubuntu updates and backports PPAs.

-- Backtrace (Reduced):
#4  0x00007f7f77341cef in QLineEdit::text (this=0x556692c33800) at widgets/qlineedit.cpp:312
#5  0x00007f7f785d9998 in KNewFileMenuPrivate::_k_slotStatResult (this=0x556691d90cc0, job=0x5566933fee40) at ./src/filewidgets/knewfilemenu.cpp:1264
#6  0x00007f7f7673a5c7 in QtPrivate::QSlotObjectBase::call (a=0x7ffc4d0f0b70, r=0x556691f0ef70, this=0x556692d4baa0) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:398
#7  doActivate<false> (sender=0x5566933fee40, signal_index=6, argv=0x7ffc4d0f0b70) at kernel/qobject.cpp:3886
#8  0x00007f7f77944700 in KJob::result(KJob*, KJob::QPrivateSignal) () from /lib/x86_64-linux-gnu/libKF5CoreAddons.so.5
Comment 17 Jiri Slaby 2021-11-16 06:55:52 UTC
*** Bug 444861 has been marked as a duplicate of this bug. ***
Comment 18 Nicolas Fella 2021-12-14 00:49:21 UTC
*** Bug 446636 has been marked as a duplicate of this bug. ***
Comment 19 Nicolas Fella 2021-12-14 00:50:39 UTC
*** Bug 446090 has been marked as a duplicate of this bug. ***
Comment 20 Nicolas Fella 2021-12-14 00:52:45 UTC

*** This bug has been marked as a duplicate of bug 433347 ***