Bug 446049 - Ark crashed the plasmashell process while archiving (or ending archiving) a folder into 7zip default profile format
Summary: Ark crashed the plasmashell process while archiving (or ending archiving) a f...
Status: RESOLVED DUPLICATE of bug 443540
Alias: None
Product: ark
Classification: Unclassified
Component: general (show other bugs)
Version: 21.11.80
Platform: Manjaro Linux
: NOR major (vote)
Target Milestone: ---
Assignee: Elvis Angelaccio
URL:
Keywords:
: 446006 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-11-24 20:39 UTC by pveax
Modified: 2021-12-10 12:29 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pveax 2021-11-24 20:39:48 UTC
IMPORTANT NOTES

1. It is the same issue as was reported in the https://bugs.kde.org/show_bug.cgi?id=446006 ticked, but on newer (even unreleased) git KDE app's version.

2. I select `ark`'s closest (newest possible) version to what I have in the `*Version` list, but I was USING the newer (still absent in the list) version:
```
~/Desktop ❯ ark --version
ark 22.03.70
~/Desktop ❯ 
```
The GIT COMMIT HASH is `fe618843`.

SUMMARY

Ark crashed the plasmashell process when archiving (or ending to archive) a folder into 7zip default profile format (LZMA2, level 5/9 or 6/10)

STEPS TO REPRODUCE

0. Download the https://mirror.koddos.net/manjaro/unstable/core/x86_64/glibc-2.33-5-x86_64.pkg.tar.zst file to Desktop.
1. Unpack it. You got another archive.
2. Unpack it into single folder.
3. Click on mouse's secondary btn on that Desktop folder.
4. Select `Compress` -> `Compress to...`
5. In the popped up archiving setting window I have `7z` format already selected, probably I use default settings for all. Click OK.

Wait 10-15 seconds. Plasma panels disappeared and was restarted, core dump file appears.

OBSERVED RESULT

`plasmashell` crash

EXPECTED RESULT

No any crash while Ark archiving things.

SOFTWARE/OS VERSIONS

```
Operating System: Manjaro Linux
KDE Plasma Version: 5.23.80
KDE Frameworks Version: 5.89.0
Qt Version: 5.15.2
Kernel Version: 5.15.4-1-MANJARO (64-bit)
Graphics Platform: X11

Processors: 4 × Intel® Core™ i5-8250U CPU @ 1.60GHz
Memory: 31.1 GiB of RAM
Graphics Processor: Mesa Intel® UHD Graphics 620
```

ADDITIONAL INFORMATION

App versions possibly involved here:
```
~/Desktop ❯ plasmashell --version
plasmashell 5.23.80
```
`plasma-workspace` commit is `81bb5ae6a`
```
~/Desktop ❯ dolphin --version
dolphin 22.03.70
```
`dolphin` commit is `caa639fb4`

Severity chosen above crash, cause the process do not crash itself, but crash even other process.

Backtrace with no debugging symbols :(

```
gdb /usr/bin/plasmashell core.plasmashell.1000.d4580c22d52b48a3a96a4d87c5b2f1ae.975.1637772880000000 
...
[New LWP 1202]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/libthread_db.so.1".
Core was generated by `/usr/bin/plasmashell'.
Program terminated with signal SIGSEGV, Segmentation fault.
#0  0x00007f5c38364d22 in raise () from /usr/lib/libc.so.6
[Current thread is 1 (Thread 0x7f5c33aa0f40 (LWP 975))]
(gdb) bt
#0  0x00007f5c38364d22 in raise () at /usr/lib/libc.so.6
#1  0x00007f5c3a87346c in KCrash::defaultCrashHandler(int) () at /usr/lib/libKF5Crash.so.5
#2  0x00007f5c38364da0 in <signal handler called> () at /usr/lib/libc.so.6
#3  0x00007f5c389ed029 in QObjectPrivate::maybeSignalConnected(unsigned int) const () at /usr/lib/libQt5Core.so.5
#4  0x00007f5c389fa360 in  () at /usr/lib/libQt5Core.so.5
#5  0x00007f5c394ae901 in KJob::result(KJob*, KJob::QPrivateSignal) () at /usr/lib/libKF5CoreAddons.so.5
#6  0x00007f5c394b011c in KJob::finishJob(bool) () at /usr/lib/libKF5CoreAddons.so.5
#7  0x00007f5c389fa7cb in  () at /usr/lib/libQt5Core.so.5
#8  0x00007f5bed58f027 in Kerfuffle::ReadOnlyArchiveInterface::finished(bool) () at /usr/lib/libkerfuffle.so.22
#9  0x00007f5c389fa7cb in  () at /usr/lib/libQt5Core.so.5
#10 0x00007f5c3892c719 in QProcess::finished(int, QProcess::ExitStatus) () at /usr/lib/libQt5Core.so.5
#11 0x00007f5c38932226 in  () at /usr/lib/libQt5Core.so.5
#12 0x00007f5c3893235e in  () at /usr/lib/libQt5Core.so.5
#13 0x00007f5c389fa800 in  () at /usr/lib/libQt5Core.so.5
#14 0x00007f5c389fdc90 in QSocketNotifier::activated(QSocketDescriptor, QSocketNotifier::Type, QSocketNotifier::QPrivateSignal) () at /usr/lib/libQt5Core.so.5
#15 0x00007f5c389fe49d in QSocketNotifier::event(QEvent*) () at /usr/lib/libQt5Core.so.5
#16 0x00007f5c396c4d62 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /usr/lib/libQt5Widgets.so.5
#17 0x00007f5c389c341a in QCoreApplication::notifyInternal2(QObject*, QEvent*) () at /usr/lib/libQt5Core.so.5
#18 0x00007f5c38a1cc5e in  () at /usr/lib/libQt5Core.so.5
#19 0x00007f5c36c544dc in g_main_context_dispatch () at /usr/lib/libglib-2.0.so.0
#20 0x00007f5c36ca8799 in  () at /usr/lib/libglib-2.0.so.0
#21 0x00007f5c36c51bc1 in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
#22 0x00007f5c38a1c046 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#23 0x00007f5c389c1d8c in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#24 0x00007f5c389ca2f4 in QCoreApplication::exec() () at /usr/lib/libQt5Core.so.5
#25 0x000055e17747ddf6 in  ()
#26 0x00007f5c3834fb25 in __libc_start_main () at /usr/lib/libc.so.6
#27 0x000055e17747df4e in  ()
(gdb) 
```

Now for the Ark (which was not crashed) in the same core dump:

```
gdb /usr/bin/ark core.plasmashell.1000.d4580c22d52b48a3a96a4d87c5b2f1ae.975.1637772880000000
...
[New LWP 1202]
Core was generated by `/usr/bin/plasmashell'.
Program terminated with signal SIGSEGV, Segmentation fault.
#0  0x00007f5c38364d22 in ?? ()
[Current thread is 1 (LWP 975)]
(gdb) bt
#0  0x00007f5c38364d22 in ?? ()
#1  0x0000000000000000 in ?? ()
(gdb) 
```

---

Again that `??`. But I can't compile packages on my low power PC for many hours in order to get debug symbols of all packages involved. For the case at least: plasma-workspace, ark, may be others also.

Nate, other KDE teammates, can you confirm, please: does my (or any other) crash reports are useless without debugging symbols?
This could save your and my time: to do not to: collect info, post report and read such possible garbage.

Thank you!
Comment 1 Nicolas Fella 2021-12-10 12:25:05 UTC

*** This bug has been marked as a duplicate of bug 443540 ***
Comment 2 Nicolas Fella 2021-12-10 12:29:16 UTC
*** Bug 446006 has been marked as a duplicate of this bug. ***