Bug 446006 - Ark crashed the plasmashell process while archiving (or ending archiving) a folder into 7z default profile format
Summary: Ark crashed the plasmashell process while archiving (or ending archiving) a f...
Status: RESOLVED DUPLICATE of bug 446049
Alias: None
Product: ark
Classification: Unclassified
Component: general (show other bugs)
Version: 21.08.3
Platform: Manjaro Linux
: NOR major (vote)
Target Milestone: ---
Assignee: Elvis Angelaccio
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-11-23 23:28 UTC by pveax
Modified: 2021-12-10 12:29 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pveax 2021-11-23 23:28:15 UTC
SUMMARY
Ark crashed the plasmashell process when archiving (or ending to archive) a folder into 7zip default profile format (LZMA2, level 5/9 or 6/10)

STEPS TO REPRODUCE
0. Download the https://mirror.koddos.net/manjaro/unstable/core/x86_64/glibc-2.33-5-x86_64.pkg.tar.zst file to Desktop.
1. Unpack it. You got another archive.
2. Unpack it into single folder.
3. Click on mouse's secondary btn on that Desktop folder.
4. Select `Compress` -> `Compress to...`
5. In the popped up archiving setting window I have `7z` format already selected, probably I use default settings for all. Click OK.

Wait 10-15 seconds. Plasma panels disappeared and was restarted, core dump file appears.

OBSERVED RESULT
plasmashell crash

EXPECTED RESULT
No crash while Ark archiving things.

SOFTWARE/OS VERSIONS
```
Operating System: Manjaro Linux
KDE Plasma Version: 5.23.3
KDE Frameworks Version: 5.88.0
Qt Version: 5.15.2
Kernel Version: 5.15.4-1-MANJARO (64-bit)
Graphics Platform: X11

Processors: 4 × Intel® Core™ i5-8250U CPU @ 1.60GHz
Memory: 31.1 GiB of RAM
Graphics Processor: Mesa Intel® UHD Graphics 620
```

ADDITIONAL INFORMATION

Severity chosen above crash, cause the process do not crash itself, but crash even other process.

Backtrace with no debugging symbols :(

```
gdb /usr/bin/plasmashell core.plasmashell.1000.8ac0b922ee1442ef8b4092f6ab7f7ab0.1022.1637690834000000
...
[New LWP 1094]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/libthread_db.so.1".
Core was generated by `/usr/bin/plasmashell'.
Program terminated with signal SIGABRT, Aborted.
#0  0x00007eff4535fd22 in raise () from /usr/lib/libc.so.6
[Current thread is 1 (Thread 0x7efef974b640 (LWP 1355))]
(gdb) bt
#0  0x00007eff4535fd22 in raise () at /usr/lib/libc.so.6
#1  0x00007eff4784d3e0 in KCrash::defaultCrashHandler(int) () at /usr/lib/libKF5Crash.so.5
#2  0x00007eff4535fda0 in <signal handler called> () at /usr/lib/libc.so.6
#3  0x00007eff4535fd22 in raise () at /usr/lib/libc.so.6
#4  0x00007eff45349862 in abort () at /usr/lib/libc.so.6
#5  0x00007eff3d50d63d in  () at /usr/lib/dri/iris_dri.so
#6  0x00007eff3e0307f4 in  () at /usr/lib/dri/iris_dri.so
#7  0x00007eff3d595e84 in  () at /usr/lib/dri/iris_dri.so
#8  0x00007eff3d52f1e1 in  () at /usr/lib/dri/iris_dri.so
#9  0x00007eff3ef1ec3c in  () at /usr/lib/libGLX_mesa.so.0
#10 0x00007eff3f7b191d in  () at /usr/lib/qt/plugins/xcbglintegrations/libqxcb-glx-integration.so
#11 0x00007eff473e0d1d in  () at /usr/lib/libQt5Quick.so.5
#12 0x00007eff473e1527 in  () at /usr/lib/libQt5Quick.so.5
#13 0x00007eff457d640b in  () at /usr/lib/libQt5Core.so.5
#14 0x00007eff44764259 in start_thread () at /usr/lib/libpthread.so.0
#15 0x00007eff454215e3 in clone () at /usr/lib/libc.so.6
(gdb) 
```

Now for the Ark (which was not crashed) in the same core dump:

```
gdb /usr/bin/ark core.plasmashell.1000.8ac0b922ee1442ef8b4092f6ab7f7ab0.1022.1637690834000000        
...
[New LWP 1094]
Core was generated by `/usr/bin/plasmashell'.
Program terminated with signal SIGABRT, Aborted.
#0  0x00007eff4535fd22 in ?? ()
[Current thread is 1 (LWP 1355)]
(gdb) bt
#0  0x00007eff4535fd22 in ?? ()
#1  0x0000000000000000 in ?? ()
(gdb) 
```
Comment 1 Nicolas Fella 2021-12-10 12:29:16 UTC
Even though the backtrace is completely different I'd say it's likely the same root cause as https://bugs.kde.org/show_bug.cgi?id=446049

Even if is isn't the backtrace isn't telling us anything useful I'm afraid

*** This bug has been marked as a duplicate of bug 446049 ***