Bug 445886 - Add some padding around menu highlight
Summary: Add some padding around menu highlight
Status: RESOLVED FIXED
Alias: None
Product: Breeze
Classification: Unclassified
Component: QStyle (show other bugs)
Version: master
Platform: Other Linux
: NOR wishlist
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 446198 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-11-21 23:43 UTC by Photon
Modified: 2022-02-20 15:27 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.25


Attachments
Weird looking (6.86 KB, image/png)
2021-11-21 23:43 UTC, Photon
Details
Zoomed image (1.57 KB, image/png)
2021-11-21 23:43 UTC, Photon
Details
Screenshot showing old behavior (28.89 KB, image/png)
2022-02-20 12:40 UTC, Oded Arbel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Photon 2021-11-21 23:43:30 UTC
Created attachment 143819 [details]
Weird looking

Breeze now has rounded corners in the selected menu item. However, the rounded corners look too weird when the item has an outline right after it or when the item is the first/last. Maybe the rounded corners could be dropped too.
Comment 1 Photon 2021-11-21 23:43:42 UTC
Created attachment 143820 [details]
Zoomed image
Comment 2 Photon 2021-11-21 23:46:01 UTC
Also, increasing the padding of menus would fix that bug which the first item is clicked right after the menu is opened (can't find it right now).
Comment 3 Bug Janitor Service 2022-02-16 18:51:49 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/breeze/-/merge_requests/186
Comment 4 Nate Graham 2022-02-16 19:12:47 UTC
(In reply to Photon from comment #2)
> Also, increasing the padding of menus would fix that bug which the first
> item is clicked right after the menu is opened (can't find it right now).

Bug 374311. And yes, it would fix that too! How exciting.
Comment 5 Jan Blackquill 2022-02-17 23:56:45 UTC
Git commit 3993ab7900986b2c594ccad34ab93d30ff346f01 by Jan Blackquill, on behalf of Janet Blackquill.
Committed on 17/02/2022 at 23:42.
Pushed by ngraham into branch 'master'.

kstyle: add menu margin

This is more consistent with Plasma and our qqc2-desktop-style.
Related: bug 374311
FIXED-IN: 5.25

M  +1    -0    kstyle/breezemetrics.h
M  +4    -0    kstyle/breezestyle.cpp

https://invent.kde.org/plasma/breeze/commit/3993ab7900986b2c594ccad34ab93d30ff346f01
Comment 6 Oded Arbel 2022-02-20 12:40:30 UTC
Created attachment 146976 [details]
Screenshot showing old behavior

Up until this change, the menu item highlight looked like it extends past the edge of the menu by a pixel on either side (the effect is seen better on dark backgrounds, as shown on the right side of the attached screenshot and is not visible on the left side's bright background).

I though that effect was interesting, different and quirky - all in a good way, and I'm sad to see it go.
Comment 7 Nate Graham 2022-02-20 15:27:56 UTC
*** Bug 446198 has been marked as a duplicate of this bug. ***