Bug 445859 - Spectacle Rectangle Screenshot Shortcut ignores include mouse pointer
Summary: Spectacle Rectangle Screenshot Shortcut ignores include mouse pointer
Status: RESOLVED DUPLICATE of bug 392057
Alias: None
Product: Spectacle
Classification: Unclassified
Component: General (show other bugs)
Version: 21.08.3
Platform: Other Linux
: NOR normal
Target Milestone: ---
Assignee: Boudhayan Gupta
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-11-21 12:00 UTC by saif1988
Modified: 2021-12-01 17:29 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description saif1988 2021-11-21 12:00:30 UTC
SUMMARY
When using Spectacle to take rectangular area screenshot with a KEYBOARD SHORTCUT, the mouse pointer appears on the screenshot even if it was disabled.

STEPS TO REPRODUCE
1. Configure a shortcut to take a rectangular area screenshot
2. Disable in Spectacle "Include mouse Pointer"
3. Use keyboard shortcut to trigger the area screenshot

OBSERVED RESULT
The mouse pointer appears in the frozen screen!!!

EXPECTED RESULT
Should not!!!


Operating System: EndeavourOS
KDE Plasma Version: 5.23.3
KDE Frameworks Version: 5.88.0
Qt Version: 5.15.2
Kernel Version: 5.15.3-arch1-1 (64-bit)
Graphics Platform: X11
Processors: 12 × Intel® Core™ i7-8750H CPU @ 2.20GHz
Memory: 31,2 GiB of RAM
Graphics Processor: Mesa Intel® UHD Graphics 630
Comment 1 saif1988 2021-11-21 12:01:12 UTC
To support the bug report, it seems this issue also happens to other users: https://www.reddit.com/r/kde/comments/i1r4uq/help_spectacle_captures_mouse_pointer_in/
Comment 2 Bharadwaj Raju 2021-11-24 16:37:15 UTC

*** This bug has been marked as a duplicate of bug 442074 ***
Comment 3 Nate Graham 2021-12-01 17:29:28 UTC

*** This bug has been marked as a duplicate of bug 392057 ***