Bug 442074 - Shortcuts for taking a screenshot always capture cursor regardless of in-app option
Summary: Shortcuts for taking a screenshot always capture cursor regardless of in-app ...
Status: RESOLVED DUPLICATE of bug 392057
Alias: None
Product: Spectacle
Classification: Unclassified
Component: General (show other bugs)
Version: 21.08.1
Platform: Other Linux
: NOR normal
Target Milestone: ---
Assignee: Antonio Prcela
URL:
Keywords: usability
Depends on:
Blocks:
 
Reported: 2021-09-06 12:39 UTC by ratijas
Modified: 2021-12-01 17:29 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ratijas 2021-09-06 12:39:19 UTC
SUMMARY
Actions triggered by shortcuts such as the default Meta+Shift+Print (Capture Rectangular Region) do not respect in-app setting whether to "Include mouse pointer".

STEPS TO REPRODUCE
1. Open Spectacle.
2. Disable "Include mouse pointer" option. It's in the main window, not on a settings page.
3. Close Spectacle (Maybe re-open, just to ensure options were persisted).
4. Take a screenshot using one of your shortcuts.

OBSERVED RESULT
Cursor (mouse pointer) is included in a screenshot picture.

EXPECTED RESULT
It should not.

SOFTWARE/OS VERSIONS
Operating System: Arch Linux
KDE Plasma Version: 5.22.5
KDE Frameworks Version: 5.86.0
Qt Version: 5.15.2
Kernel Version: 5.13.13-arch1-1 (64-bit)
Graphics Platform: X11
Processors: 8 × Intel® Core™ i7-6700HQ CPU @ 2.60GHz
Memory: 15.6 GiB of RAM
Graphics Processor: NVIDIA GeForce GTX 970M/PCIe/SSE2

ADDITIONAL INFORMATION
Comment 1 Antonio Prcela 2021-10-24 20:30:52 UTC
Can confirm, but only using META+SHIFT+PRINT for Rectangual region. All others don't include the mouse pointer.
Can you confirm or do you get the mouse pointer included with every shortcut combination?
Comment 2 Bharadwaj Raju 2021-11-24 16:37:15 UTC
*** Bug 445859 has been marked as a duplicate of this bug. ***
Comment 3 Miepee 2021-11-24 16:43:51 UTC
Wanted to confirm that this happens to me too. However, my rectangual region shortcut is "META+SHIFT+S". I also tried the shortcuts "META+B", "SHIFT+B", "M" as well as "CTRL+." and the same behavior was observed in all of them.

System specs:
Operating System: Arch Linux
KDE Plasma Version: 5.23.3
KDE Frameworks Version: 5.88.0
Qt Version: 5.15.2
Kernel Version: 5.15.2-arch1-1 (64-bit)
Graphics Platform: X11
Processors: 12 × AMD Ryzen 5 1600 Six-Core Processor
Memory: 15.6 GiB of RAM
Graphics Processor: AMD Radeon RX 570 Series
Comment 4 Bharadwaj Raju 2021-11-24 16:45:02 UTC
The flag for including mouse pointer is part of the DBus API, and there seems to be no way to specify "whatever the user set in Spectacle" using it. Currently it's set to true in the definition for the RectangularRegionScreenShot desktop action.
Comment 5 Miepee 2021-11-25 13:34:31 UTC
Discovered that Bug (392057) exists, pretty sure this is a duplicate of it.
Comment 6 Bug Janitor Service 2021-11-27 17:03:10 UTC
A possibly relevant merge request was started @ https://invent.kde.org/graphics/spectacle/-/merge_requests/98
Comment 7 Antonio Prcela 2021-11-27 17:08:29 UTC
(In reply to Jan from comment #5)
> Discovered that Bug (392057) exists, pretty sure this is a duplicate of it.

Hm, seems so. But it also mentions "include window decorations".
The MR above is only for mouse pointer. Tho, adding "include window decorations" is straight forward and could be implemented in the same MR.
Comment 8 Miepee 2021-11-28 11:58:34 UTC
I'd be in favour of it.
Since 392057 talks of "etc." does it make sense to include "Capture the current pop-up only" in that MR as well?
Comment 9 Antonio Prcela 2021-11-28 16:43:59 UTC
(In reply to Jan from comment #8)
> I'd be in favour of it.
> Since 392057 talks of "etc." does it make sense to include "Capture the
> current pop-up only" in that MR as well?

is doable, let's see tho what first impressions are in the MR
Comment 10 Nate Graham 2021-12-01 17:29:23 UTC

*** This bug has been marked as a duplicate of bug 392057 ***