Bug 445770 - Dolphin crashes when using right-click Compress as ZIP
Summary: Dolphin crashes when using right-click Compress as ZIP
Status: RESOLVED DUPLICATE of bug 443540
Alias: None
Product: dolphin
Classification: Unclassified
Component: general (show other bugs)
Version: 21.08.3
Platform: Neon Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2021-11-19 19:44 UTC by Steve Zakulec
Modified: 2021-11-19 23:58 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steve Zakulec 2021-11-19 19:44:59 UTC
Application: dolphin (21.08.3)

Qt Version: 5.15.3
Frameworks Version: 5.87.0
Operating System: Linux 5.11.0-40-generic x86_64
Windowing System: X11
Distribution: KDE neon User - Plasma 25th Anniversary Edition
DrKonqi: 5.23.3 [KCrashBackend]

-- Information about the crash:
- What I was doing when the application crashed:
I was compressing a set of .PNG files with the right click menu option Compress, Compress as ZIP.
ZIP file appears to be created successfully, but Dolphin crashes, and throws up an error box saying "Compressing a file (failed) Application closed unexpectedly".

- Custom settings of the application:

The crash can be reproduced every time.

-- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault

[New LWP 1431]
[New LWP 1445]
[New LWP 1581]
[New LWP 1582]
[New LWP 1583]
[New LWP 1584]
[New LWP 1593]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
0x00007f5ea5b76aff in __GI___poll (fds=0x7fff1740a7f8, nfds=1, timeout=1000) at ../sysdeps/unix/sysv/linux/poll.c:29
__preamble__
[Current thread is 1 (Thread 0x7f5ea11329c0 (LWP 1420))]

Thread 8 (Thread 0x7f5e89847700 (LWP 1593)):
#0  0x00007fff174f9b1e in clock_gettime ()
#1  0x00007f5ea5b41235 in __GI___clock_gettime (clock_id=1, tp=0x7f5e89846950) at ../sysdeps/unix/sysv/linux/clock_gettime.c:38
#2  0x00007f5ea6143ee5 in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#3  0x00007f5ea614277d in QTimerInfoList::updateCurrentTime() () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007f5ea6142d59 in QTimerInfoList::timerWait(timespec&) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f5ea6144376 in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007f5ea3c088ef in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#7  0x00007f5ea3c0929b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#8  0x00007f5ea3c094a3 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#9  0x00007f5ea614461b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#10 0x00007f5ea60e88ab in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#11 0x00007f5ea5f022c2 in QThread::exec() () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#12 0x00007f5ea5f0345c in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#13 0x00007f5ea4687609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#14 0x00007f5ea5b83293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 7 (Thread 0x7f5e95eea700 (LWP 1584)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x564e95754c88) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x564e95754c38, cond=0x564e95754c60) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x564e95754c60, mutex=0x564e95754c38) at pthread_cond_wait.c:638
#3  0x00007f5e96833e7b in ?? () from /usr/lib/x86_64-linux-gnu/dri/iris_dri.so
#4  0x00007f5e96833a7b in ?? () from /usr/lib/x86_64-linux-gnu/dri/iris_dri.so
#5  0x00007f5ea4687609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#6  0x00007f5ea5b83293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 6 (Thread 0x7f5e966eb700 (LWP 1583)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x564e95754c88) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x564e95754c38, cond=0x564e95754c60) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x564e95754c60, mutex=0x564e95754c38) at pthread_cond_wait.c:638
#3  0x00007f5e96833e7b in ?? () from /usr/lib/x86_64-linux-gnu/dri/iris_dri.so
#4  0x00007f5e96833a7b in ?? () from /usr/lib/x86_64-linux-gnu/dri/iris_dri.so
#5  0x00007f5ea4687609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#6  0x00007f5ea5b83293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 5 (Thread 0x7f5e9cd48700 (LWP 1582)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x564e95754c88) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x564e95754c38, cond=0x564e95754c60) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x564e95754c60, mutex=0x564e95754c38) at pthread_cond_wait.c:638
#3  0x00007f5e96833e7b in ?? () from /usr/lib/x86_64-linux-gnu/dri/iris_dri.so
#4  0x00007f5e96833a7b in ?? () from /usr/lib/x86_64-linux-gnu/dri/iris_dri.so
#5  0x00007f5ea4687609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#6  0x00007f5ea5b83293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 4 (Thread 0x7f5e9d549700 (LWP 1581)):
#0  futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x564e95754c88) at ../sysdeps/nptl/futex-internal.h:183
#1  __pthread_cond_wait_common (abstime=0x0, clockid=0, mutex=0x564e95754c38, cond=0x564e95754c60) at pthread_cond_wait.c:508
#2  __pthread_cond_wait (cond=0x564e95754c60, mutex=0x564e95754c38) at pthread_cond_wait.c:638
#3  0x00007f5e96833e7b in ?? () from /usr/lib/x86_64-linux-gnu/dri/iris_dri.so
#4  0x00007f5e96833a7b in ?? () from /usr/lib/x86_64-linux-gnu/dri/iris_dri.so
#5  0x00007f5ea4687609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#6  0x00007f5ea5b83293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 3 (Thread 0x7f5e9f9e7700 (LWP 1445)):
#0  0x00007f5ea5b76aff in __GI___poll (fds=0x7f5e90004e60, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f5ea3c0936e in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f5ea3c094a3 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f5ea614461b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007f5ea60e88ab in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f5ea5f022c2 in QThread::exec() () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007f5ea719cf4b in ?? () from /lib/x86_64-linux-gnu/libQt5DBus.so.5
#7  0x00007f5ea5f0345c in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x00007f5ea4687609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#9  0x00007f5ea5b83293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 2 (Thread 0x7f5ea05c4700 (LWP 1431)):
#0  0x00007f5ea5b76aff in __GI___poll (fds=0x7f5ea05c3ae8, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007f5ea46bdc1a in ?? () from /lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f5ea46bf90a in xcb_wait_for_event () from /lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f5ea0d06e88 in ?? () from /lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
#4  0x00007f5ea5f0345c in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f5ea4687609 in start_thread (arg=<optimized out>) at pthread_create.c:477
#6  0x00007f5ea5b83293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7f5ea11329c0 (LWP 1420)):
[KCrash Handler]
#4  0x00007f5ea6120b5c in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f5ea7354d10 in KJob::result(KJob*, KJob::QPrivateSignal) () from /lib/x86_64-linux-gnu/libKF5CoreAddons.so.5
#6  0x00007f5ea735618b in KJob::finishJob(bool) () from /lib/x86_64-linux-gnu/libKF5CoreAddons.so.5
#7  0x00007f5e9c21d1b8 in Kerfuffle::Job::onFinished (this=0x7f5e90003800, result=<optimized out>) at ./kerfuffle/jobs.cpp:217
#8  0x00007f5ea6120dce in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#9  0x00007f5e9c2078b6 in Kerfuffle::ReadOnlyArchiveInterface::finished (this=this@entry=0x564e95f80f10, _t1=<optimized out>, _t1@entry=true) at ./obj-x86_64-linux-gnu/kerfuffle/kerfuffle_autogen/EWIEGA46WW/moc_archiveinterface.cpp:293
#10 0x00007f5e9c243eb0 in Kerfuffle::CliInterface::processFinished (this=0x564e95f80f10, exitCode=<optimized out>, exitStatus=<optimized out>) at ./kerfuffle/cliinterface.cpp:346
#11 0x00007f5ea6120dce in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#12 0x00007f5ea60578bc in QProcess::finished(int, QProcess::ExitStatus) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#13 0x00007f5ea606101f in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#14 0x00007f5ea6061202 in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#15 0x00007f5ea6120e00 in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#16 0x00007f5ea6124e53 in QSocketNotifier::activated(QSocketDescriptor, QSocketNotifier::Type, QSocketNotifier::QPrivateSignal) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#17 0x00007f5ea61255f3 in QSocketNotifier::event(QEvent*) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#18 0x00007f5ea6bc5dc3 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /lib/x86_64-linux-gnu/libQt5Widgets.so.5
#19 0x00007f5ea6bcebb8 in QApplication::notify(QObject*, QEvent*) () from /lib/x86_64-linux-gnu/libQt5Widgets.so.5
#20 0x00007f5ea60e9daa in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#21 0x00007f5ea6145205 in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#22 0x00007f5ea3c0917d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007f5ea3c09400 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007f5ea3c094a3 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#25 0x00007f5ea6144602 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#26 0x00007f5ea60e88ab in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#27 0x00007f5ea60f0a64 in QCoreApplication::exec() () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#28 0x0000564e938a3fb2 in main (argc=<optimized out>, argv=<optimized out>) at ./src/main.cpp:222
[Inferior 1 (process 1420) detached]

Possible duplicates by query: bug 445222, bug 444861, bug 444758, bug 444687, bug 444679.

Reported using DrKonqi
Comment 1 Nicolas Fella 2021-11-19 23:58:24 UTC

*** This bug has been marked as a duplicate of bug 443540 ***