Bug 444679 - Dolphin crashes when copying many files to remote folder using webdavs
Summary: Dolphin crashes when copying many files to remote folder using webdavs
Status: RESOLVED DUPLICATE of bug 364039
Alias: None
Product: dolphin
Classification: Unclassified
Component: general (show other bugs)
Version: 21.08.0
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2021-10-30 19:15 UTC by jdl
Modified: 2022-05-28 21:55 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jdl 2021-10-30 19:15:45 UTC
Application: dolphin (21.08.0)

Qt Version: 5.15.2
Frameworks Version: 5.85.0
Operating System: Linux 5.14.14-200.fc34.x86_64 x86_64
Windowing System: X11
Drkonqi Version: 5.22.5
Distribution: Fedora 34 (KDE Plasma)

-- Information about the crash:
- What I was doing when the application crashed:
copying 13000 files from a locally mounted hdd, partitioned with btrfs, to a NAS running Truenas Scale. 
1500 files succeeded in 20 minutes, but then Dolphin unexpectedly closed.
Protocol used was webdavs.
- Custom settings of the application:

The reporter is unsure if this crash is reproducible.

-- Backtrace:
Application: Dolphin (dolphin), signal: Aborted

[KCrash Handler]
#4  0x00007f2375e962a2 in raise () from /lib64/libc.so.6
#5  0x00007f2375e7f8a4 in abort () from /lib64/libc.so.6
#6  0x00007f23760cba46 in __gnu_cxx::__verbose_terminate_handler() [clone .cold] () from /lib64/libstdc++.so.6
#7  0x00007f23760d729c in __cxxabiv1::__terminate(void (*)()) () from /lib64/libstdc++.so.6
#8  0x00007f23760d7307 in std::terminate() () from /lib64/libstdc++.so.6
#9  0x00007f23760d75a9 in __cxa_throw () from /lib64/libstdc++.so.6
#10 0x00007f23762f97f1 in qBadAlloc() () from /lib64/libQt5Core.so.5
#11 0x00007f23762fbf58 in QListData::detach_grow(int*, int) [clone .cold] () from /lib64/libQt5Core.so.5
#12 0x00007f23764df3f0 in QList<QObject*>::detach_helper_grow(int, int) () from /lib64/libQt5Core.so.5
#13 0x00007f23764df4f6 in QList<QObject*>::append(QObject* const&) () from /lib64/libQt5Core.so.5
#14 0x00007f237651f9da in QObjectPrivate::setParent_helper(QObject*) () from /lib64/libQt5Core.so.5
#15 0x00007f23770c4bd2 in QWidgetPrivate::setParent_sys(QWidget*, QFlags<Qt::WindowType>) () from /lib64/libQt5Widgets.so.5
#16 0x00007f23770d1417 in QWidget::setParent(QWidget*, QFlags<Qt::WindowType>) () from /lib64/libQt5Widgets.so.5
#17 0x00007f23770d177e in QWidgetPrivate::init(QWidget*, QFlags<Qt::WindowType>) () from /lib64/libQt5Widgets.so.5
#18 0x00007f237729c7d3 in QDialog::QDialog(QWidget*, QFlags<Qt::WindowType>) () from /lib64/libQt5Widgets.so.5
#19 0x00007f23780c8eed in KIO::SkipDialog::SkipDialog(QWidget*, QFlags<KIO::SkipDialog_Option>, QString const&) () from /lib64/libKF5KIOWidgets.so.5
#20 0x00007f23780e0051 in KIO::WidgetsAskUserActionHandler::askUserSkip(KJob*, QFlags<KIO::SkipDialog_Option>, QString const&) () from /lib64/libKF5KIOWidgets.so.5
#21 0x00007f2377e235d4 in KIO::CopyJobPrivate::slotResultErrorCopyingFiles(KJob*) () from /lib64/libKF5KIOCore.so.5
#22 0x00007f23765233a9 in void doActivate<false>(QObject*, int, void**) () from /lib64/libQt5Core.so.5
#23 0x00007f23776b5cf0 in KJob::result(KJob*, KJob::QPrivateSignal) () from /lib64/libKF5CoreAddons.so.5
#24 0x00007f23776ba5cb in KJob::finishJob(bool) () from /lib64/libKF5CoreAddons.so.5
#25 0x00007f23765233a9 in void doActivate<false>(QObject*, int, void**) () from /lib64/libQt5Core.so.5
#26 0x00007f23776b5cf0 in KJob::result(KJob*, KJob::QPrivateSignal) () from /lib64/libKF5CoreAddons.so.5
#27 0x00007f23776ba5cb in KJob::finishJob(bool) () from /lib64/libKF5CoreAddons.so.5
#28 0x00007f23765233a9 in void doActivate<false>(QObject*, int, void**) () from /lib64/libQt5Core.so.5
#29 0x00007f2377e422ea in KIO::SlaveInterface::error(int, QString const&) () from /lib64/libKF5KIOCore.so.5
#30 0x00007f2377e41ad7 in KIO::SlaveInterface::dispatch(int, QByteArray const&) () from /lib64/libKF5KIOCore.so.5
#31 0x00007f2377e3a25d in KIO::SlaveInterface::dispatch() () from /lib64/libKF5KIOCore.so.5
#32 0x00007f2377e43af2 in KIO::Slave::gotInput() () from /lib64/libKF5KIOCore.so.5
#33 0x00007f23765233a9 in void doActivate<false>(QObject*, int, void**) () from /lib64/libQt5Core.so.5
#34 0x00007f2376519f09 in QObject::event(QEvent*) () from /lib64/libQt5Core.so.5
#35 0x00007f237708d443 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /lib64/libQt5Widgets.so.5
#36 0x00007f23764ef798 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /lib64/libQt5Core.so.5
#37 0x00007f23764f2d06 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /lib64/libQt5Core.so.5
#38 0x00007f23765410d7 in postEventSourceDispatch(_GSource*, int (*)(void*), void*) () from /lib64/libQt5Core.so.5
#39 0x00007f23742264cf in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#40 0x00007f237427a4f8 in g_main_context_iterate.constprop () from /lib64/libglib-2.0.so.0
#41 0x00007f2374223c03 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#42 0x00007f2376540b78 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#43 0x00007f23764ee1a2 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#44 0x00007f23764f66e4 in QCoreApplication::exec() () from /lib64/libQt5Core.so.5
#45 0x000055d924f4d64f in main ()
[Inferior 1 (process 43445) detached]

The reporter indicates this bug may be a duplicate of or related to bug 439542, bug 364039.

Possible duplicates by query: bug 439542, bug 437773, bug 431077, bug 419440, bug 411812.

Reported using DrKonqi
Comment 1 postix 2022-05-28 21:55:37 UTC

*** This bug has been marked as a duplicate of bug 364039 ***