Bug 444676 - Option for auto-generated accent color from current wallpaper
Summary: Option for auto-generated accent color from current wallpaper
Status: RESOLVED FIXED
Alias: None
Product: systemsettings
Classification: Unclassified
Component: kcm_colors (show other bugs)
Version: 5.23.2
Platform: Archlinux Packages Linux
: NOR wishlist with 20 votes (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 442300 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-10-30 18:33 UTC by Dominik Kummer
Modified: 2022-04-22 14:52 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.25


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dominik Kummer 2021-10-30 18:33:47 UTC
SUMMARY
An option "use desktop/wallpaper color" could be totally helpful to visually indicate the current activity/virtual desktop, and assist to mentally associate and activate skillsets for activity-related tasks.

STEPS TO REPRODUCE
1. Configure Desktop and Wallpaper ...
2. Set plain color as Wallpaper
3. Configure Global Color Scheme in system settings
4. Use accent color: choose option "Wallpaper color"

OBSERVED RESULT
option not available

EXPECTED RESULT
Color Settings UI
  Use accent color:
    [ ] From current color scheme
    [*] From current wallpaper color
    [ ] Custom
Comment 1 Dominik Kummer 2021-11-25 13:33:24 UTC
*** Bug 442300 has been marked as a duplicate of this bug. ***
Comment 2 Nate Graham 2022-04-12 16:15:41 UTC
In progress with https://invent.kde.org/plasma/plasma-workspace/-/merge_requests/1325!
Comment 3 Nate Graham 2022-04-22 14:52:09 UTC
Git commit 6eb2b529452dc4db003783046f3b3e74edb5e037 by Nate Graham, on behalf of Tanbir Jishan.
Committed on 22/04/2022 at 14:52.
Pushed by ngraham into branch 'master'.

kcms/colors: Add an option to apply accent color from wallpaper

This adds an option to set the accent color from the current wallpaper.

The way it works is that it exposes some DBus calls; if a wallpaper plugin
supports wallpaper accent colors then it should say so by this DBus call
when starting up and also should say which wallpaper is being currently
used (for the purpose of extracting an accent color from it) or set an
accent color itself. After that it should keep declaring the wallpaper or
set accent color whenever wallpaper changes or whenever the plugin author
thinks it is appropriate to say so.

There is already an implementation of the color extracting algorithm which
the plugin can either use, or else set whatever accent color it wants. The
necessary DBus calls for the official image and wallpaper plugin are
implemented, so they should work out of the box.
FIXED-IN: 5.25

M  +47   -0    kcms/colors/CMakeLists.txt
A  +47   -0    kcms/colors/accentColorService/accentColorService.cpp  *
A  +22   -0    kcms/colors/accentColorService/accentColorService.h  *
A  +8    -0    kcms/colors/accentColorService/accentColorService.json
M  +41   -0    kcms/colors/colors.cpp
M  +13   -1    kcms/colors/colors.h
M  +4    -0    kcms/colors/colorssettings.kcfg
M  +1    -1    kcms/colors/colorssettings.kcfgc
M  +43   -7    kcms/colors/package/contents/ui/main.qml
M  +3    -0    shell/CMakeLists.txt
M  +6    -0    shell/dbus/org.kde.PlasmaShell.xml
M  +28   -0    shell/desktopview.cpp
M  +6    -0    shell/desktopview.h
M  +13   -0    shell/shellcorona.cpp
M  +2    -0    shell/shellcorona.h

The files marked with a * at the end have a non valid license. Please read: https://community.kde.org/Policies/Licensing_Policy and use the headers which are listed at that page.


https://invent.kde.org/plasma/plasma-workspace/commit/6eb2b529452dc4db003783046f3b3e74edb5e037