Bug 442300 - Little to no visual indication of which virtual desktop or activity I'm currently in
Summary: Little to no visual indication of which virtual desktop or activity I'm curre...
Status: RESOLVED DUPLICATE of bug 444676
Alias: None
Product: plasmashell
Classification: Plasma
Component: general (show other bugs)
Version: 5.23.1
Platform: Archlinux Linux
: NOR wishlist
Target Milestone: 1.0
Assignee: David Edmundson
URL:
Keywords: usability
Depends on:
Blocks:
 
Reported: 2021-09-11 11:15 UTC by Dominik Kummer
Modified: 2021-11-25 13:33 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
glowing screen edge based on desktop color/image (419.06 KB, image/png)
2021-09-17 10:19 UTC, Dominik Kummer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dominik Kummer 2021-09-11 11:15:35 UTC
SUMMARY
As I am working with a workflow matrix of several virtual desktops and activities with specific colors assigned (education:green,work:blue,creative:orange,devel:violet) to place related applications in their "buckets" with window rules, shortcuts for quick window access, plus krohnkite as tiling script: It would be awesome to have the window shadow changing according to the current desktop background color! I am a bit of a visual guy, and the colors help me to mentally switch context.

Additionally I am currently working on a showcase video of this described technique to contribute to the 25th kde anniversary video call. I'd love to demonstrate this accordingly colored window shadow, because it makes the point of this vdesktop/activity/window-rule/shortcut technique visually better comprehensible to people who are used "linear" workflows like ms windows where applications tend to be all over the place.

But maybe there is a better way to indicate the current vdesktop/activity by color which I haven't found yet.


SOFTWARE/OS VERSIONS
KDE Plasma Version: 5.22.5
Comment 1 Nate Graham 2021-09-16 17:07:48 UTC
Thanks for working on all this 25th anniversary stuff!

However I'm sorry to say that customizable per-virtual desktop/Activity Breeze theme window shadow colors is probably not going to happen as it would be a very weird niche feature. I think it would be better to step back and define the problem as "There is little to no visual indication of which virtual desktop or activity I'm currently in" which is a real issue.

For Activities, you can change the wallpaper so that each activity has a different one. You can use solid colors, or different images. However you can't do that for virtual Desktops; see Bug 341143.

Would being able to change the wallpaper for virtual desktops provide you what you need?
Comment 2 Dominik Kummer 2021-09-17 10:19:51 UTC
Created attachment 141644 [details]
glowing screen edge based on desktop color/image
Comment 3 Dominik Kummer 2021-09-17 10:23:46 UTC
Another indicator I could think of is a kwin effect which just generates a colored glow around the screen edge based on the current desktop background, with optional glow radius. Similar to the panel-autohide-glow.
Thats because if one uses krohnkite it happens that windows are covering the desktop most of the time. Not sure if its a weird niche, its just longterm usage of kde, which is probably not that weird.
Comment 4 Nate Graham 2021-09-17 13:04:54 UTC
That could work too.
Comment 5 Dominik Kummer 2021-10-20 19:07:27 UTC
Congratulations to the 25th anniversary edition!!!
Its beautiful and it gave me another vision, already navigating through kde source code. The craft so long to learn..

Anyways, now there is the System Settings/Appearance/Colors/Custom Option with several predefined colors. An additional option "use wallpaper color" could solve my niche issue perfectly. Also System Settings/Appearance/Window Decoration/Breeze/Shadows could provide a checkbox "use accent color"
Do you think it is hard to implement?

It could really bring the MS Windows Logo Symbolism to a real practical experience of colorful multitasking by activity, and shows yet again that KDE is a step ahead :-D

best wishes
Comment 6 Dominik Kummer 2021-11-25 13:33:24 UTC

*** This bug has been marked as a duplicate of bug 444676 ***