Bug 444413 - Plasma Crash when quiting double-shown Mattermost via task bar
Summary: Plasma Crash when quiting double-shown Mattermost via task bar
Status: RESOLVED DUPLICATE of bug 443961
Alias: None
Product: plasmashell
Classification: Unclassified
Component: general (show other bugs)
Version: 5.23.0
Platform: openSUSE RPMs Linux
: NOR crash
Target Milestone: 1.0
Assignee: David Edmundson
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2021-10-26 07:40 UTC by Andreas Grupp
Modified: 2021-10-26 14:06 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Grupp 2021-10-26 07:40:03 UTC
Application: plasmashell (5.23.0)

Qt Version: 5.15.2
Frameworks Version: 5.87.0
Operating System: Linux 5.14.11-2-default x86_64
Windowing System: X11
Distribution: "openSUSE Tumbleweed"
DrKonqi: 5.23.0 [KCrashBackend]

-- Information about the crash:
- What I was doing when the application crashed:
During system start I have Mattermost as autostart application. This app is then shown twice(!!), by two identical icons, in the control section of the task bar, although it is running only once. Right click on the icon to quit leads first to disappearance of one icon, then the second goes away ... and then Plasma is crashing

The reporter is unsure if this crash is reproducible.

-- Backtrace:
Application: Plasma (plasmashell), signal: Segmentation fault
Content of s_kcrashErrorMessage: std::unique_ptr<char []> = {get() = <optimized out>}
[KCrash Handler]
#6  QString::QString(QString const&) (other=..., this=0x7ffcb9a1e040) at /usr/include/qt5/QtCore/qstring.h:1093
#7  StatusNotifierItemSource::id() const (this=0x0) at /usr/src/debug/plasma5-workspace-5.23.0-2.1.x86_64/applets/systemtray/statusnotifieritemsource.cpp:140
#8  extractItemId (sniData=0x0) at /usr/src/debug/plasma5-workspace-5.23.0-2.1.x86_64/applets/systemtray/systemtraymodel.cpp:284
#9  StatusNotifierModel::data(QModelIndex const&, int) const (this=0x5555bc836e50, index=<optimized out>, role=364) at /usr/src/debug/plasma5-workspace-5.23.0-2.1.x86_64/applets/systemtray/systemtraymodel.cpp:302
#10 0x00007f158f5fca43 in QModelIndex::data(int) const (arole=364, this=0x7ffcb9a1e0a0) at ../../include/QtCore/../../src/corelib/itemmodels/qabstractitemmodel.h:460
#11 QConcatenateTablesProxyModel::data(QModelIndex const&, int) const (this=<optimized out>, index=<optimized out>, role=364) at itemmodels/qconcatenatetablesproxymodel.cpp:195
#12 0x00007f158f609491 in QSortFilterProxyModel::data(QModelIndex const&, int) const (this=<optimized out>, index=..., role=364) at itemmodels/qsortfilterproxymodel.cpp:2294
#13 0x00007f158f609491 in QSortFilterProxyModel::data(QModelIndex const&, int) const (this=<optimized out>, index=..., role=364) at itemmodels/qsortfilterproxymodel.cpp:2294
#14 0x00007f158e576c7f in QModelIndex::data(int) const (arole=364, this=0x7ffcb9a1e1d0) at /usr/include/qt5/QtCore/qabstractitemmodel.h:460
#15 QQmlDMAbstractItemModelData::value(int) const (role=364, this=0x5555bc11d480) at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde29-1.5.x86_64/src/qmlmodels/qqmladaptormodel.cpp:414
#16 QQmlDMCachedModelData::metaCall(QMetaObject::Call, int, void**) (this=0x5555bc11d480, call=<optimized out>, id=<optimized out>, arguments=0x7ffcb9a1e280) at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde29-1.5.x86_64/src/qmlmodels/qqmladaptormodel.cpp:282
#17 0x00007f1590b4eff6 in QQmlPropertyData::readProperty(QObject*, void*) const (property=0x7ffcb9a1e260, target=0x5555bc11d480, this=0x5555bc942018) at ../../include/QtQml/5.15.2/QtQml/private/../../../../../../src/qml/qml/qqmlpropertydata_p.h:357
#18 loadProperty(QV4::ExecutionEngine*, QObject*, QQmlPropertyData const&) (v4=0x5555bacf2330, object=0x5555bc11d480, property=...) at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde29-1.5.x86_64/src/qml/jsruntime/qv4qobjectwrapper.cpp:176
#19 0x00007f1561c5a4b5 in  ()
#20 0x0000000000000000 in  ()
[Inferior 1 (process 3131) detached]

Possible duplicates by query: bug 444171, bug 443961, bug 443923, bug 443352, bug 443059.

Reported using DrKonqi
Comment 1 Nate Graham 2021-10-26 14:06:05 UTC

*** This bug has been marked as a duplicate of bug 443961 ***