Bug 444171 - Plasma crashed when ending keyboard layout switcher plasmoid
Summary: Plasma crashed when ending keyboard layout switcher plasmoid
Status: RESOLVED DUPLICATE of bug 443961
Alias: None
Product: plasmashell
Classification: Unclassified
Component: general (show other bugs)
Version: 5.23.0
Platform: openSUSE RPMs Linux
: NOR crash
Target Milestone: 1.0
Assignee: David Edmundson
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2021-10-21 08:22 UTC by rainer
Modified: 2021-10-21 14:59 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rainer 2021-10-21 08:22:14 UTC
Application: plasmashell (5.23.0)

Qt Version: 5.15.2
Frameworks Version: 5.86.0
Operating System: Linux 5.14.11-1-default x86_64
Windowing System: X11
Distribution: "openSUSE Tumbleweed"
DrKonqi: 5.23.0 [KCrashBackend]

-- Information about the crash:
- What I was doing when the application crashed:
Since the last update an additonal version (?) of the keyboard layout switche shows up in my systray, displaying 2 icons
When I right-click on on of them and select close, plasma crashes (every time I tried)

The crash can be reproduced every time.

-- Backtrace:
Application: Plasma (plasmashell), signal: Segmentation fault
Content of s_kcrashErrorMessage: std::unique_ptr<char []> = {get() = <optimized out>}
[KCrash Handler]
#6  QString::QString(QString const&) (other=..., this=0x7ffddaa07cc0) at /usr/include/qt5/QtCore/qstring.h:1093
#7  StatusNotifierItemSource::id() const (this=0x0) at /usr/src/debug/plasma5-workspace-5.23.0-1.1.x86_64/applets/systemtray/statusnotifieritemsource.cpp:140
#8  extractItemId (sniData=0x0) at /usr/src/debug/plasma5-workspace-5.23.0-1.1.x86_64/applets/systemtray/systemtraymodel.cpp:284
#9  StatusNotifierModel::data(QModelIndex const&, int) const (this=0x557ab1d8fae0, index=<optimized out>, role=364) at /usr/src/debug/plasma5-workspace-5.23.0-1.1.x86_64/applets/systemtray/systemtraymodel.cpp:302
#10 0x00007fb9457f3a43 in QModelIndex::data(int) const (arole=364, this=0x7ffddaa07d20) at ../../include/QtCore/../../src/corelib/itemmodels/qabstractitemmodel.h:460
#11 QConcatenateTablesProxyModel::data(QModelIndex const&, int) const (this=<optimized out>, index=<optimized out>, role=364) at itemmodels/qconcatenatetablesproxymodel.cpp:195
#12 0x00007fb945800491 in QSortFilterProxyModel::data(QModelIndex const&, int) const (this=<optimized out>, index=..., role=364) at itemmodels/qsortfilterproxymodel.cpp:2294
#13 0x00007fb945800491 in QSortFilterProxyModel::data(QModelIndex const&, int) const (this=<optimized out>, index=..., role=364) at itemmodels/qsortfilterproxymodel.cpp:2294
#14 0x00007fb944770c7f in QModelIndex::data(int) const (arole=364, this=0x7ffddaa07e50) at /usr/include/qt5/QtCore/qabstractitemmodel.h:460
#15 QQmlDMAbstractItemModelData::value(int) const (role=364, this=0x557ab4318b60) at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde29-1.5.x86_64/src/qmlmodels/qqmladaptormodel.cpp:414
#16 QQmlDMCachedModelData::metaCall(QMetaObject::Call, int, void**) (this=0x557ab4318b60, call=<optimized out>, id=<optimized out>, arguments=0x7ffddaa07f00) at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde29-1.5.x86_64/src/qmlmodels/qqmladaptormodel.cpp:282
#17 0x00007fb946d45ff6 in QQmlPropertyData::readProperty(QObject*, void*) const (property=0x7ffddaa07ee0, target=0x557ab4318b60, this=0x557ab1eb1da8) at ../../include/QtQml/5.15.2/QtQml/private/../../../../../../src/qml/qml/qqmlpropertydata_p.h:357
#18 loadProperty(QV4::ExecutionEngine*, QObject*, QQmlPropertyData const&) (v4=0x557aafc92940, object=0x557ab4318b60, property=...) at /usr/src/debug/libqt5-qtdeclarative-5.15.2+kde29-1.5.x86_64/src/qml/jsruntime/qv4qobjectwrapper.cpp:176
#19 0x00007fb92a0351d5 in  ()
#20 0x0000000000000000 in  ()
[Inferior 1 (process 6128) detached]

Possible duplicates by query: bug 443961, bug 443923, bug 443059, bug 442244, bug 439721.

Reported using DrKonqi
Comment 1 Nate Graham 2021-10-21 14:59:11 UTC
#7  StatusNotifierItemSource::id() const (this=0x0) at /usr/src/debug/plasma5-workspace-5.23.0-1.1.x86_64/applets/systemtray/statusnotifieritemsource.cpp:140
#8  extractItemId (sniData=0x0) at /usr/src/debug/plasma5-workspace-5.23.0-1.1.x86_64/applets/systemtray/systemtraymodel.cpp:284
#9  StatusNotifierModel::data(QModelIndex const&, int) const (this=0x557ab1d8fae0, index=<optimized out>, role=364) at /usr/src/debug/plasma5-workspace-5.23.0-1.1.x86_64/applets/systemtray/systemtraymodel.cpp:302

*** This bug has been marked as a duplicate of bug 443961 ***