Bug 444107 - Thumbnails frequently missing in Task Manager on Wayland
Summary: Thumbnails frequently missing in Task Manager on Wayland
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Task Manager and Icons-Only Task Manager (show other bugs)
Version: 5.23.1
Platform: Other Linux
: NOR normal
Target Milestone: 1.0
Assignee: Eike Hein
URL:
Keywords: wayland
: 445461 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-10-20 12:50 UTC by Lyubomir
Modified: 2022-01-14 16:21 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.24


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lyubomir 2021-10-20 12:50:19 UTC
SUMMARY
When i move the cursor between/over different apps the thumbnails are frequently missing. I recorded it.

STEPS TO REPRODUCE
Please see the screencast here: https://youtu.be/8yBZ0ucsDC8

EXPECTED RESULT
Thumbnails not missing.

SOFTWARE/OS VERSIONS
Operating System: Kubuntu 21.10
KDE Plasma Version: 5.23.1
KDE Frameworks Version: 5.87.0
Qt Version: 5.15.2
Kernel Version: 5.13.0-20-lowlatency (64-bit)
Graphics Platform: Wayland
Processors: 8 × Intel® Core™ i5-8250U CPU @ 1.60GHz
Memory: 7,6 GiB of RAM
Graphics Processor: Mesa Intel® UHD Graphics 620
Comment 1 Patrick Silva 2021-10-20 20:23:16 UTC
Can reproduce on Arch (Plasma 5.23.1) and neon unstable.
On my systems Plasma even crashes sometimes, as reported in bug 439681.
Comment 2 Fushan Wen 2021-10-24 12:38:43 UTC
Can always reproduce on Wayland.

kf.plasma.quick: Couldn't create KWindowShadow for ToolTipDialog
Comment 3 Nate Graham 2021-11-23 18:55:13 UTC
*** Bug 445461 has been marked as a duplicate of this bug. ***
Comment 4 Nate Graham 2022-01-12 17:50:12 UTC
This should be fixed in Plasma 5.24 with the pipewire buffer size fix recently.
Comment 5 Patrick Silva 2022-01-14 16:21:31 UTC
This bug persists with windows grouped in the task manager.

Operating System: Arch Linux
KDE Plasma Version: 5.23.90
KDE Frameworks Version: 5.90.0
Qt Version: 5.15.2
Graphics Platform: Wayland