Bug 443464 - Kaddressbook does not show any more contacts from google groupware
Summary: Kaddressbook does not show any more contacts from google groupware
Status: RESOLVED DUPLICATE of bug 439285
Alias: None
Product: kaddressbook
Classification: Unclassified
Component: general (show other bugs)
Version: 5.18.1
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-10-08 08:04 UTC by themroc
Modified: 2022-01-17 11:22 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description themroc 2021-10-08 08:04:22 UTC
After upgrading to Kubuntu 21.10, the Google contacts were displayed once in kadressbook.
After another restart, all contacts were gone.
Even when you write an email, the contacts are no longer suggested by Google.

The following output in akonadictl restart:
org.kde.kgapi: Bad request, Google replied ' "Contacts API is being deprecated. Migrate to People API to retain programmatic access to Google Contacts. See https://developers.google.com/people/contacts-api-migration." '
org.kde.pim.google: Got error: KGAPI2::ContactFetchJob(0x555d25884140) "Fehlerhafte Anfrage."
org.kde.kgapi: Bad request, Google replied ' "Contacts API is being deprecated. Migrate to People API to retain programmatic access to Google Contacts. See https://developers.google.com/people/contacts-api-migration." '
org.kde.pim.google: Got error: KGAPI2::ContactFetchJob(0x7f28fc02b210) "Fehlerhafte Anfrage."

Operating System: Kubuntu 21.10
KDE Plasma Version: 5.22.5
KDE Frameworks Version: 5.86.0
Qt Version: 5.15.2
Kernel Version: 5.13.0-16-generic (64-bit)
Graphics Platform: X11
Comment 1 Colin J Thomson 2021-10-08 18:43:44 UTC
I am also seeing this with kaddressbook as well - 5.18.2 (21.08.2)

KDE Plasma Version: 5.22.5
KDE Frameworks Version: 5.86.0
Qt Version: 5.15.2
Comment 2 Colin J Thomson 2021-10-10 11:35:34 UTC
Probably related to this:

https://bugs.kde.org/show_bug.cgi?id=439285
Comment 3 Philippe ROUBACH 2021-10-11 10:58:56 UTC
yesterday(2021/10/10) i return to my home.

I work intensivley with kmail.
Suddenly my contacts disappears in google contacts in kaddressbook.


1. In kaddressbook i delete the google contacts addressbook
then
i add again the google contacts addressbook
then
google calendar is filled with my events but google contact stays empty!


2. In an opensuse 15.3 Virtualbox Machine (a fresh install where I never set anything about kontact)

I add the google contacts addressbook
then
google calendar was filled with my events but google contact stays empty!

I assume something changed to google side about contacts. Now gapi is no more compliant with google contacts.

please it' critical for me. I use intensively kmail. I need a solution rapidly.

SOFTWARE/OS VERSIONS
Windows: 
macOS: 
Linux/KDE Plasma: 
(available in About System)
KDE Plasma Version: 5.22.5
KDE Frameworks Version: 5.86.0
Qt Version: 5.15.2
kde gears 21.08.1

openSuse 15.3
Comment 4 Philippe ROUBACH 2021-10-11 12:02:27 UTC
Do you know a mail client which can use google contacts ?
Comment 5 Philippe ROUBACH 2021-10-11 14:54:07 UTC
I installed Thunderbird 91.2.0 with TbSync and Google-4-TbSync extensions.

I can access to Google contacts.

The extension uses Google People API.

This confirms that kgapi uses an old API which is deprecated.
Comment 6 Philippe ROUBACH 2021-10-11 15:00:55 UTC
I got problems for one year. My problem began on 2020-10-04 !

See https://bugs.kde.org/show_bug.cgi?id=427319

No reaction from kde team. I am very disappointed.
Comment 7 Philippe ROUBACH 2021-10-12 13:54:20 UTC
from this

https://euroquis.nl/kde/2020/01/13/google.html

it is said that kaccounts has no problem. Why kaddressbook does not use kaccounts for accessing to Google resources.

Is there a problem for kaddressbook to use kaccounts instead its own authentication technology ?
Comment 8 Philippe ROUBACH 2021-10-14 09:26:12 UTC
Today a miracle. I got my contacts!

But 4 duplicate contacts, -3 contacts
Comment 9 Kishore Gopalakrishnan 2021-10-15 05:42:29 UTC

*** This bug has been marked as a duplicate of bug 439285 ***