Bug 427319 - less contacts in kaddressbook "my contacts" than in google contacts "contacts"
Summary: less contacts in kaddressbook "my contacts" than in google contacts "contacts"
Status: CONFIRMED
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: Google Resource (show other bugs)
Version: 5.18.1
Platform: OpenSUSE Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Daniel Vrátil
URL:
Keywords:
Depends on: 439285
Blocks:
  Show dependency treegraph
 
Reported: 2020-10-04 09:51 UTC by Philippe ROUBACH
Modified: 2022-08-23 04:17 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe ROUBACH 2020-10-04 09:51:50 UTC
SUMMARY

When updating to 20.08.0

i checked that many contacts disappeared in "my contacts" in kaddressbook.

Happily these contacts were always in google contacts "contacts"

i tried to sync kaddressbook "my contacts" but no effect.

i tried to sync kaddressbook google folder but no effect.

i wait for 60 mn but no effect.

i deleted in kaddressbook my google adressbook then recreate it
then
this time kadressbook "my contacts" get same quantity of contacts than Google contacts "Contacts"

Today i want to send a mail to my brother. In "To" field i type the first name then he does not appear in "my contacts".

Then i go to kaddressbook searching my brother then i did not find him in "my contacts"

I check that in kaddressbook in "my contacts" there are 203 contacts and in google contacts "contacts" there are 289 contacts ! I found my brother.

SOFTWARE/OS VERSIONS
Windows: 
macOS: 
Linux/KDE Plasma: 
(available in About System)
KDE Plasma Version: 5.19.5
KDE Frameworks Version: 5.74.0
Qt Version: 5.15.1


ADDITIONAL INFORMATION

kde apps 20.08.1

For many years I use akonadi google engine to sync contacts and continuously I get problems. How do you explain this ? I am really desperate.
Comment 1 Philippe ROUBACH 2021-07-03 07:24:47 UTC
Again and again. the problem appears cyclically.

Today
- in kaddressbook "my contacts", 207 contacts
- in google "contacts", 301 contacts

kde gear 21.04.2
kde plasma 5.22.2.1
kde frameworks 5.83.0
qt 5.15.2

the sole solution I found is to delete in kaddressbook the google addressbook and to add it again.
Comment 2 Philippe ROUBACH 2021-09-08 08:00:54 UTC
Again and again, less contacts in kaddressbook than in G contacts. 5 contacts disaapeared !


kde gear 20.08.1
plama 5.22.5
framework 5.85.0
qt 5.15.2

i must delete Google addressbook in kaddressbook then add it again to get a good sync.
Comment 3 Axel Braun 2021-09-13 07:55:46 UTC
I can confirm the issue with
Operating System: openSUSE Tumbleweed 20210910
KDE Plasma Version: 5.22.5
KDE Frameworks Version: 5.85.0
Qt Version: 5.15.2
I have less contacts in my local copy of the google address book than on google itself - and a refresh of the address book with F5 does not help
Comment 4 Philippe ROUBACH 2021-10-01 11:02:25 UTC
Again today, 214 contacts instead of 308 !

I made a fresh install of openSuse 15.3 15 days before .

I must delete in kaddressbook the google addressbook then recreate it.

kde gear 21.08.1
plasma 5.22.5
kde frameworks 5.86.0
qt 5.15.2
Comment 5 Philippe ROUBACH 2021-10-07 05:21:57 UTC
Some news.

This day 0 contacts in kaddressbook and 310 contacts in Google contacts

This time with akonadi console, I restarted the Google agent then kaddressbook were populated.

I assume sometime randomly the Google agent stops running or runs badly, then contacts are not synced.
Comment 6 Philippe ROUBACH 2021-10-10 12:16:16 UTC
Suddenly viewing my mails, i can't view them. I get a panel saying i must wait.

I quit kontact

I launch kontact. I get a message saying an app crashed but kontact launched without any problem

I can work with kmail again

but no more google calendar and no more google contacts in kaddressbook.
no more google groupware in akonadi!

I restart the PC

After opening a kde session a strange phenomenon occurs. After a while the google groupware reappeared but google contacts was not populated.

i restarted google agent but google contacts was not populated.

i deleted the google groupware
i created again a google groupware
i get again my google calendar but my google contacts is not populated.
Comment 7 Philippe ROUBACH 2021-10-10 14:49:45 UTC
I created again the google groupware. I get the google calendar, but the contacts are not populated

More I get a problem in kmail with my gmail account authentication (unreadable password).  I used it for several months. i get the problem just after using in "advanced" tab the "automatically detect the connection settings". I solved the problem by using "plain" and enabling "less security" feature in my google account as recommended by Daniel Vràtil.

Today I wonder if the problem with  google contacts sync is an authentication problem like Daniel Vràtil wrote about here 
https://www.dvratil.cz/2019/08/kontact-google-integration-issue/

another hypothesis :

I deleted all Google mail groups excepted "others" for several years. This troubles lbkgapi.
Comment 8 davidkacerek 2022-07-22 19:18:48 UTC
Same issue here. Changes I made to contacts in KAddressBook haven't propagated to GMail. I tried to delete the whole address book and add the new one to no avail - Address Books list is empty. When restarting akonadi, I can see an error in the output: "Bad request, Google replied ' "Contacts API is being deprecated. Migrate to People API to retain programmatic access to Google Contacts. See https://developers.google.com/people/contacts-api-migration." '" I've found out another report with this error: https://bugs.kde.org/show_bug.cgi?id=439285. It looks like the same problem, shouldn't be this report to be marked as a duplicate one of the #439285?

Operating System: openSUSE Leap 15.3
KDE Plasma Version: 5.18.6
KDE Frameworks Version: 5.76.0
Qt Version: 5.12.7