Bug 442343 - Unnecessary text ellipsis with non-integer general font size
Summary: Unnecessary text ellipsis with non-integer general font size
Status: RESOLVED DUPLICATE of bug 432372
Alias: None
Product: systemsettings
Classification: Unclassified
Component: kcm_fonts (show other bugs)
Version: 5.22.4
Platform: Fedora RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-09-12 15:46 UTC by Grzegorz Kowzan
Modified: 2021-09-16 17:10 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Systems settings fonts applet with ellided labels (256.93 KB, image/jpeg)
2021-09-12 15:46 UTC, Grzegorz Kowzan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Grzegorz Kowzan 2021-09-12 15:46:02 UTC
Created attachment 141493 [details]
Systems settings fonts applet with ellided labels

SUMMARY
Text labels in System Settings are partially ellided when general font size is set to a fractional value. 

STEPS TO REPRODUCE
1. Set General font size to a non-integer value in system settings
2. Restart system settings app

OBSERVED RESULT
Some text labels are ellided

EXPECTED RESULT
No unnecessary ellision

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: Fedora 34
KDE Plasma Version: 5.22.4
KDE Frameworks Version: 5.85.0
Qt Version: 5.15.2

ADDITIONAL INFORMATION
Verified that it occurs with a clean user account and a different font family.
Comment 1 Paul Worrall 2021-09-13 11:57:19 UTC
I can reproduce so setting to Confirmed

Operating System: KDE neon Unstable Edition
KDE Plasma Version: 5.22.80
KDE Frameworks Version: 5.86.0
Qt Version: 5.15.3
Kernel Version: 5.11.0-27-generic (64-bit)
Graphics Platform: Wayland
Processors: 2 × AMD A6-6400K APU with Radeon(tm) HD Graphics
Memory: 7.7 GiB of RAM
Graphics Processor: AMD CEDAR
Comment 2 Nate Graham 2021-09-16 17:10:18 UTC

*** This bug has been marked as a duplicate of bug 432372 ***