Bug 441746 - Make Favorites more accessible
Summary: Make Favorites more accessible
Status: RESOLVED DUPLICATE of bug 434904
Alias: None
Product: plasmashell
Classification: Plasma
Component: Application Launcher (Kickoff) (show other bugs)
Version: 5.21.5
Platform: Debian testing Linux
: NOR wishlist
Target Milestone: 1.0
Assignee: David Edmundson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-08-30 08:59 UTC by Valentin Petzel
Modified: 2021-08-30 16:11 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Valentin Petzel 2021-08-30 08:59:27 UTC
Hello,

Most of the times I use Kicker it is to open one of a handful of applications (such as browser, e-mail client, text editor, terminal and such), for which I therefore use the favorites bar.
Kickoff makes it quite hard to access these favorites quickly, because if you click on the application launcher (assuming it is in the bottom left corner) you have the list of categories between your mouse and your favorites. Thus it happens that moving the mouse towards the favorites you change the category. This is quite anoying, as it forces you to move around the mouse a lot to open a common application.

Due to delays this only happens if you move your mouse slowly enough, but still it still happens.

So I suggest some options how this could be solved:
→ Add an option to change category only on click, not on hover (or maybe a system where the hover changuing is unlocked by clicking and locked by clicking again or leaving the list or something)
→ Add an additional delay for activation of a category when you move the mouse into the category list (maybe even configurable?)
→ Add a small favorites bar of some sort to kickoff (one could potentially have a favbar as option for the primary actions bar?)
→ Maybe a system where if you are not in the favorites category the favorites are pushed into a bar on the right side?

While some of these options would probably present an unreasonable amount of work, something like an option to change only on click should be little effort.

Valentin
Comment 1 Nate Graham 2021-08-30 16:11:26 UTC

*** This bug has been marked as a duplicate of bug 434904 ***